Jump to content

Module: AIOM+ (All In One Minify) for CSS, LESS, JS and HTML


David Karich

Recommended Posts

On 24.8.2017 at 3:29 PM, DV-JF said:

Hi,

I switched my site to https and now I can't get AIOM to running. Here are the errors I'm getting:


Mixed Content: The page at 'https://****/' was loaded over HTTPS, but requested an insecure stylesheet 'warning: A non-numeric value encountered in /mnt/****/site/assets/cache/FileCompiler/site/modules/AllInOneMinify/AllInOneMinify.module on line 713/work/roltek/site/assets/aiom/css_b863322778056fb524ea6127cc06763c_dev.css?no-cache=1503581072'. This request has been blocked; the content must be served over HTTPS.
(index):1 Mixed Content: The page at 'https://****/' was loaded over HTTPS, but requested an insecure script 'warning: A non-numeric value encountered in /mnt/****/site/assets/cache/FileCompiler/site/modules/AllInOneMinify/AllInOneMinify.module on line 713/work/roltek/site/assets/aiom/js_656d424f993dafdaf7bd972288171ab2_dev.js?no-cache=1503581072'. This request has been blocked; the content must be served over HTTPS.

When I disable AIOM everything works like it should be. Any ideas?

EDIT: 

In order to debug this error I generated a subdomain without HTTPS encription. Now I get the following error:


Warning: A non-numeric value encountered in /***/site/assets/cache/FileCompiler/site/modules/AllInOneMinify/AllInOneMinify.module on line 713
/site/assets/aiom/js_656d424f993dafdaf7bd972288171ab2_dev.js?no-cache=1503583266

EDIT: 

I've figured out, that the error only happens, when I'm using PHP Ver. 7.1. with PHP Ver. 7.0. everything works like it should be. 

 

Many greets, Jens alias DV-JF

I have the same problem. This is the error in Chrome:

[Deprecation] Resource requests whose URLs contained both removed whitespace (`\n`, `\r`, `\t`) characters and less-than characters (`<`) are blocked. Please remove newlines and encode less-than characters from places like element attribute values in order to load these resources. See https://www.chromestatus.com/feature/5735596811091968 for more details.

Does anybody know how to fix this?

//Solution found:

Change the code in "AllInOneMinify.module" in line 713 to:

            $_timestamp = ((int)$_timestamp + $file['last_modified']);

 

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

I'm thinking of switching from CSS to SCSS in order to use variables. Very useful for example when you want to change colors. Unfortunately the module doesn't minify scss files. Can someone add this feature?

Sorry I'm new to SASS. If I understand correctly I don't need to include a scss file in html.

Link to comment
Share on other sites

  • 2 weeks later...

I really like your module and it is on every site we make.

I found an odd bug when using core page cache and this module; styles not loading correctly and the page looks like there no CSS at all. Most of the sites have no problem, but this happened to maybe five of them. Not very often though. One of them has no page cache, but others do. It's always certain template / page and not the whole site without CSS. All the sites have https on but pages can use both ways.

Link to comment
Share on other sites

  • 1 month later...

Hello @all

I have a problem with integrating external stylesheets into AIOM.

Screenshot(7).thumb.png.67bb38e62a5e900e66541abc4ab75285.png

I have toggled the checkbox to allow stylesheets from outside the template folder, but I always get the following message:

PHP Warning: file_get_contents(): Filename cannot be empty in .../site/modules/AllInOneMinify/AllInOneMinify.module:596

So it doesnt find the external stylesheet wich is located in /node_modules/cookieconsent/build/cookieconsent.min.css.

This is how I have tried to integrate it:

    $stylesheets = [
      '/node_modules/cookieconsent/build/cookieconsent.min.css',
      'css/main.less'
    ];

echo '<link rel="stylesheet" href="'.\AIOM::CSS($stylesheets).'">' . "\n";

Independent if I change the path to

/node_modules/cookieconsent/build/cookieconsent.min.css or

./node_modules/cookieconsent/build/cookieconsent.min.css or

../node_modules/cookieconsent/build/cookieconsent.min.css

there is no difference.

 

Technical data:

AIOM 3.2.3

PHP 7

PW latest dev

 

Is there something else I am missing?

 

Link to comment
Share on other sites

5 hours ago, Juergen said:

 

Independent if I change the path to

/node_modules/cookieconsent/build/cookieconsent.min.css or

./node_modules/cookieconsent/build/cookieconsent.min.css or

../node_modules/cookieconsent/build/cookieconsent.min.css

there is no difference.

 

Did you try this?

../../node_modules/coo...

 

Link to comment
Share on other sites

  • 4 weeks later...

Hello all,

I'm experiencing serious issues when using PW built in template cache together wit AIOM.


When a page is loaded from cache and you then change any of your CSS or JS assets, the rebuilding of the combined/minified versions is not being triggered at all. This explains @anttila's problem mentioned above.

Also when you use the button in the module config screen to clear the asset cache, the template caches are not being cleared. So next time a page is loaded from cache, it will point to old asset files that do not exist anymore.

I also did extensive testing with @matjazp's fork. But same problem there.

After looking at the module code, I think that the problem lies in the module hooking into Page::render. But this never gets called once pages are cached. Please correct me if I'm wrong here.


One possible solution would be to hook into PageRender::renderPage instead. This always gets called for every page request and returns a cached version if available or a fresh Page::render.

I forked @matjazp's version as it seems to be the most up to date and will try to fix these issues...

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Can anyone tell me please, if I load Processwire from another site using 

require('/home/othersite/public_html/wire/core/ProcessWire.php');
$site = new \ProcessWire\ProcessWire('/home/othersite/public_html/site/');

What do I need to change 

<script src="<?php echo AIOM::JS('script.js') ?>" type="text/javascript"></script>

to, in order to get it to work? At the moment it just causes an error.

Link to comment
Share on other sites

25 minutes ago, zoeck said:

Can you tell us the error message?

I couldn't at first til I realised I needed to enable debug on the central site.

Maybe I just need right folder permissions on the folder where the js goes?

Error: Uncaught exception 'ProcessWire\WireException' with message 'The combined js file can not be written. Check if the script has sufficient permissions.' in /home/othersite/public_html/site/modules/AllInOneMinify/AllInOneMinify.module:483
Stack trace:
#0 /home/newsite/public_html/index.php(315): AllInOneMinify::JS('script.js')
#1 {main}
thrown (line 483 of /home/othersite/public_html/site/modules/AllInOneMinify/AllInOneMinify.module) 

Link to comment
Share on other sites

  • 1 month later...

Hello,

I always get this warning with Tracy:

PHP Warning: A non-numeric value encountered in .../site/modules/AllInOneMinify/AllInOneMinify.module:713

This is the line of code:

 $_timestamp = ($_timestamp + $file['last_modified']);

It seems that one of the two values is not in the right format.

Best regards

Link to comment
Share on other sites

  • 2 weeks later...

HELLO, found that AIOM is not compiling the following code which is pretty annoying, if any one knows of any works around that would be great.

Think i got it working now, for some reason i couldnt see it but might have been a caching issue. 😐

@supports(display: grid) {
    .two-up {
        @media screen and (min-width: @small-screen) {
            display: grid;
        }
    }
}

// edit

was given this by @Christophe which was super useful to anyone using css grid

https://www.smashingmagazine.com/2017/06/building-production-ready-css-grid-layout/

"The challenge is Microsoft Edge, the only modern browser that, as of this writing, still uses the old grid specification. It returns true for @supports (display: grid) {}, even though its grid support is spotty and non-standard. Most relevant for our example is the lack of support for the grid-template-areas and grid-area properties and for the minmax() function. As a result, a feature query targeting display: grid would not exclude Microsoft Edge, and users of this browser would be served a broken layout. To resolve this issue and serve up grid layouts to Microsoft Edge only when the browser gets full support for the specification, target one of the unsupported features instead:

@supports (grid-area: auto) {}

Link to comment
Share on other sites

Hi,

I'm struggling with AIOM.

I installed this module and now I want to use my less file. In the head I have this, which doesn't work:

<link rel="stylesheet" type="text/css" href="<?php echo AllInOneMinify::CSS('assets/css/main_design.less'); ?>">
or
<link rel="stylesheet" type="text/css" href="<?php echo AllInOneMinify::CSS('assets/css/main_design.css'); ?>">

This f.e. works:

<link rel="stylesheet" type="text/css" href="<?php echo $config->urls->templates?>assets/css/main_design.css" />

The less file has the same styles like the css file. 

 

The source code shows me this:

<link rel="stylesheet" type="text/css" href="&lt;br /&gt;
&lt;b&gt;Warning&lt;/b&gt;:  A non-numeric value encountered in &lt;b&gt;/www/htdocs/w005e302/physio/site/assets/cache/FileCompiler/site/modules/AllInOneMinify/AllInOneMinify.module&lt;/b&gt; on line &lt;b&gt;713&lt;/b&gt;&lt;br /&gt;
/site/assets/aiom/css_a3d1005d4a254bfaf5c76d729e0773fb_dev.css?no-cache=1530095993">

In the AIOM module configurations, the only thing I did, is the activation of the html-minify and the dev-mode.

 

 

Edited by neophron
solved
Link to comment
Share on other sites

1 hour ago, wbmnfktr said:

Glad it works this way.

You might consider using PW ProCache. It does all this minifying and compiling stuff PLUS awesome and reliable caching. It's paid I know but it's worth every cent.

Thanks for the tip. I'll check this out.

I'm using the ProFields modules and they are worth every penny.

Link to comment
Share on other sites

  • 3 weeks later...

Hum, I working on a website, and as soon as I put the website on my server for testing  (OVH, not a dedicated server)  I have an error saying I don't have the permissions to open the js file ... ?  😞

"You don't have permission to access ... /js_ee2fc073cb5c1c887f4d8e31963c7461_dev.js on this server." 

 

 

 

Link to comment
Share on other sites

  • 3 weeks later...

Hi,

just found an strange bug. If I activate the »HTML minify« option, a simple gallery (uikit v3) with this structure

<ul class="uk-slideshow-items">
        <li class="uk-active uk-transition-active" style="transform: translateX(0px); z-index: 0;">
        	<img src="/site/assets/files/1080/sample01.jpg" uk-cover="" class="uk-cover" style="width: 1828px; height: 934px;">
        </li>
  		. . .
  		. . .
</ul>

is converting into this structure:

<ul class="uk-slideshow-items">
	<li class="uk-active uk-transition-active" style="transform: translateX(0px); z-index: 0;">
		<strong>
			<strong>
			<img src="/site/assets/files/1080/sample01.jpg" uk-cover="" class="uk-cover" style="height: 0px; width: 0px;">
			</strong>
		</strong>
	</li>
    . . .
    . . .
    . . .
</ul>

 

Does it make sense to count on this module for the future? Cause to me it looks like, as if there is no longer support for this module. 
Are there alternative solutions? 

 github.jpg.1c6222933afa1a5758d7287829943b16.jpggithub.jpg.1c6222933afa1a5758d7287829943b16.jpg

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...