Jump to content
justb3a

Module: Image Extra

Recommended Posts

Hey @justb3a

I'm using your module together with matrix some repeaters fields at the moment and get the following notice:

Notice: Undefined index: title in C:\xampp\htdocs\intern\oneslider\site\modules\ImageExtra\ImageExtra.module on line 523

PW: 3.0.62 / ImageExtra: 1.0.6

Share this post


Link to post
Share on other sites
6 hours ago, mauricemoss said:

Hey @justb3a

I'm using your module together with matrix some repeaters fields at the moment and get the following notice:

Notice: Undefined index: title in C:\xampp\htdocs\intern\oneslider\site\modules\ImageExtra\ImageExtra.module on line 523

PW: 3.0.62 / ImageExtra: 1.0.6

Hi @mauricemoss, there's already a PR for this issue here: https://github.com/justb3a/processwire-imageextra/pull/30

I hope @justb3a takes it into account for her next release.

Share this post


Link to post
Share on other sites

I have a sudden problem with this module. The "Image extra fields" don't show up any more. Not on the Edit Page template, nor on the published page itself. There is the caption field enabled and two extra TextInputs. (see the attached image_extra_field_details.png) but they are not visible.

I have done this page for a library more than a year ago and they used it without a problem since then.

On the Page > Home -> Content ->  Edit (an item) which uses this module: there is only the image and a description field (like a normal image field) the other TextInputs are simply gone. (see the image_extra_field_page_edit.png).

Nobody has changed anything what so ever, I have checked the logs to be sure.

The page uses the Image Extra Module 1.0.0 and ProcessWire version 3.0.27

Any idea what the reason could be?

Thanks for any feedback.

P.S.

When I enable debug mode the only notice I get is :

Undefined index: vitrineimages in /home/bla/public_html/wire/modules/ImageExtra.module on line 826

but no error

The Admin->Modules->ImageExtra->Module information page shows:

Title Image Extra
Class ImageExtra
File /wire /modules /ImageExtra.module
Version 1.0.0
Installed 1 year ago
Summary Adds custom fields to image fields (including multi-language support)
Hooks To after.InputfieldImage::getConfigInputfields(), after.InputfieldImage::renderItem(), before.ProcessField::executeSave()
More Information https://github.com/justonestep/processwire-imageextra

 

image_extra_field_details.png

image_extra_field_page_edit.png

Share this post


Link to post
Share on other sites

I have added an additional field called price, which starts with a $ symbol. Every time the page is saved, whether or not there is an output formatter set, an additional \ is added in front of the $ symbol, so if you save say five times you end up with \\\\\$

Share this post


Link to post
Share on other sites

After I installed this, I couldn't upload anything, all images failed to upload and the console output 

Failed to load resource: net::ERR_CONNECTION_RESET

for each. After uninstalling, image uploads work again

ProcessWire ver 3.0.89

Share this post


Link to post
Share on other sites
On 30.10.2017 at 9:35 PM, titanium said:

Hi @mauricemoss, there's already a PR for this issue here: https://github.com/justb3a/processwire-imageextra/pull/30

I hope @justb3a takes it into account for her next release.

@justb3a

Same problem here with an image field in a repeater:

ErrorException: Undefined index: title in C:\laragon\www\XXX\site\modules\ImageExtra\ImageExtra.module:523

PW 3.0.95

Share this post


Link to post
Share on other sites

Hi.
I have a problem with the "link field" and PW 3.0.96 .
When I try to select a page (page tree) the "Choose" button disappears. Unfortunately it is no longer possible to make a selection.

Does anyone have the same problem or a quick solution for it?

I think the error is not the module, but the file "ProcessPageList.js"

Thanks,
Robert

  • Like 2

Share this post


Link to post
Share on other sites
On 3/24/2018 at 4:15 AM, ro-bo said:

Hi.
I have a problem with the "link field" and PW 3.0.96 .
When I try to select a page (page tree) the "Choose" button disappears. Unfortunately it is no longer possible to make a selection.

Does anyone have the same problem or a quick solution for it?

I think the error is not the module, but the file "ProcessPageList.js"

Thanks,
Robert

I'm on PW 3.0.104 and having the same problem.

Share this post


Link to post
Share on other sites
On 8/4/2017 at 1:50 PM, mr-fan said:

just tested with 3.0.65 and it seems that the pagelink field is not working?

imageextra.thumb.jpg.9ee7b8bd45060a8c970cea78bb8f1388.jpg

Best regards mr-fan

 

On 8/7/2017 at 5:22 PM, justb3a said:

Thanks @mr-fan: there was a little bug figuring out, whether the user is working in the backend or not (differentiate between int(0) und false :D ). The belonging JavaScript file wasn't loaded.

Hello, i am experiencing this problem as well. Unfortunately i have to consider myself an absolute beginner so i would be more than happy if someone could explain this solution in more detail. Thanks in advance!

Share this post


Link to post
Share on other sites

Sorry for spaming this thread but i am kinda stuck. As far as i understand this issue has fixed at some point. I only need a solution to apply image-links in pw and from what i read ImageExtra seems the way to go. It will work properly with image-fields but not within repeater-fields. I am using module version 1.0.6 with processwire 3.0.98. Any advise is highly appriciated. 😅

Share this post


Link to post
Share on other sites

Hello,

I'm having the Select button disappearing, so I can't select anything. Is there a fix for this issue?

I'm using last version of the module.

Thanks!

Share this post


Link to post
Share on other sites
14 hours ago, alejandro said:

Hello,

I'm having the Select button disappearing, so I can't select anything. Is there a fix for this issue?

I'm using last version of the module.

Thanks!

Are you by chance using the master instead of develop branch again?

Remember this was fixed on the develop branch:

 

Share this post


Link to post
Share on other sites
9 hours ago, adrian said:

Are you by chance using the master instead of develop branch again?

 

Yes, I upgraded to the latest version. Anyway, I've changed it to repeater field with image + page reference fields, so problem solved.

Share this post


Link to post
Share on other sites

Hey there,

I create all my fields with the Migrations module, so I create all my fields with the core functions.
Sadly, I'm having trouble creating "otherField" information with ImageExtra.

If I try this, the whole field is broken:

$myField = $fields->get('test_field');
$myField->otherField = 'copyright';
$myField->otherFieldSettings = "{\"cf_textformatter\":{\"copyright\":\"\"},\"cf_label\":{\"cf_label__copyright\":\"Copyright\"}}";
$myField->save();

Or with an array:

$myField = $fields->get('test_field');
$myField->otherField = 'copyright';
$myField->otherFieldSettings = [
	'cf_textformatter' => [
		'copyright' => ''
	],
	'cf_label' => [
		'cf_label__copyright' => ''
	]
];
$myField->save();

I always get this error:

ProcessWire: ProcessPageEdit: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'field_test_field.copyright' in 'field list'

 

Has anyone made any experience with this? Suggestions? 🙂

Thanks in advance!

Share this post


Link to post
Share on other sites
17 minutes ago, noodles said:

Hey there,

I create all my fields with the Migrations module, so I create all my fields with the core functions.
Sadly, I'm having trouble creating "otherField" information with ImageExtra.

If I try this, the whole field is broken:


$myField = $fields->get('test_field');
$myField->otherField = 'copyright';
$myField->otherFieldSettings = "{\"cf_textformatter\":{\"copyright\":\"\"},\"cf_label\":{\"cf_label__copyright\":\"Copyright\"}}";
$myField->save();

Or with an array:


$myField = $fields->get('test_field');
$myField->otherField = 'copyright';
$myField->otherFieldSettings = [
	'cf_textformatter' => [
		'copyright' => ''
	],
	'cf_label' => [
		'cf_label__copyright' => ''
	]
];
$myField->save();

I always get this error:


ProcessWire: ProcessPageEdit: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'field_test_field.copyright' in 'field list'

 

Has anyone made any experience with this? Suggestions? 🙂

Thanks in advance!

 

If I see it correctly, the "other field columns" will be added on a save hook via the $input->post data - which I don't have in my case.
In line 1213 it looks like I will have to alter the table in my script. 😞

Damn! 🙂 

Any sweeter way known by someone?

Share this post


Link to post
Share on other sites

I just pulled from the dev branch and still get the same error as before (right after new image upload)

$title = $language->title->getLanguageValue($language); // line 398

Call to a member function getLanguageValue() on string

And also: line 229-231: PHP Warning: stripos() expects parameter 1 to be string, array given

latest PW dev installed, PHP 7.2

Share this post


Link to post
Share on other sites

Hi there,

I set up the Image Extra Fields + multilang support. 

UNF the second language is not showing when switching to the other page language.
It always displays the default language.

Custom field name is "img_title";

Trying to output the field like this:

<?=$page->images->first()->img_title;?>

 

Share this post


Link to post
Share on other sites
On 7/19/2018 at 10:46 AM, alejandro said:

Hello,

I'm having the Select button disappearing, so I can't select anything. Is there a fix for this issue?

I'm using last version of the module.

Thanks!

 

Here is a little fix:

In your templates/admin.php add a custom css file:

$config->styles->add($config->urls->templates . "styles/admin.css");
require($config->paths->adminTemplates . 'controller.php'); 

in templates/styles/admin.css

.PageList .PageListItem:hover .PageListActions {
    display: inline-block !important;
}

Share this post


Link to post
Share on other sites

I really like this module. It's much cleaner for managing different alt-Text and caption than everything I tried before (extra fields, repeater, complex Hanna Code) but I ran into an issue on the second site I installed.

The image field I wanted to enhance was named Bilder (with uppercase). After adding extra field imgcaption the site stopped working and in debug mode it read something like field Bilder.imgcaption doesn't exist. After changing the field name to bilder (lowercase) and correcting my templates and Hanna Code everything worked again. Might be worth some warning in the documentation

  • Like 1

Share this post


Link to post
Share on other sites

I ran into an issue with multilanguage support.

Most sites I'm working need only one language, but for a german user interface I need the module Languages Support which automatically adds a description field for every language to an image field. I used to disable these extra language fields in the admin interface by setting disable multilanguage support in the input settings of the definition for my images-fields. After installing the Image Extra Module I added a caption field, which seemed to work fine: I could edit and process content of this new caption field.

Now I noticed that it is  possible to insert a new caption, but not to alter an existent one. I get a notice that the field was changed, but nothing happens. After checking the database I saw that there was a connection to multi-language support. Instead of a simple entry for new captions like "["Schloss Rheinsberg (Photo: xyz)"] an edited entry is like '{"0":"Das Refektorium","1019":"Das Refektorium"}'
When I enable multi language support for the image field I can see, that only changes in the field for the custom language (in my case german) are processed but do also change the value of the field in the default language (english) This is very confusing for authors.

As a workaround When changing the language of the admin to default instead of german everything works as expected.

Share this post


Link to post
Share on other sites
On 3/14/2019 at 3:18 PM, sujag said:

I ran into an issue with multilanguage support.

Most sites I'm working need only one language, but for a german user interface I need the module Languages Support which automatically adds a description field for every language to an image field. I used to disable these extra language fields in the admin interface by setting disable multilanguage support in the input settings of the definition for my images-fields. After installing the Image Extra Module I added a caption field, which seemed to work fine: I could edit and process content of this new caption field.

Now I noticed that it is  possible to insert a new caption, but not to alter an existent one. I get a notice that the field was changed, but nothing happens. After checking the database I saw that there was a connection to multi-language support. Instead of a simple entry for new captions like "["Schloss Rheinsberg (Photo: xyz)"] an edited entry is like '{"0":"Das Refektorium","1019":"Das Refektorium"}'
When I enable multi language support for the image field I can see, that only changes in the field for the custom language (in my case german) are processed but do also change the value of the field in the default language (english) This is very confusing for authors.

As a workaround When changing the language of the admin to default instead of german everything works as expected.

Yes we have also this problem. only solution is the workaround to set the users language to the default language 😞

Share this post


Link to post
Share on other sites
On 10/30/2017 at 9:35 PM, titanium said:

Hi @mauricemoss, there's already a PR for this issue here: https://github.com/justb3a/processwire-imageextra/pull/30

I hope @justb3a takes it into account for her next release.

I've got the same error here. I use the Image in a Repeater.

Is there any workaround at this time? Although the module works fine, to have an error is annoying.

Thanks for your help!

Share this post


Link to post
Share on other sites
On 3/16/2019 at 5:13 AM, MateThemes said:

I've got the same error here. I use the Image in a Repeater.

Is there any workaround at this time? Although the module works fine, to have an error is annoying.

Thanks for your help!

I have found a solution, that worked for me.

I just put in the module file at line 523 a isset statement:

/**
   * Hook format extra fields
   *
   * @param HookEvent $event
   */
  public function formatExtraValue(HookEvent $event) {
    $page = $event->arguments(0);

    if (!isset ($page->data['title'])) {
      $field = $event->arguments(1);
      $value = $event->arguments(2);
      $settings = $this->getOtherFieldSettings($field);

      if ($settings && $formatters = $settings->cf_textformatter) {
        foreach ($value as $v) {
          foreach ($this->additionalFields['other'][$field->name] as $otherField) {
            if (!array_key_exists($otherField, $formatters)) continue;
            $formatter = $formatters->$otherField;
            $currentValue = $v->$otherField;
            if ($formatter) $this->modules->get($formatter)->formatValue($page, $field, $currentValue);
            $v->$otherField = $currentValue;
          }
        }
      }
    }
  }

And this works for me.

 

Share this post


Link to post
Share on other sites
On 3/20/2019 at 6:39 PM, MateThemes said:

I have found a solution, that worked for me.

I just put in the module file at line 523 a isset statement:


/**
   * Hook format extra fields
   *
   * @param HookEvent $event
   */
  public function formatExtraValue(HookEvent $event) {
    $page = $event->arguments(0);

    if (!isset ($page->data['title'])) {
      $field = $event->arguments(1);
      $value = $event->arguments(2);
      $settings = $this->getOtherFieldSettings($field);

      if ($settings && $formatters = $settings->cf_textformatter) {
        foreach ($value as $v) {
          foreach ($this->additionalFields['other'][$field->name] as $otherField) {
            if (!array_key_exists($otherField, $formatters)) continue;
            $formatter = $formatters->$otherField;
            $currentValue = $v->$otherField;
            if ($formatter) $this->modules->get($formatter)->formatValue($page, $field, $currentValue);
            $v->$otherField = $currentValue;
          }
        }
      }
    }
  }

And this works for me.

 

This issue is solved, because the PR I submitted has now been accepted by @justb3a.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By d'Hinnisdaël
      Happy new year, everybody 🥬
      I've been sitting on this Dashboard module I made for a client and finally came around to cleaning it up and releasing it to the wider public. This is how it looks.
      ProcessWire Dashboard

      If anyone is interested in trying this out, please go ahead! I'd love to get some feedback on it. If this proves useful and survives some real-world testing, I'll add this to the module directory.
      Download
      You can find the latest release on Github.
      Documentation
      Check out the documentation to get started. This is where you'll find information about included panel types and configuration options.
      Custom Panels
      My goal was to make it really simple to create custom panels. The easiest way to do that is to use the panel type template and have it render a file in your templates folder. This might be enough for 80% of all use cases. For anything more complex (FormBuilder submissions? Comments? Live chat?), you can add new panel types by creating modules that extend the DashboardPanel base class. Check out the documentation on custom panels or take a look at the HelloWorld panel to get started. I'm happy to merge any user-created modules into the main repo if they might be useful to more than a few people.
       Disclaimer
      This is a pre-release version. Please treat it as such — don't install it on production sites. Just making sure 🍇
      Roadmap
      These are the things I'm looking to implement myself at some point. The wishlist is a lot longer, but those are the 80/20 items that I probably won't regret spending time on.
      Improve documentation & add examples ⚙️ Panel types Google Analytics ⚙️ Add new page  🔥 Drafts 🔥 At a glance / Page counter 404s  Layout options Render multiple tabs per panel panel groups with heading and spacing between ✅ panel wrappers as grid item (e.g. stacked notices) ✅ Admin themes support AdminThemeReno and AdminThemeDefault ✅ Shortcuts panel add a table layout with icon, title & summary ✅ Chart panel add default styles for common chart types ✅ load chart data from JS file (currently passed as PHP array) Collection panel support image columns ✅ add buttons: view all & add new ✅
    • By Gadgetto
      Status update links (inside this thread) for SnipWire development will be always posted here:
      2020-01-14 --> new date range picker, discount editor, order notifiactions, order statuses, and more ... 2019-11-15 --> orders filter, order details, download + resend invoices, refunds 2019-10-18 --> list filters, REST API improvements, new docs platform, and more ... 2019-08-08 --> dashboard interface, currency selector, managing Orders, Customers and Products, Added a WireTabs, refinded caching behavior 2019-06-15 --> taxes provider, shop templates update, multiCURL implementation, and more ... 2019-06-02 --> FieldtypeSnipWireTaxSelector 2019-05-25 --> SnipWire will be free and open source If you are interested, you can test the current state of development:
      https://github.com/gadgetto/SnipWire
      Please note that the software is not yet intended for use in a production system (alpha version).
      If you like, you can also submit feature requests and suggestions for improvement. I also accept pull requests.
      ---- INITIAL POST FROM 2019-05-25 ----
      I wanted to let you know that I am currently working on a new ProcessWire module that fully integrates the Snipcart Shopping Cart System into ProcessWire. (this is a customer project, so I had to postpone the development of my other module GroupMailer).
      The new module SnipWire offers full integration of the Snipcart Shopping Cart System into ProcessWire.
      Here are some highlights:
      simple setup with (optional) pre-installed templates, product fields, sample products (quasi a complete shop system to get started immediately) store dashboard with all data from the snipcart system (no change to the snipcart dashboard itself required) Integrated REST API for controlling and querying snipcart data webhooks to trigger events from Snipcart (new order, new customer, etc.) multi currency support self-defined/configurable tax rates etc. Development is already well advanced and I plan to release the module in the next 2-3 months.
      I'm not sure yet if this will be a "Pro" module or if it will be made available for free.
      I would be grateful for suggestions and hints!
      Please have a look at the screenshots to get an idea what I'm talking about (open spoiler):
      (Please note: these screenshots are from an early development state of SnipWire. To see actual screens please have a look at later posts below!)
       
    • By Robin S
      This module is inspired by and similar to the Template Stubs module. The author of that module has not been active in the PW community for several years now and parts of the code for that module didn't make sense to me, so I decided to create my own module. Auto Template Stubs has only been tested with PhpStorm because that is the IDE that I use.
      Auto Template Stubs
      Automatically creates stub files for templates when fields or fieldgroups are saved.
      Stub files are useful if you are using an IDE (e.g. PhpStorm) that provides code assistance - the stub files let the IDE know what fields exist in each template and what data type each field returns. Depending on your IDE's features you get benefits such as code completion for field names as you type, type inference, inspection, documentation, etc.
      Installation
      Install the Auto Template Stubs module.
      Configuration
      You can change the class name prefix setting in the module config if you like. It's good to use a class name prefix because it reduces the chance that the class name will clash with an existing class name.
      The directory path used to store the stub files is configurable.
      There is a checkbox to manually trigger the regeneration of all stub files if needed.
      Usage
      Add a line near the top of each of your template files to tell your IDE what stub class name to associate with the $page variable within the template file. For example, with the default class name prefix you would add the following line at the top of the home.php template file:
      /** @var tpl_home $page */ Now enjoy code completion, etc, in your IDE.

      Adding data types for non-core Fieldtype modules
      The module includes the data types returned by all the core Fieldtype modules. If you want to add data types returned by one or more non-core Fieldtype modules then you can hook the AutoTemplateStubs::getReturnTypes() method. For example, in /site/ready.php:
      // Add data types for some non-core Fieldtype modules $wire->addHookAfter('AutoTemplateStubs::getReturnTypes', function(HookEvent $event) { $extra_types = [ 'FieldtypeDecimal' => 'string', 'FieldtypeLeafletMapMarker' => 'LeafletMapMarker', 'FieldtypeRepeaterMatrix' => 'RepeaterMatrixPageArray', 'FieldtypeTable' => 'TableRows', ]; $event->return = $event->return + $extra_types; }); Credits
      Inspired by and much credit to the Template Stubs module by mindplay.dk.
       
      https://github.com/Toutouwai/AutoTemplateStubs
      https://modules.processwire.com/modules/auto-template-stubs/
    • By Mike Rockett
      Jumplinks for ProcessWire
      Release: 1.5.60
      Composer: rockett/jumplinks
      ⚠️ NOTICE: 1.5.60 is an important security patch-release for an XSS vulnerability discovered by @phlp. It's HIGHLY RECOMMENDED that all Jumplinks users update to the latest version as soon as possible.
      Jumplinks is an enhanced version of the original ProcessRedirects by Antti Peisa.
      The Process module manages your permanent and temporary redirects (we'll call these "jumplinks" from now on, unless in reference to redirects from another module), useful for when you're migrating over to ProcessWire from another system/platform. Each jumplink supports wildcards, shortening the time needed to create them.
      Unlike similar modules for other platforms, wildcards in Jumplinks are much easier to work with, as Regular Expressions are not fully exposed. Instead, parameters wrapped in curly braces are used - these are described in the documentation.
      Under Development: 2.0, to be powered by FastRoute
      As of version 1.5.0, Jumplinks requires at least ProcessWire 2.6.1 to run.
      View on GitLab
      Download via the Modules Directory
      Read the docs
      Features
      The most prominent features include:
      Basic jumplinks (from one fixed route to another) Parameter-based wildcards with "Smart" equivalents Mapping Collections (for converting ID-based routes to their named-equivalents without the need to create multiple jumplinks) Destination Selectors (for finding and redirecting to pages containing legacy location information) Timed Activation (activate and/or deactivate jumplinks at specific times) 404-Monitor (for creating jumplinks based on 404 hits) Additionally, the following features may come in handy:
      Stale jumplink management Legacy domain support for slow migrations An importer (from CSV or ProcessRedirects) Feedback & Feature Requests
      I’d love to know what you think of this module. Please provide some feedback on the module as a whole, or even regarding smaller things that make it whole. Also, please feel free to submit feature requests and their use-cases.
      Note: Features requested so far have been added to the to-do list, and will be added to 2.0, and not the current dev/master branches.
      Open Source

      Jumplinks is an open-source project, and is free to use. In fact, Jumplinks will always be open-source, and will always remain free to use. Forever. If you would like to support the development of Jumplinks, please consider making a small donation via PayPal.
      Enjoy! 🙂
    • By Robin S
      Add Image URLs
      Allows images/files to be added to Image/File fields by pasting URLs.

      Usage
      Install the Add Image URLs module.
      A "Paste URLs" button will be added to all image and file fields. Use the button to show a textarea where URLs may be pasted, one per line. Images/files are added when the page is saved.
       
      https://github.com/Toutouwai/AddImageUrls
      https://modules.processwire.com/modules/add-image-urls/
×
×
  • Create New...