Jump to content
justb3a

Module: Image Extra

Recommended Posts

10 hours ago, justb3a said:

One opportunity would be to use a `label` element if it isn't a multilingual site and a `strong` tag if it is one.  What do you think?

Sounds good, thanks.

10 hours ago, justb3a said:

The idea behind this was that some textformatter like "NewLineToBreak" or "NewLineToListItem" doesn't make that much sense applied to an one liner input element.

True, but the textformatter that I'm thinking of is HTML Entity Encoder, which is important for any text field to avoid ambiguous ampersands or other invalid HTML. The string could be manually encoded in the template but more convenient to set-and-forget with a textformatter. :)

Share this post


Link to post
Share on other sites

Hi,

Thanks so much - that makes sense... I've tried to combine the below in a lot of different ways but keep getting an error...

Any ideas?

Thanks

<?php
if ($image->caption){
    //Output markup 1
}
else {
    //Output markup 2
}
?>

<?foreach($page->images as $image) {
 $thumb = $image->width(1040); 
echo "<li><img src='$thumb->url' alt='$image->description'><p class='caption'><strong>{$image->imagetitle}</strong> <em>{$image->imagetext}</em> <span><br>{$image->role}</span></p></li>";}
?>

 

Edited by kongondo
Mod Note: Moved your question to this module's support forum

Share this post


Link to post
Share on other sites

hi!
thanks for this great module!

today I experienced a strange issue when using this module with the Video Fieldtype Module
I get the following error when uploading a video, when the image extra module is installed:

<br />
<b>Notice</b>:  Trying to get property of non-object in <b>/www/htdocs/w00dd152/projekte/jp-relaunch/site/modules/ImageExtra/ImageExtra.module</b> on line <b>722</b><br />
[{"error":false,"message":"Added file: portfolio_screencap_02.mp4","file":"\/jp-relaunch\/site\/assets\/files\/1162\/portfolio_screencap_02.mp4","size":3214711,"markup":"<li id='file_c17b44756649023a42ba014c5b29202c' class='InputfieldFile InputfieldImage InputfieldVideo ui-widget'>\n\t\t<p class='InputfieldFileInfo ui-widget ui-widget-header'>\n\t\t\t<span class='ui-icon ui-icon-arrowthick-2-n-s'><\/span>\n\t\t\t<span class='InputfieldFileName'>portfolio_screencap_02.mp4<\/span> \n\t\t\t<span class='InputfieldFileStats'>• 3,139 kB • <\/span> \n\t\t\t<label class='InputfieldFileDelete'><input type='checkbox' name='delete_video_repeater1162_c17b44756649023a42ba014c5b29202c' value='1' \/><span class='ui-icon ui-icon-trash'>Delete<\/span><\/label>\n\t\t\t<a class='InputfieldFileMove InputfieldFileMoveBottom' href='#'><span class='ui-icon ui-icon-arrowthickstop-1-s'><\/span><\/a> \n\t\t\t<a class='InputfieldFileMove InputfieldFileMoveTop' href='#'><span class='ui-icon ui-icon-arrowthickstop-1-n'><\/span><\/a> \n\t\t<\/p>\n\t\t\t<div class='InputfieldFileDescription'><label for='description_video_repeater1162_c17b44756649023a42ba014c5b29202c' class='detail'>Description<\/label><input type='text' name='description_video_repeater1162_c17b44756649023a42ba014c5b29202c' id='description_video_repeater1162_c17b44756649023a42ba014c5b29202c' value='' \/><\/div>\n\t\t<br \/><label class='InputfieldFileDescription'><span class='detail'>Subtitles<\/span>\n\t\t<br \/><br \/>In templates, you can access this subtitles file (portfolio_screencap_02.srt) using: <code>$page->video->eq(0)->subtitles<\/code><br \/>In templates you can access a formatted transcript (converted from subtitles entered in SRT format), by using: <code>$page->video->eq(0)->transcript<\/code>\n\t\t<br \/><br \/><textarea rows='10' name='subtitles_video_repeater1162_c17b44756649023a42ba014c5b29202c' \/><\/textarea>\n\t\t\t<input class='InputfieldFileSort' type='text' name='sort_video_repeater1162_c17b44756649023a42ba014c5b29202c' value='0' \/>\n\t\t<\/p><\/li>","replace":false,"overwrite":0}]

I testes this in PW 3.0 with the newest versions of both modules installed.
Not sure why its even interfering with the video field..
When I disable the image extra module, everything works fine.

Share this post


Link to post
Share on other sites

@jploch - I'd like to see a dump of $event after line 718 because $field is not an object and it should be.

That said, a quick fix might be to change the hook on line 97 to:

InputfieldImage::processInputFile

 

  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, adrian said:

@jploch - I'd like to see a dump of $event after line 718 because $field is not an object and it should be.

That said, a quick fix might be to change the hook on line 97 to:


InputfieldImage::processInputFile

 

Thx! this fixed it for me

  • Like 1

Share this post


Link to post
Share on other sites

@Jon E 

Just use the comparison inside the foreach loop:

foreach ($page->images as $image) {
  $caption = '';
  if ($image->imagetitle) {
    $caption = "<p class='caption'>{$image->imagetitle}</p>";
  }

  echo "<li><img src='{$image->width(1040)->url}' alt='{$image->description}'>$caption</li>";
}

Or if you want to combine multiple parts: you can check every extra field individually and concatenate the caption before outputting it.

foreach ($page->images as $image) {
  $caption = '';
  if ($image->imagetitle) $caption .= "<strong>{$image->imagetitle}</strong>";
  if ($image->imagetext) $caption .= "<em>{$image->imagetext}</em>";
  if ($image->role) $caption .= "<span>{$image->role}</span>";
  if ($caption) $caption = "<p class='caption'>$caption</p>";

  echo "<li><img src='{$image->width(1040)->url}' alt='{$image->description}'>$caption</li>";
}

 

  • Like 1

Share this post


Link to post
Share on other sites

New Version 1.0.4:

@Robin S  use label tag if it isn't a multilangual site

@jploch, @adrian changed hook InputfieldFile::processInputFile to InputfieldImage::processInputFile

  • Like 5

Share this post


Link to post
Share on other sites

Hi there! And, as always, thanks for a perfect product!

Would like to discuss an interesting case. Let's suppose we have some images attached to different pages, each image having some extra fields including uid field which is unique. We have to build an api page which should receive requests like /api?uid=efv97yg and it should return some JSON about the image with that uid.

Is there any possibility to find an image by its extrafield value (e.g. uid)? Well, i know that we can do something like this:

$pages_ = $pages->find('template=page_with_fotos');
foreach($pages_ as $page_)
	{
	$images = $page_->images;
	foreach($images as $image)
		{
		if($image->uid !== $uid) continue;
		$json = json_encode($image);
		break;
		}
	}
echo $json;

But its not very elegant.

And even worse:

$sql = "select * from field_foto where uid=$uid";
$query = $database->prepare($sql);
$query->execute();
...

What is on my wishlist:

//pseudocode, will NOT work for sure!

$foto = $field_fotos->get("uid=$uid");
...

Will appreciate any advice. Thanks!

Share this post


Link to post
Share on other sites

Just used this module for adding a video link to images. There was a glitch that there was no indication on the thumbnails whether there is a link added or not, so I put together a small js/css combo to add an icon:

has-video.thumb.gif.6e88144313e59ece60e44535eb9dda44.gif

Here is the corresponding code - dirty but works :)

Spoiler

var fieldname = 'video_url_project_images';

function updateVideoItems() {

    $('.gridImage__hover.has-video').removeClass('has-video');

    $('input[id*="video_url_project_images"][value!=""]').each(function() {

        var $item = $(this),
            seekId = $item.attr('id').replace(fieldname, 'file'),
            $target = $('#' + seekId);

        if($target.length) {
            $target.find('.gridImage__hover').addClass('has-video');
        }
    });
}

$(document).ready(function() {
    updateVideoItems();
});

$(document).on('keyup change', 'input[id*="' + fieldname + '"]', function() {
    updateVideoItems();
});

.gridImage__hover.has-video .gridImage__inner::after {
    content: "";
    position: absolute;
    right: 2px;
    bottom: 2px;
    width: 30px;
    height: 30px;
    background: #333 url('/site/templates/images/icons/play-circle.svg') center center no-repeat;
    background-size: 30px;
    border-radius: 100%;
    border: 2px solid white;
    background-clip: content-box;
}

 

 

  • Like 1

Share this post


Link to post
Share on other sites

There are two different ways to get the label of any input Field:

echo "This is the field label: {$page->fields->get("simple_slider")->label}";
echo "This is the field label: {$page->fields->get("simple_slider")->getLabel()}";

Let's pretend I added to my image field an extra field "location" with the label "This was in:". So if I want the value of the "location" field I do it like this:

echo "This is was in: {$page->simple_slider->location}";
// Outputs "Barcelona"

How can I get the LABEL of the location field?

Something like:

// not working code:
echo "{$page->fields->get("simple_slider")->location->getLabel()}: {$page->simple_slider->location}";
// Should output "This was in: Barcelona"

 

Share this post


Link to post
Share on other sites

Hi,

since extra fields aren't regular ProcessWire fields you cannot access the labels using `->getLabel()` method or `->label` property.
The extra field labels are saved in the regarding field settings (table fields, column data) using json and looks like this:

{"otherFieldSettings":"{\"cf_label\":{\"cf_label__location\":\"Location\",\"cf_label__location__1012\":\"Ort\",\"cf_label__custom__1013\":\"Paikka\"}}"}

You can get the label using this functionality:

$fieldSettings = $fields->get('images')->otherFieldSettings;
$settings = json_decode($fieldSettings);
echo $settings->cf_label->cf_label__location;

As you can see there is no error handling or fallback strategy. Therefore I updated the module and added a method called getExtraLabel()

Usage example:

// outputs something like: "Location: Munich"
echo $image->getExtraLabel('location') . ': ' . $image->location;

// outputs something like: "Ort: München"
echo $image->getExtraLabel('location', 'de') . ': ' . $image->location;


 

  • Like 3

Share this post


Link to post
Share on other sites

just tested with 3.0.65 and it seems that the pagelink field is not working?

imageextra.thumb.jpg.9ee7b8bd45060a8c970cea78bb8f1388.jpg

Best regards mr-fan

Share this post


Link to post
Share on other sites

Thanks @mr-fan: there was a little bug figuring out, whether the user is working in the backend or not (differentiate between int(0) und false :D ). The belonging JavaScript file wasn't loaded.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for this great module and for fixing so fast...often when it come to the javascript debuging i'm a little lost...;)

best regards mr-fan

Share this post


Link to post
Share on other sites

Thank you for the module!

I'm using it to add a Markdown enhanced captions for some blog images. I have a problem - the text is processed by the Mardown module only for the first image (in ProcessWire 3.0.72 multi language).
Could someone give me a hint about where to look, please? I'm stumped.
I'm retrieving them like this:

<?php foreach (pages('parent=8888') as $item) { ?>

    <div>
        <div class="uk-card uk-card-default">

            <?php if (count($item->images)) {
                      $item_image = $item->images->getRandom(); ?>

                <div class="uk-card-media-top">
                    <figure>
                        <img src="<?=$item_image->size(580, 384, ['quality' => 75])->url?>"
                             title="<?=$item_image->description?>"
                             alt="<?=$item_image->description?>">
                        <figcaption class="uk-text-meta uk-padding uk-padding-remove-vertical"><?=$item_image->caption?></figcaption>
                    </figure>
                </div>

            <?php } ?>

            <div class="uk-card-body">
                <h3 class="uk-card-title"><a href="<?=$item->url?>" title=""><?=$item->title?></a></h3>
                <p><?=$item->summary?></p>
            </div>
        </div>
    </div>

<?php } ?>

2017-08-21_150736.png

Share this post


Link to post
Share on other sites

OK, found the culprit, is the static variable

$alreadyFormatted

which is set to true at line 527 (module version 106):

525  public function formatExtraValue(HookEvent $event) {
526    if (!self::$alreadyFormatted) {
527      self::$alreadyFormatted = true;

I don't know its purpose, but in my case (a loop retrieving captions for an image from every blog post) it stops the text formatter from processing any item after the first one. So I commented it out, I'll see if anything goes wrong.

Share this post


Link to post
Share on other sites

@geedamed I took me some time but I figured out, what the problem might be. I found a fix, but I do not understand exactly why this is happening. So if anybody could explain this behaviour, feel free to share it :)

 I added the `already formatted` check because in some cases the formatter was called twice (which could break the output). Let's define `in some cases`:

  • images are outputted on the same page as saved to
  • it just counts for the first/one image field

I compared the passed HookEvents. The only difference was that in the first argument, which contains the current Page object, the page title was missing.
So I added a check whether the Page object does contain a title, otherwise skip the formatter. I tested different cases (multiple images, multiple image fields, output from another page and so on). Seems to work – or every extra field the formatter is only called once. 

Share this post


Link to post
Share on other sites

Hi @justb3a I just found your module and I was wondering if you could add a cropping option field with all of it's values: northwest, north, northeast, west, center, east, southwest, south, southeast.

Share this post


Link to post
Share on other sites

Very useful Module.

Is there a way to hide / unpublish a single image temporarily instead of deleting (trashing) the entire image + information?

A checkbox for this would be great.

Thank you.

Share this post


Link to post
Share on other sites
On 03/09/2017 at 11:43 PM, PWaddict said:

Hi @justb3a I just found your module and I was wondering if you could add a cropping option field with all of it's values: northwest, north, northeast, west, center, east, southwest, south, southeast.

@PWaddict: There is already a module for cropping images: CroppableImage3

On 04/09/2017 at 10:29 PM, theo said:

Very useful Module.

Is there a way to hide / unpublish a single image temporarily instead of deleting (trashing) the entire image + information?

A checkbox for this would be great.

Thank you.

@theo: Actually the core/module do support it in a way that's not immediately obvious or as straightforward as checking a checkbox, but it's still quite useful and worthwhile when you need the capability. You could use tags or any other image extra field to achieve this. 

  1. Edit any existing files/images field, or create a new one.

  2. When editing the field settings,  check the box to enable “tags”, or create a new extra field named “hidden“ or something like that.

  3. In the “tags” or “hidden“ field for the image (which should be unpublished), enter a specific phrase like “hidden" (tags field)  or “1“ (hidden field).

  4. Now you need to check if the file should be shown on the front-end of your site. Here's how you do that:

// tag usage example
if (!$image->hasTag('hidden')) echo "<img src='$image->url' alt=''>";

// extra field hidden example
if (!$image->hidden) echo "<img src='$image->url' alt=''>";

 

You could also send a feature request to add this as a core feature (so you do not need to check manually whether the image is hidden and as an extra bonus the hidden images would be visible at first glance using opacity to indicate that).

  • Like 1

Share this post


Link to post
Share on other sites

seem to be getting a number "1" added to the first custom field for some reason.

59d3bbcce690a_Screenshot2017-10-0317_31_24.thumb.png.c6f7c7fb138555d259877d812c706cd3.png

Share this post


Link to post
Share on other sites

I'm having an issue with the module. When I add an additional field to an existing image field and try to edit the page I get an error like:

SQLSTATE[42S22]: Column not found: 1054 Unknown column 'field_headerImage.title' in 'field list'

I get a similar but more verbose error on the frontend trying to view the page.

Removing the additional field resumes normal behaviour for the page.

I have other fields that I've added a title field to that work fine, so it's worked in the past, and image fields that already have custom fields have no problem, but I can't add more.

I'm working with the latest build of PW (3.0.79)

Share this post


Link to post
Share on other sites
On 17/02/2016 at 9:33 PM, justb3a said:

Could you please try to rename the field so that it doesn't contain camelCase (capital letters)? For example field_backgroundImages to field_background_images. Have a look at the description: "Any combination of ASCII letters [a-z], numbers [0-9], or underscores (no dashes or spaces)."

Please rename headerImage to header_image (or something like this) and try again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mike Rockett
      Jumplinks for ProcessWire
      Release: 1.5.56
      Composer: rockett/jumplinks
      Jumplinks is an enhanced version of the original ProcessRedirects by Antti Peisa.
      The Process module manages your permanent and temporary redirects (we'll call these "jumplinks" from now on, unless in reference to redirects from another module), useful for when you're migrating over to ProcessWire from another system/platform. Each jumplink supports wildcards, shortening the time needed to create them.
      Unlike similar modules for other platforms, wildcards in Jumplinks are much easier to work with, as Regular Expressions are not fully exposed. Instead, parameters wrapped in curly braces are used - these are described in the documentation.
      Under Development: 2.0, to be powered by FastRoute
      As of version 1.5.0, Jumplinks requires at least ProcessWire 2.6.1 to run.
      View on GitLab
      Download via the Modules Directory
      Read the docs
      Features
      The most prominent features include:
      Basic jumplinks (from one fixed route to another) Parameter-based wildcards with "Smart" equivalents Mapping Collections (for converting ID-based routes to their named-equivalents without the need to create multiple jumplinks) Destination Selectors (for finding and redirecting to pages containing legacy location information) Timed Activation (activate and/or deactivate jumplinks at specific times) 404-Monitor (for creating jumplinks based on 404 hits) Additionally, the following features may come in handy:
      Stale jumplink management Legacy domain support for slow migrations An importer (from CSV or ProcessRedirects) Feedback & Feature Requests
      I’d love to know what you think of this module. Please provide some feedback on the module as a whole, or even regarding smaller things that make it whole. Also, please feel free to submit feature requests and their use-cases.
      Note: Features requested so far have been added to the to-do list, and will be added to 2.0, and not the current dev/master branches.
      Open Source

      Jumplinks is an open-source project, and is free to use. In fact, Jumplinks will always be open-source, and will always remain free to use. Forever. If you would like to support the development of Jumplinks, please consider making a small donation via PayPal.
      Enjoy! :)
    • By BitPoet
      As threatened in Ryan's announcement for 3.0.139, I built a little module for sliding toggles as a replacement for checkboxes. Styling of the input is CSS3 only (with all the usual caveats about older browsers), no JS necessary, and may still be a bit "rough around the edges", so to speak, since I didn't have much time for testing on different devices or brushing things up enough so I'd feel comfortable pushing it to the module directory. But here's the link to the GitHub repo for now:
      InputfieldSlideToggle
      Fieldtype and Inputfield that implements smartphone-style toggles as replacement for checkbox inputs. The visualization is CSS-only, no additional JS necessary.
      Status
      Still very alpha, use with caution!
      Features / Field Settings
      Size
      You can render the toggles in four different sizes: small, medium, large and extra large.
      Off Color
      Currently, "unchecked" toggles can be displayed either in grey (default) or red.
      On Color
      "Checked" toggles can be rendered in one of these colors: blue (default), black, green, grey, orange or red.
      Screenshots

      Some examples with checkbox label


      View all Size and Color Combinations
      Small toggles Medium toggles Big toggles Extra big toggles  









    • By Orkun
      Hi Guys
      I needed to add extended functionalities for the InputfieldDatetime Module (module is from processwire version 2.7.3) because of a Request of Customer.
      So I duplicated the module and placed it under /site/modules/.
      I have added 3 new Settings to the InputfieldDatetime Module.
      1. Day Restriction - Restrict different days based on weekdays selection (e.g. saturday, sunday) - WORKING

       
      2. Time Slots - Define Time slots based on custom Integer Value (max is 60 for 1 hour) - WORKING

       
      3. Time Range Rules per Weekday - Define a minTime and MaxTime per Weekday (e.g. Opening Hours of a Restaurant) - NOT WORKING PROPERLY

       
      The Problem
      Time Slots and Day Restriction working fine so far. But the Time Range Rules per Weekday doesn't work right.
      What should happen is, that when you click on a date, it should update the minTime and maxTime of the Time Select.
      But the change on the select only happens if you select a date 2 times or when you select a date 1 time and then close the datepicker and reopen it again.
      The time select doesn't get change when you select a date 1 time and don't close the picker.
      Here is the whole extended InputfieldDatetime Module.
      The Files that I have changed:
      InputfieldDatetime.module InputfieldDatetime.js jquery-ui-timepicker-addon.js (https://trentrichardson.com/examples/timepicker/) - updated it to the newest version, because minTime and maxTime Option was only available in the new version  
      Thats the Part of the JS that is not working correctly:
      if(datetimerules && datetimerules.length){ options.onSelect = function(date, inst) { var day = $(this).datetimepicker("getDate").getDay(); day = day.toString(); var mintime = $(this).attr('data-weekday'+day+'-mintime'); var maxtime = $(this).attr('data-weekday'+day+'-maxtime'); console.log("weekday: "+day); console.log("minTime: "+mintime); console.log("maxTime: "+maxtime); var optionsAll = $(this).datetimepicker( "option", "all" ); optionsAll.minTime = mintime; optionsAll.maxTime = maxtime; $(this).datetimepicker('destroy'); $(this).datetimepicker(optionsAll); $(this).datetimepicker('refresh'); //$.datepicker._selectDate($(this).attr("id"),date); //$.datepicker._base_getDateDatepicker(); // var inst = $.datepicker._getInst($(this)); // $.datepicker._updateDatepicker(inst); /*$(this).datetimepicker('destroy'); InputfieldDatetimeDatepicker($(this), mintime, maxtime); $(this).datetimepicker('refresh'); */ // $(this).datetimepicker('option', {minTime: mintime, maxTime: maxtime}); } } Can you have a look and find out what the Problem is?
      InputfieldDatetime.zip
       
      Kind Regards
      Orkun
    • By teppo
      This module tracks changes, additions, removals etc. of public (as in "not under admin") pages of your site. Like it's name says, it doesn't attempt to be a version control system or anything like that - just a log of what's happened.
      At the moment it's still a work in progress and will most likely be a victim of many ruthless this-won't-work-let's-try-that-instead cycles, but I believe I've nailed basic functionality well enough to post it here.. so, once again, I'll be happy to hear any comments you folks can provide
      https://modules.processwire.com/modules/process-changelog/
      https://github.com/teppokoivula/ProcessChangelog
      How does it work?
      Exactly like it's (sort of) predecessor, Process Changelog actually consists of two modules: Process Changelog and Process Changelog Hooks. Hooks module exists only to serve main module by hooking into various functions within Pages class, collecting data of performed operations, refining it and keeping up a log of events in it's own custom database table (process_changelog.) Visible part is managed by Process Changelog, which provides users a (relatively) pretty view of the contents of said log table.
      How do you use it?
      When installed this module adds new page called Changelog under Admin > Setup which provides you with a table view of collected data and basic filtering tools See attached screenshots to get a general idea about what that page should look like after a while.
      For detailed installation instructions etc. see README.md.
       


    • By Gadgetto
      Status update links (inside this thread) for SnipWire development will be always posted here:
      2019-08-08
      2019-06-15
      2019-06-02
      2019-05-25
      If you are interested, you can test the current state of development:
      https://github.com/gadgetto/SnipWire
      Please note that the software is not yet intended for use in a production system (alpha version).
      If you like, you can also submit feature requests and suggestions for improvement. I also accept pull requests.
      ---- INITIAL POST FROM 2019-05-25 ----
      I wanted to let you know that I am currently working on a new ProcessWire module that fully integrates the Snipcart Shopping Cart System into ProcessWire. (this is a customer project, so I had to postpone the development of my other module GroupMailer).
      The new module SnipWire offers full integration of the Snipcart Shopping Cart System into ProcessWire.
      Here are some highlights:
      simple setup with (optional) pre-installed templates, product fields, sample products (quasi a complete shop system to get started immediately) store dashboard with all data from the snipcart system (no change to the snipcart dashboard itself required) Integrated REST API for controlling and querying snipcart data webhooks to trigger events from Snipcart (new order, new customer, etc.) multi currency support self-defined/configurable tax rates etc. Development is already well advanced and I plan to release the module in the next 2-3 months.
      I'm not sure yet if this will be a "Pro" module or if it will be made available for free.
      I would be grateful for suggestions and hints!
      (please have a look at the screenshots to get an idea what I'm talking about)
       




×
×
  • Create New...