Jump to content

Auto Template Stubs


Robin S
 Share

Recommended Posts

This module is inspired by and similar to the Template Stubs module. The author of that module has not been active in the PW community for several years now and parts of the code for that module didn't make sense to me, so I decided to create my own module. Auto Template Stubs has only been tested with PhpStorm because that is the IDE that I use.

Auto Template Stubs

Automatically creates stub files for templates when fields or fieldgroups are saved.

Stub files are useful if you are using an IDE (e.g. PhpStorm) that provides code assistance - the stub files let the IDE know what fields exist in each template and what data type each field returns. Depending on your IDE's features you get benefits such as code completion for field names as you type, type inference, inspection, documentation, etc.

Installation

Install the Auto Template Stubs module.

Configuration

  • You can change the class name prefix setting in the module config if you like. It's good to use a class name prefix because it reduces the chance that the class name will clash with an existing class name.

  • The directory path used to store the stub files is configurable.

  • There is a checkbox to manually trigger the regeneration of all stub files if needed.

Usage

Add a line near the top of each of your template files to tell your IDE what stub class name to associate with the $page variable within the template file. For example, with the default class name prefix you would add the following line at the top of the home.php template file:

/** @var tpl_home $page */

Now enjoy code completion, etc, in your IDE.

stubs

Adding data types for non-core Fieldtype modules

The module includes the data types returned by all the core Fieldtype modules. If you want to add data types returned by one or more non-core Fieldtype modules then you can hook the AutoTemplateStubs::getReturnTypes() method. For example, in /site/ready.php:

// Add data types for some non-core Fieldtype modules
$wire->addHookAfter('AutoTemplateStubs::getReturnTypes', function(HookEvent $event) {
    $extra_types = [
        'FieldtypeDecimal' => 'string',
        'FieldtypeLeafletMapMarker' => 'LeafletMapMarker',
        'FieldtypeRepeaterMatrix' => 'RepeaterMatrixPageArray',
        'FieldtypeTable' => 'TableRows',
    ];
    $event->return = $event->return + $extra_types;
});

Credits

Inspired by and much credit to the Template Stubs module by mindplay.dk.

 

https://github.com/Toutouwai/AutoTemplateStubs
https://modules.processwire.com/modules/auto-template-stubs/

  • Like 12
  • Thanks 3
Link to comment
Share on other sites

Brilliant! I never got into the habit of using Template Stubs (mostly since at the time I didn't use an IDE that would've benefitted from it) but I'm definitely going to give this module a try now 🙂

One thing I'm wondering, though, is the directory for the stubs. Unless I'm misreading this, currently it needs to be under the AutoTemplateStubs module directory?

This is a bit of a problem for me: first of all (as a matter of principle, mostly due to security concerns) I never allow PHP to write into the modules directory, so this would require some tweaking on a per-directory basis – and second of all it would force me to run these files through version control and a deploy process (which could also be seen as a good thing, but for the time being I would prefer to avoid that).

Would you consider adding a config setting for storing these files somewhere else? That "somewhere else" could be a folder under cache, perhaps /site/assets/cache/AutoTemplateStubs/.

  • Like 4
Link to comment
Share on other sites

Note for PHPStorm users: In my case the AutoTemplateStubs directory was automatically marked as excluded (don't know from which setting this comes from) and I had to mark the directory as "not excluded" to make autocompletition work.

  • Like 1
Link to comment
Share on other sites

At first I set the prefix to "stub_" and no(!) AutoTemplateStubs folder was created at all. Afterwards I uninstalled the module and installed it again. This time I left the prefix at the default "tpl_" setting and now I have the AutoTemplateStubs with the php files in it. So now it works.

However, AutoTemplateStubs being in the cache folder, I cannot set the whole cache folder to be excluded, which I have been setting so far so I do not accidentally start editing a template cache file, for example. I do a lot of global search so excluding the cache folder is a must.

Can't you make it optional where the AutoTemplateStubs folder is created?

EDIT: actually I usually mark /site/assets folder to be excluded, not just /site/assets/cache

Edited by szabesz
Link to comment
Share on other sites

3 minutes ago, dragan said:

did you re-scan your project with PHPStorm?

I did not. How can one do that? 🙂

Anyways, I have just figured out what the issue might have been: my workflow is that I install modules on the production site, configure it and afterwards clone the db and sync files to my local environment. However, I did not clone the AutoTemplateStubs folder from production to local because the cache folder is excluded in that case too.

So storing AutoTemplateStubs in /site/assets/cache makes it a pain for me to use the module 😞

Link to comment
Share on other sites

7 minutes ago, szabesz said:

I did not. How can one do that?

in the upper left corner you have a reload-icon. "reload all from disk" shows on hover.

Another way is to simply restart PHPStorm. Usually the IDE is then re-scanning / looking for changes.

I don't know what IDE plugins I've been installing in the last couple of months, but I'm quite happy with how PHPStorm is doing autosuggest. Far from perfect though... ideally it would only show suggestions that make sense in the context (show only applicable methods). It would be nice to have a keyboard shortcut to only show page fields or something like that.

phpstorm-pw-autosuggest2.gif.476c65cf7f68f8faaa059721d62a776b.gif

  • Like 1
Link to comment
Share on other sites

5 minutes ago, dragan said:

in the upper left corner you have a reload-icon. "reload all from disk" shows on hover.

Upper left corner of what? I cannot find it. This topic says it is obsolete and removed: https://intellij-support.jetbrains.com/hc/en-us/community/posts/207066455-Where-is-Reload-from-Disk-option- ???
yeah it's about IntelliJ but such things are usually the same in Jetbrains apps.

However, I do have "File > Invalidate Caches / Restart..." menu. BTW, in may experiences, any external changes are detected by PhpStorm.

Link to comment
Share on other sites

5 minutes ago, szabesz said:

Upper left corner of what?

in the upper left corner of PHPStorm's toolbar. From left to right I see:

  1. open
  2. save all floppy icon
  3. reload from disk

v. 2019.3.1

btw, that topic you linked... is more than 5 years old 🙂

Link to comment
Share on other sites

7 minutes ago, szabesz said:

BTW, in may experiences, any external changes are detected by PhpStorm.

true, but sometimes I have to use that button (especially when adding a new project, and the directory list is not up-to-date, but also elsewhere...)

  • Like 1
Link to comment
Share on other sites

3 hours ago, szabesz said:

Anyways, I have just figured out what the issue might have been: my workflow is that I install modules on the production site, configure it and afterwards clone the db and sync files to my local environment. However, I did not clone the AutoTemplateStubs folder from production to local because the cache folder is excluded in that case too.

So storing AutoTemplateStubs in /site/assets/cache makes it a pain for me to use the module 😞

I think providing an option for this would indeed be sensible 🙂

While testing the module I found it quite simple to regenerate the template stubs content on the local environment – this way there's no real need to sync stub files, and if you've got a full environment locally you can do this just by changing the prefix for something else and then restoring the old value. I'm currently running a slightly modified version of the module with a regenerate option in module config; seemed like a good idea at first, but not sure anymore. Might send a PR and let Robin decide 😅

Also, just in case there are other VSCode users here, a couple of pointers for getting things up and running:

  • If you've excluded the /site/assets/cache/ directory (I had), you'll have to change the exclude setting. Sadly VSCode doesn't support full glob syntax, but ignoring everything except certain subdirectories is still doable with a hacky workaround (more discussion here) :
    "files.exclude": {
        "**/site/assets/cache/{[^A],?[^u],??[^t],???[^o],????[^T],?????[^e],??????[^m],???????[^p],????????[^l]}*": true,
    },
  • Suggested syntax for var (/* @var tpl_basic_page $page */) won't work, since VSCode expects valid PHPDoc syntax. Use /** @var tpl_basic_page $page */ instead.

I'm using the PHP Intelephense plugin (bmewburn.vscode-intelephense-client), and after resolving aforementioned inconveniences things are working just fine 🙂

Edit: sent a PR for the regenerate stubs option (https://github.com/Toutouwai/AutoTemplateStubs/pull/4).

Edited by teppo
  • Like 4
Link to comment
Share on other sites

3 minutes ago, teppo said:

While testing the module I found it quite simple to regenerate the template stubs content on the local environment – this way there's no real need to sync stub files, and if you've got a full environment locally you can do this just by changing the prefix for something else and then restoring the old value. I'm currently running a slightly modified version of the module with a regenerate option in module config; seemed like a good idea at first, but not sure anymore. Might send a PR and let Robin decide

Thanks for the info, however, I find your explanation a bit confusing and I'm not sure I follow...

4 minutes ago, teppo said:

I think providing an option for this would indeed be sensible 🙂

Thanks for supporting the idea!

Link to comment
Share on other sites

7 minutes ago, szabesz said:

Thanks for the info, however, I find your explanation a bit confusing and I'm not sure I follow...

If the issue is that stub files are not being synced from the server to your local environment, you can just go to the module config on your local develoment site and change the class prefix to something else (say, tpl2_) and then restore it to whatever it was (such as tpl_). Every time you change this variable stub files are removed and then recreated, so this way you can force the module to create local stub files for you.

Does that make sense? 🙂

  • Like 1
Link to comment
Share on other sites

12 hours ago, erikvanberkum said:

One thing i have some templates files named _main.php, it seems that templates that start with and underscore are not generated in the AutoTemplateStubs directory.

I just tested this by creating a new template named "_test" and the stub file was created normally. I can't think of any reason why a template name starting with an underscore would behave differently with this module.

It's common to create a file named "_main.php" that is auto-appended to template files if you are using a delayed output strategy, but in that case the file does not correspond to any PW template. Maybe that's the case for you. Are you sure you actually have a template named "_main" in Setup > Templates? 

Link to comment
Share on other sites

IMPORTANT NOTICE TO ALL USERS OF THIS MODULE!

I just discovered that the uninstall routine in v0.2.0 can inadvertently delete directories that it shouldn't depending on the module configuration. If you have v0.2.0 installed please DO NOT UNINSTALL but instead update the module to the recently released v0.2.1 as soon as possible. The module can be safely uninstalled from v0.2.1 or higher.

To update the module, visit the module config page, expand the Module Information section and click "check for updates".

2020-01-23_172715.png.888df35efb10f3c1c458f86777eff040.png

I apologise for this error.

 

  • Like 4
Link to comment
Share on other sites

@Jens Martsch - dotnetic, @rjgamer, @teppo, @szabesz, @erikvanberkum, @dragan, @Lutz, @eydun, @psy, @horst, @cstevensjr, @tpr

Just tagging in those who have reacted/responded to this topic in order to bring your attention to the notice above. Please don't uninstall but update to v0.2.1 or greater ASAP.

Again, my apologies for the error. The intention was to have the module clean up after itself on uninstall but it's just too risky.

  • Like 8
Link to comment
Share on other sites

On 1/20/2020 at 7:20 AM, Robin S said:

I just tested this by creating a new template named "_test" and the stub file was created normally. I can't think of any reason why a template name starting with an underscore would behave differently with this module.

It's common to create a file named "_main.php" that is auto-appended to template files if you are using a delayed output strategy, but in that case the file does not correspond to any PW template. Maybe that's the case for you. Are you sure you actually have a template named "_main" in Setup > Templates? 

Sorry yes my mistake its an auto-appended file not a template.

Link to comment
Share on other sites

  • 1 month later...
2 hours ago, eydun said:

Would it be possible to add the Config class as a variable?

I have tried:


/** @var tpl_config $config */

But it does not work.

That's not how this module works. It's just gives you code completion for fields that belong to the template of the current page - $config is an API variable so is something totally different.

But you can add type hints for the API variables that PW makes available to template files in a DocBlock at the top of your template files. More info:

 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...