Jump to content

Gideon So

Members
  • Posts

    472
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Gideon So

  1. Is it possible to set page image focus through a hook?? I tried this piece of code but it seems doesn't work. wire()->addHookAfter('Pages::saveReady', function ($event) { $page = $event->arguments(0); if(count($page->pageBanner)){ $page->of(false); $page->pageBanner->focus(10,10); $page->save(); $page->of(true); } }); Processwire throw this error: Any ideas is much welcome. Gideon
  2. I got your idea wrong. Let me see.... $randomPages = $pages->find("your selector here")->shuffle(); foreach($randomPages as $randomPage): foreach($randomPage->repeater_field->findRandom(3) as $item) : Output endforeach; endforeach; Use findRandom() instead of getRandom().
  3. Please try $randomPage = $pages->find("id=1049|1053|1055|1059|1152")->findRandom(1); Don't use get. Gideon
  4. Hi @Tyssen. for($i = 0; $i < 5; $i++): $randomPage = $pages->find("your selector here")->findRandom(1); foreach($randomPage->repeater_field->getRandom(3) as $item) : Output endforeach; endfor; Hope this helps.
  5. Hi @gregory, Can you tell me more about your template settings?? Are you using the pro module: repeater matrix?? https://processwire.com/store/pro-fields/repeater-matrix/ Gideon
  6. Hi @gregory, Is "case_studies" is a repeater or repeater matrix field?? Gideon
  7. Hi @gregory, What is the field type of "type"?? Please provide more info about your template and field settings. Gideon
  8. Hi @hollyvalero, Maybe you can try $yourArray->eq() to get the item you want. Can't give long example. Please take a look on the doc here: https://processwire.com/api/ref/wire-array/eq/ Gideon
  9. Yes. You can try it out yourself. Gideon
  10. Hi, The alternate user template approach @adrian mentioned is the way to go. Actually, it really depends on what you want to do. For me, I added fields to the user template and it is good enough for me. I put a page reference field in the user template and another field in some other template that need to store user id. Then connect the two page reference fields with the connect page fields module. It works great for me. Gideon
  11. Hi @joer80, 1. Go the Setup --> Templates, click Filters. Then set "show system templates" to Yes. 2. Click "user" template 3. click Family tab 4. set "May this template has childern" to Yes. 5. set templates allowed for this template if necessary. But please think twice before you do this. It is not encouraged to add children to user page. It is better to create a separate page with page reference field that set to choose from user pages. Gideon
  12. Hi @louisstephens, <link rel="icon" type="image/png" href="<?php echo $config->urls->templates?>favicon.png" /> There is no need to add a splash before favicon.png. Gideon
  13. You can go to the support forum to ask for help. Gideon
  14. I suggest you to upgrade to 3.0 if no other reason prevent you from doing it. All the fixes was pushed to the 3.0 branch and as far as I know 2.8 branch is no longer updated. Gideon
  15. Hi @oflcad, Welcome to the forum and the world of Processwire. Do you mean that you need to move the development site to a production server?? If so, there are several ways to do it. 1. Export the datebase and import it to the production server then upload the whole site to the production server. Please amend the site/config.php file as needed if database name, database username and password are different from your development server. You also need to amend the $config->httpHost in the config.php file to the production domain. 2. Use the miration module. and there is a blog post about it. Hope this helps. Gideon
  16. A quick thought: make a subdirectory within the old site and develop the new site there. Delete all the old stuff (remember to leave the new site directory). Then move everything in the new site directory to the main directory. Done. Gideon
  17. Hi, 1. PHP notice is not error. Your code still valid. 2. Try change the line if displaying image to the following: <?php echo $member->images->first()->url; ?> Gideon
  18. It is very hard to tell because I don't know your template settings and page structure. Gideon
  19. Hi @mattcohen, I see. But I think the title=$item_title selector may just return 1 page. This is the reason the found page is not sorted. Please provide more info, for exampe , your template settings, page structure and what you want to achieve. Gideon
  20. Hi @benbyf, Put setlocale(LC_ALL, "fr_FR.UTF-8"); into ready.php. Gideon
  21. Have to tried to read the source code of the page to see if the field values are properly propagated? Gideon
  22. Hi @adamspruijt @Torsten BaldesBaldes, Please add comment here https://github.com/processwire/processwire-issues/issues/724 And let see if we can raise some attention from @ryan Gideon
  23. Hi @ryan, Can you look into this issue again: https://github.com/processwire/processwire-issues/issues/724 The fix is good for single language environment but there is error show in the backend under multi-language settings: https://github.com/processwire/processwire-issues/issues/724#issuecomment-443126270 Gideon
×
×
  • Create New...