Jump to content
ryan

Map Marker Map

Recommended Posts

@ dragan

this is a localhost issue. Try it on a life server and it should work. As far as I'm aware of, Gmaps don't work from localhosts.

Since Gmaps API v3 there is no need for a key.

Share this post


Link to post
Share on other sites

Thanks. I installed it now on a live server, but now I get still no infos at all, and in addition:

Error: Call to a member function render() on a non-object (line 19 of /home/foo/public_html/site/templates/map.php) 
 

line 19 = echo $map->render($page, 'map'); // straight from the Module docs / example

Also, in page edit mode, I still see "Geocode OFF" below the map - or "N/A".

To add to all these oddities, the address never gets saved. When I re-edit the page, the address is gone.

PW 2.3.8, Google Chrome, PHP 5.4.12

Share this post


Link to post
Share on other sites

Frontend:

Did you check with Firebug that all google maps JS gets loaded?

Backend

Sorry, no idea. Maybe someone else can jump in.

Share this post


Link to post
Share on other sites

I have the same issue when entering a location and saving a page, the location is gone. Usually it works to enter the location again and save once more.

Share this post


Link to post
Share on other sites

The "Geocode OFF" text is what is shown when the checkbox between address and lat/lng is not checked–make sure you've got that checked, unless you want to manually input your own lat/lng coordinates. 

Share this post


Link to post
Share on other sites

Ryan I just pushed a change to the inputMapMarker.js file on github that solves this problem.

Added this inside the InputFieldMarker function:

// added by diogo to solve the problem of maps not rendering correctly in hidden elements
// trigger a resize on the map when either the tab button or the toggle field bar are pressed
$(document).ready(function() {

    // get the tab element where this map is integrated
    $tab = $('#_' + $(map.b).closest('.InputfieldFieldsetTabOpen').attr('id'));
    // get the inputfield where this map is integrated and add the tab to the stack
    $inputFields = $(map.b).closest('.Inputfield').find('.InputfieldStateToggle').add($tab);

    $inputFields.on('click',function(){
        // give it time to open
        window.setTimeout(function(){
            google.maps.event.trigger(map,'resize');
        }, 200);
    });
});
 

I had to put it inside the function, to have the "map" variable in scope. I'm not sure how we could move it outside the function if you don't like it that way.

Also, the 200 value on the setTimeout works for me (it works above 120 but I set it to 200 to be on the safe side), but we can decide on a safer value depending on other's tests.

I am trying to use Zurb Foundation Reveal modal dialog to show the map with some other information. I have the problem that the map is not loaded correctly, only showing part of the map in the upper left corner with gray background on the leftover part of the map. Could it be related to this problem discussed here and how could I fix this?

post-442-0-28103400-1388096079_thumb.jpg

Share this post


Link to post
Share on other sites

Google Maps doesn't like being initially hidden. It will produce the effect you see in your screenshot. The solution would be to initialize the map at the time you intend to show it (like after the reveal modal opens). An alternative would be to trigger an event on the map, telling it to redraw when shown. Credits to diogo for figuring this one out, as it's the solution we implemented in the InputfieldMapMarker for when a map is on a tab. For Zurb Foundation reveal, you'd do something like this below. The "mgmap1" is the map from MarkupGoogleMap module, so you may need to change that according to your map name, etc. The setTimeout() below may not be necessary, or you may be able to reduce the delay from 250 down to 100 or something. 

$(document).on('opened', '[data-reveal]', function () {
  setTimeout(function() {
    google.maps.event.trigger(mgmap1, 'resize'); 
    mgmap1.map.setCenter(mgmap1.options.center);
  }, 250);  
}); 
  • Like 2

Share this post


Link to post
Share on other sites

Thanks Ryan! I tried this, but can't get the map to resize. 

I have the code just as yours above.

My map div is called mgmap1 and if I put an alert("OK"); after the setCenter line, I get that alert triggered, but the map is not resized. 

I'll send you a private message of the page, if you can check why my code doesn't work?

Share this post


Link to post
Share on other sites

Lpa: I looked at your map, and you've got a Javscript error occuring related to magnificPopup. That error is occurring before the map resize gets to occur (due to the setTimeout), so it is effectively preventing the JS code from running. If you can resolve the JS error you are getting, my guess is it would start working. 

Share this post


Link to post
Share on other sites

Thanks Ryan, but it didn't help. The map still sometimes shows up correct but after clicking some more concerts it shows up with the same error.

Share this post


Link to post
Share on other sites

Looks maybe like you have some max-width: 100% in your css for images.

Share this post


Link to post
Share on other sites

I am using the Foundation profile and it seems foundation.css has max-width: 100% for img in a few places. Why does this affect the maps? What should be used instead?

Share this post


Link to post
Share on other sites

Thanks Soma! That is another problem that I had noticed but not tried to fix yet. My problem is still the one I wrote about in #156. The map doesn't resize and Ryan's example JS code doesn't fix it properly. Maybe it's something to do with loading the  content of the Foundation Reveal Modal with Ajax. 

Share this post


Link to post
Share on other sites

Hello all,

I would like to add a standard Gmaps info window (the white balloon type with shadow) to my marker.

I have a single marker on the map and use standard $map->render function.

From the Gmaps API documentation about info windows I see that I somehow have to add something like

  var infowindow = new google.maps.InfoWindow({
      content: contentString
  });

How would I go about that, can I create something like a hook event to extend the standard render function from the module or can I just add a piece of JS to the page?

Any enlightenment would be much appreciated.

Cheers

gerhard

In the MarkupGoogleMap.js you need to add the some code from the example you link @ https://developers.google.com/maps/documentation/javascript/examples/infowindow-simple

You also might want to display different data from a page and wil need to modify the MarkupGoogleMap.module foreach loop and add custom fields to your template page.

I've created a 2 fields called map_location_name and phone_number

//Edit the MarkupGoogleMap.module  $out variable

foreach($pageArray as $page) {
$marker = $page->get($fieldName); 
if(!$marker instanceof MapMarker) continue; 
if(!$marker->lat) continue; 
$url = $options['markerLinkField'] ? $page->get($options['markerLinkField']) : '';
$title = $options['markerTitleField'] ? $page->get($options['markerTitleField']) : ''; 
$map_location_name = $page->map_location_name ? $page->map_location_name  : '';
$phone_number = $page->phone_number ? $page->phone_number  : '';
$out .= "$id.addMarker($marker->lat, $marker->lng, '$url', '$title', '','$map_location_name','$phone_number'); ";
}
if(this.hoverBox){ //right above this line add the code below in MarkupGoogleMap.js
var contentString = '<div class=\"chapter-bubble\">' + 
                    '<div class=\"chapter-bubble-title\">' + title + '</div>' +
                    '<div class=\"chapter-bubble-name\">' + map_name + '</div>' +
                    '<div class=\"chapter-bubble-number\">' + map_number + "</div>" +
                    '<div class=\"chapter-bubble-url\">' + '<a href=\"' + url + '\">Visit Chapter Site</a></div>';
      var infowindow = new google.maps.InfoWindow({ content: contentString });
      google.maps.event.addListener(marker, 'click', function() { infowindow.open(this.map,marker); }); 
this.addMarker = function(lat, lng, url, title, icon, map_name, map_number) { //you'll need to add addition arguments to this line as well.
 
  • Like 3

Share this post


Link to post
Share on other sites

I must be blind, but I can find no way how to delete or unset the map, once I've added it. Neither setting the latitude and longitude to 0 nor deleting the field "Adress" works for me. Everytime I click save lat and long reappear and I can still see the map???   
 

post-889-0-61597700-1389970353_thumb.jpg

Can yo help?

Share this post


Link to post
Share on other sites

Uncheck the box to the left of latitude, then delete the latitude and longitude (make them blank). Save. Following that it should return to the default/unset location specified in the field settings. 

Share this post


Link to post
Share on other sites

Uncheck the box to the left of latitude, then delete the latitude and longitude (make them blank). Save. Following that it should return to the default/unset location specified in the field settings. 

Hey Ryan,

thx for replying, but that way doesn't work for me ?!? After saving the old coordinates reappear and I can still see the map on frontend.

Share this post


Link to post
Share on other sites

The top save button has had some issues actually saving any changes in some web browsers on older versions of PW. Everything should be fixed in recent dev versions, but if you don't want to upgrade, try using the save button at the bottom of the page and see if that works.

Share this post


Link to post
Share on other sites

The top save button has had some issues actually saving any changes in some web browsers on older versions of PW. Everything should be fixed in recent dev versions, but if you don't want to upgrade, try using the save button at the bottom of the page and see if that works.

Tried both: A different browser (Chrome and FF latest ver.) and both "Save" buttons ;(  Nothing worked for me... I'm using PW Ver. 2.3 with teflon admintheme http://modules.processwire.com/modules/teflon/

  Any other ideas?

Share this post


Link to post
Share on other sites

I just tested and it seems to work fine at my end too. If you're comfortable in PHPMyAdmin you could delete the entry from the field_geo_address table. It would be great to figure out why it's not working for you. But if you need this quickly, it might be the simplest way for now.

Share this post


Link to post
Share on other sites

I just tested and it seems to work fine at my end too. If you're comfortable in PHPMyAdmin you could delete the entry from the field_geo_address table. It would be great to figure out why it's not working for you. But if you need this quickly, it might be the simplest way for now.

Of course this would be the simplest way to get rid of it, but I wonder, why I can#t delete it the regular way.

When installing MapMarkerFieldtype I've had some problems, because PHP-allow_url_fopen and PHP-allow_url_include where switched off an the server. After activating them, it seemed to work for me, but I still get an errormessage, when I try to open  the field settings.

post-889-0-82360200-1390493038_thumb.jpg

Perhaps my saving problem is in relationship to the hassle while installing the field?!

Share this post


Link to post
Share on other sites

Double check that you are running the latest version of the MapMarker Fieldtype. Go to your map field settings (Setup > Fields) and see if you've got default coordinates defined. Hit save on this page, just to make sure everything is committed to the DB (perhaps something was left out before). Now try editing your page again to see if you can delete the coordinates. If you are still getting an error message, try switching out two things just for testing purpose: try it in Chrome (rather than FF), and try using the default admin theme. I suspect it's not the admin theme, but just good to rule things out. Lastly, if you aren't on the dev branch, try switching to it. Please let me know if you find any of these to change or resolve the issue. However, the actual error message you got about being unable to geocode the address seems to indicate that it still can't connect to Google for one reason or another.. but that would probably be an issue separate from being able to delete the coordinates. Still, you may want to double check from a phpinfo(); that allow_url_fopen really is active in your PHP (you do not need to enable allow_url_include, nor do I recommend it). 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gebeer
      I am happy to present my new fieldtype FieldtypeImageFromPage. It is made up of 2 modules:
      Fieldtype Image Reference From Another Page is a Fieldtype that stores a reference to a single image from another page. The image can be selected with the associated Inputfield.
      Inputfield Select Image From Page is an Inputfield to select a single image from images on a predefined page and it's children.
      And there also is a helper module that takes care of cleanup tasks.
      This module evolved out of a discussion about my other Module FieldtypeImagePicker.  It caters for use cases where a set of images is being reused multiple times across a site. With this fieldtype these images can be administered through a chosen page. All images uploaded to that page will be available in the inputfield.
      When to use ?
      Let editors choose an image from a set of images that is being used site-wide. Ideal for images that are being re-used across the site.
      Suited for images that are used on multiple pages throughout the site (e.g. icons).
      Other than the native ProcessWire images field, the images here are not stored per page. Only references to images on another page are stored. This has several advantages:
      one central place to organize images when images change, you only have to update them in one place. All references will be updated, too. (Provided the name of the image that has changed stays the same) Features
      Images can be manipulated like native ProcessWire images (resizing, cropping etc.) Image names are fully searchable through the API Accidental image deletion is prevented. When you want to delete an image from one of the pages that hold your site-wide images, the module searches all pages that use that image. If any page contains a reference to the image you are trying to delete, deletion will be prevented. You will get an error message to help you edit those pages and remove references there before you can finally delete the image. How to install and setup
      Download and install this module like any other modules in ProcessWire Create a page in the page tree that will hold your images. This page's template must have an images field Upload some images to the page you created in step 2 Create a new field. As type choose 'Image Reference From Another Page'. Save the field. In 'Details' Tab of the field choose the page you created in step 2 Click Save button Choose the images field name for the field that holds your images (on page template from step 2) Click Save button again Choose whether you want to include child pages of page from step 2 to supply images Add the field to any template You are now ready to use the field View of the inputfield on the page edit screen:

      View of the field settings

      The module can be installed from this github repo. Some more info in the README there, too.
      In my tests it was fairly stable. After receiving your valued feedback, I will eventually add it to the modules directory.
      My ideas for further improvement:
      - add ajax loading of thumbnails
      Happy to hear your feedback!
       
    • By gebeer
      Although the PW backend is really intuitive, ever so often my clients need some assistance. Be it they are not so tech savvy or they are not working in the backend often.
      For those cases it is nice to make some help videos available to editors. This is what this module does.
      ProcessHelpVideos Module
      A Process module to display help videos for the ProcessWire CMS. It can be used to make help videos (screencasts) available to content editors.
      This module adds a 'Help Videos" section to the ProcessWire backend. The help videos are accessible through an automatically created page in the Admin page tree. You can add your help videos as pages in the page tree. The module adds a hidden page to the page tree that acts as parent page for the help video pages. All necessary fields and templates will be installed automatically. If there are already a CKEditor field and/or a file field for mp4 files installed in the system, the module will use those. Otherwise it will create the necessary fields. Also the necessary templates for the parent help videos page and it's children are created on module install. The module installs a permission process-helpvideos. Every user role that should have access to the help video section, needs this permission. I use the help video approach on quite a few production sites. It is stable so far and well received by site owners/editors. Up until now I installed required fields, templates and pages manually and then added the module. Now I added all this logic to the install method of the module and it should be ready to share.
      The module and further description on how to use it is available on github: https://github.com/gebeer/ProcessHelpVideos
      If you like to give it a try, I am happy to receive your comments/suggestions here.
    • By Robin S
      A module created in response to the topic here:
      Page List Select Multiple Quickly
      Modifies PageListSelectMultiple to allow you to select multiple pages without the tree closing every time you select a page.
      The screencast says it all:

       
      https://github.com/Toutouwai/PageListSelectMultipleQuickly
      https://modules.processwire.com/modules/page-list-select-multiple-quickly/
    • By gebeer
      Hello all,
      sharing my new module FieldtypeImagePicker. It provides a configurable input field for choosing any type of image from a predefined folder.
      The need for it came up because a client had a custom SVG icon set and I wanted the editors to be able to choose an icon in the page editor.
      It can also be used to offer a choice of images that are used site-wide without having to upload them to individual pages.
      There are no image manipulation methods like with the native PW image field.
      Module and full description can be found on github https://github.com/gebeer/FieldtypeImagePicker
      Kudos to @Martijn Geerts. I used his module FieldTypeSelectFile as a base to build upon.
      Here's how the input field looks like in the page editor:

      Hope it can be of use to someone.
      If you like to give it a try, I'm happy to hear your comments or suggestions for improvement. Eventually this will go in the module directory soon, too.
    • By bernhard
      @Sergio asked about the pdf creation process in the showcase thread about my 360° feedback/survey tool and so I went ahead and set my little pdf helper module to public.
      Description from PW Weekly:
       
      Modules Directory: https://modules.processwire.com/modules/rock-pdf/
      Download & Docs: https://github.com/BernhardBaumrock/RockPDF
       
      You can combine it easily with RockReplacer: 
      See also a little showcase of the RockPdf module in this thread:
       
×
×
  • Create New...