Jump to content

☁️ Duplicator: Backup and move sites


Recommended Posts

2 hours ago, adrian said:

Actually, should both be exactly the same file size - does the encryption not result in some change?


Missed your question, and the answer is not necessarily.

In our case, we use asymmetric file encryption and the lib run his seals operations on a resource implementing StreamInterface (PSR-7). Just to say that, without going into deep details, the methods read the file from a stream block by block, with a defined buffer size, and a minimum shortest cypher text of 100 bytes, then run the cipher algo (XChaCha20) on the blocks till the EOF. This mean that your file should have the same size. The encrypted file could have 100 bytes more than the source.

You can try to run in the terminal `du -b source_file` and `du -b encrypted_file` to compare them. By curiosity, you can also test it with openssl by running :

`openssl enc -d -chacha20 -K YOUR_PUBLIC_KEY -iv 0123456789abcdef0123456789abcdef -in SOURCE.zip > ENCRYPTED.zip`

(the difference between Chacha20 and XChacha20 is the last use an extended nonce, the result should be same size).

Link to comment
Share on other sites

On 11/21/2022 at 8:49 PM, James Morris said:

I am getting an error of 'Class "DUP_Logs" not found' when upgrading to the latest version (1.4.26) when using the Amazon S3 option.  The provided SDK is on place, all was working fine before the upgrade.  Reverting back to 1.4.0 solved the problem.  Here is the full call stack for reference:

Fixed it, it will be released in Duplicator v1.5.0. I tested AWS, no problem found. I will release also the updated Duplicator-SDKs.


On 3/23/2023 at 8:47 PM, adrian said:

I am still confused why the .zip is kept - shouldn't that be deleted after the creation of the .zip.enc file?

It's committed.

Link to comment
Share on other sites

Hey @flydev

thank you for providing this module, it's really helpful to me an safes a ton of time!

Just want to mention that there seems to be something wrong with the version number on PW:


Also when trying to update the module (obviously)


Cheers !

  • Thanks 1
Link to comment
Share on other sites

I’m getting this when I try to go to the Duplicator module:

Fatal Error: Uncaught Error: Call to undefined function shell_exec() in site/modules/Duplicator/Duplicator.module:1439

#0 [internal function]: Duplicator::getModuleConfigInputfields(Array)
#1 wire/core/Modules.php (4130): call_user_func(Array, Array)
#2 wire/core/Wire.php (419): Modules->___getModuleConfigInputfields('Duplicator', Object(InputfieldForm))
#3 wire/core/WireHooks.php (952): Wire->_callMethod('___getModuleCon...', Array)
#4 wire/core/Wire.php (484): WireHooks->runHooks(Object(Modules), 'getModuleConfig...', Array)
#5 wire/modules/Process/ProcessModule/ProcessModule.module (1680): Wire->__call('getModuleConfig...', Array)
#6 wire/modules/Process/ProcessModule/ProcessModule.module (1415): ProcessModule->renderEdit('Duplicator', Array)
#7 wire/core/Wire.php (413): ProcessModule->___executeEdit()
#8 wire/core/WireHooks.php (952): Wire->_callMethod('___executeEdit', Array)
#9 wire/core/Wire.php (484): WireHooks->runHooks(Object(ProcessModule), 'executeEdit', Array)
#10 wire/core/ProcessController.php (350): Wire->__call('executeEdit', Array)
#11 wire/core/Wire.php (413): ProcessController->___execute()
#12 wire/core/WireHooks.php (952): Wire->_callMethod('___execute', Array)
#13 wire/core/Wire.php (484): WireHooks->runHooks(Object(ProcessController), 'execute', Array)
#14 wire/core/admin.php (160): Wire->__call('execute', Array)
#15 wire/modules/AdminTheme/AdminThemeDefault/controller.php (13): require('/customers/a/0/...')
#16 site/templates/admin.php (15): require('/customers/a/0/...')
#17 wire/core/TemplateFile.php (328): require('/customers/a/0/...')
#18 wire/core/Wire.php (413): TemplateFile->___render()
#19 wire/core/WireHooks.php (952): Wire->_callMethod('___render', Array)
#20 wire/core/Wire.php (484): WireHooks->runHooks(Object(TemplateFile), 'render', Array)
#21 wire/modules/PageRender.module (575): Wire->__call('render', Array)
#22 wire/core/Wire.php (416): PageRender->___renderPage(Object(HookEvent))
#23 wire/core/WireHooks.php (952): Wire->_callMethod('___renderPage', Array)
#24 wire/core/Wire.php (484): WireHooks->runHooks(Object(PageRender), 'renderPage', Array)
#25 wire/core/WireHooks.php (1060): Wire->__call('renderPage', Array)
#26 wire/core/Wire.php (484): WireHooks->runHooks(Object(Page), 'render', Array)
#27 wire/modules/Process/ProcessPageView.module (184): Wire->__call('render', Array)
#28 wire/modules/Process/ProcessPageView.module (114): ProcessPageView->renderPage(Object(Page), Object(PagesRequest))
#29 wire/core/Wire.php (416): ProcessPageView->___execute(true)
#30 wire/core/WireHooks.php (952): Wire->_callMethod('___execute', Array)
#31 wire/core/Wire.php (484): WireHooks->runHooks(Object(ProcessPageView), 'execute', Array)
#32 index.php (55): Wire->__call('execute', Array)
#33 {main}
thrown (line 1439 of site/modules/Duplicator/Duplicator.module) 

This error message was shown because: you are logged in as a Superuser. Error has been logged.


  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...