Jump to content

WireMailSmtp


horst

Recommended Posts

Just tested and sending via CURL using Postmark's API from a command line it went through fine so I guess it must be the module trimming the .solutions part of the domain unless the server config can also have an effect on emails sent this way?

Link to comment
Share on other sites

  • 1 month later...

Hello, I'm having some trouble using the module inside another module.

It looks like it can't process the "to" email, I'm always getting "Error in hnsmtp::send : it were not specified any valid recipients".

I simply call the module as I call it inside a template

$m =  wireMail();
$m->to($email);
$m->subject('my subject');
$m->bodyHTML($body);
$numSent = $m->send();

I tried to change the call to $this->modules->get('WireMailSmtp') with no success...what I'm doing wrong?

 

Edit: I solved it. Maybe it could be helpful for someone else...the send email address in the general setting of the module was wrong (different domain from the one set in the smpt) and somehow it didn't show any error when Wiremail sends an email from a template..

Link to comment
Share on other sites

  • 2 months later...

I've been encountering frequent Error in hnsmtp::send : cannot connect to smtp-server! errors indicating a failure to connect to the SMTP server. I'm using Brevo, formerly known as SendinBlue, and this issue only started a few months ago. The errors seem to occur randomly, with varying frequency, ranging from ten times a day to once a week. I've reached out to Brevo for assistance, but they haven't identified any issues so far.

Additionally, I recently conducted an external SMTP test on dnschecker.org, and it consistently succeeded each time (though this might be coincidental). The problem persists regardless of whether I test the connection locally or in a live environment.

I'm wondering if there's a way to debug the SMTP connection to gather more information about the problem.

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...
On 8/14/2023 at 6:00 AM, Pete said:

Just tested and sending via CURL using Postmark's API from a command line it went through fine so I guess it must be the module trimming the .solutions part of the domain unless the server config can also have an effect on emails sent this way?

Also having this same issue and digging through the module to find a solution. Did you happen to find a better solution than using the curl command?

Link to comment
Share on other sites

51 minutes ago, Jason Spooner said:

Also having this same issue and digging through the module to find a solution. Did you happen to find a better solution than using the curl command?

Found this in the module and needs to be fixed:

var $email_address_pattern="([-!#\$%&'*+./0-9=?A-Z^_`a-z{|}~])+@([-!#\$%&'*+/0-9=?A-Z^_`a-z{|}~]+\\.)+[a-zA-Z]{2,6}";

  • Thanks 1
Link to comment
Share on other sites

@horst the regex mentioned above does appear to be faulty as it only allows domain endings up to 6 characters whereas this discussion suggests an upper limit of 63 (though nobody has created one that long yet to my knowledge). I would just go for 2,24 for now to keep it relatively sensible as the longest currently is 24, or you could just make it 2,63 to future-proof it a bit?

Source: https://stackoverflow.com/a/22038535

  • Thanks 1
Link to comment
Share on other sites

  • 4 weeks later...
  • 3 weeks later...

Hello everyone,
does anyone have experience with All-Inkl.com?

Somehow I can't get it set up correctly. My settings can be seen on the screenshot.

When I test the settings I get the following:

 

array(1) 
{
  ["SETTINGS"]                       array(28) 
  {
    ["default_charset"]              string(5) "UTF-8"
    ["localhost"]                    string(10) "fgfc820.de"
    ["smtp_host"]                    string(21) "v075199.kasserver.com"
    ["smtp_port"]                    int(465)
    ["smtp_ssl"]                     int(1)
    ["smtp_ssl_crypto_method"]       string(0) ""
    ["smtp_start_tls"]               int(1)
    ["smtp_tls_crypto_method"]       string(1) "0"
    ["smtp_user"]                    string(15) "page@fgfc820.de"
    ["smtp_password"]                string(20) "---MyPassword---"
    ["smtp_password2"]               string(0) ""
    ["clear_smtp_password"]          string(0) ""
    ["allow_without_authentication"] string(0) ""
    ["realm"]                        string(0) ""
    ["workstation"]                  string(0) ""
    ["authentication_mechanism"]     string(0) ""
    ["smtp_debug"]                   int(0)
    ["smtp_html_debug"]              int(0)
    ["sender_name"]                  string(12) "Kilian Spohr"
    ["sender_email"]                 string(15) "page@fgfc820.de"
    ["sender_reply"]                 string(0) ""
    ["sender_errors_to"]             string(0) ""
    ["sender_signature"]             string(0) ""
    ["sender_signature_html"]        string(0) ""
    ["send_sender_signature"]        string(0) ""
    ["extra_headers"]                array(0) 
    {
    }
    ["valid_recipients"]             array(0) 
    {
    }
    ["smtp_certificate"]             int(1)
  }
}
array(1) 
{
  ["RESULT"]             array(5) 
  {
    ["subject"]          string(9) "Test Mail"
    ["addSignature"]     string(1) "0"
    ["textbody"]         string(39) "This is a test message. ÄÖÜ äöüß"
    ["recipients"]       array(1) 
    {
      [0]                array(3) 
      {
        ["emailaddress"] string(18) "kilianspohr@web.de"
        ["name"]         string(0) ""
        ["type"]         string(2) "to"
      }
    }
    ["send"]             string(0) ""
  }
}
array(1) 
{
  ["ERRORS"] array(1) 
  {
    [0]      string(36) "server does not support starting TLS"
  }
}
array(1) 
{
  ["DEBUGLOG"] string(548) "

Resolving SMTP server domain "v075199.kasserver.com"...
Connecting to SMTP server "v075199.kasserver.com" port 465...
Connected to SMTP server "v075199.kasserver.com".
S 220 dd48224.kasserver.com ESMTP
C EHLO fgfc820.de
S 250-dd48224.kasserver.com
S 250-PIPELINING
S 250-SIZE 102400000
S 250-VRFY
S 250-ETRN
S 250-AUTH PLAIN LOGIN
S 250-AUTH=PLAIN LOGIN
S 250-ENHANCEDSTATUSCODES
S 250-8BITMIME
S 250-DSN
S 250 CHUNKING
"
}

Does anyone have an idea why this might be?

Sending emails via Thunderbird works

Thank you

Screenshot 2024-01-25 at 12-04-59 Module Wire Mail SMTP • fgfc820.de.png

Link to comment
Share on other sites

You have entered a few small details incorrectly 😉 

Use Port 587, Uncheck "use SSL" and then "Select a crypto method for TLS" (for Example STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT)

And change the SMTP User to your Mail USERNAME, not your Email Address (you can find this info in the All-Inkl KAS -> Edit the Mailbox).

  • Like 1
  • Thanks 2
Link to comment
Share on other sites

16 minutes ago, zoeck said:

You have entered a few small details incorrectly 😉 

Use Port 587, Uncheck "use SSL" and then "Select a crypto method for TLS" (for Example STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT)

And change the SMTP User to your Mail USERNAME, not your Email Address (you can find this info in the All-Inkl KAS -> Edit the Mailbox).

Thank you, it works now.

But it's strange, for thunderbird or other mail programs I had to use the Port 465 and I could use the mail address as username. In their faq they also wrote Port 465.

Link to comment
Share on other sites

3 hours ago, ShadowByte said:

But it's strange, for thunderbird or other mail programs I had to use the Port 465 and I could use the mail address as username. In their faq they also wrote Port 465.

I think Both is possible 🙂 Port 465 is the SSL Port.

All Inkl FAQ:

Quote

If you use STARTTLS as connection security, enter port 25 or 587. When using SSL/TLS, port 465 applies.

The Mail address as username also works (mostly), but I have had problems with it before, so I always recommend using the username.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...