Jump to content

Recommended Posts

Hi guys, so since I moved to Processwire, it has been my default go-to CMF/CMS for my website and client applications, apparently my previous job took a toll on me, and made me have less time, but now finally had the chance to change my website to something I always had in mind.

I decided to go with something minimal, as I tend to enjoy writing, so wanted a website to have more text than graphics and I think I whipped up something clean. Currently I still have more to do, but this is my current website, the main purpose to have a content driven website where I will be writing tutorials , articles more and hopefully  technical  notes.

Please let me know your honest opinion.

PS: I am more of a coder than a designer but i think this old dog still pulled it off

 

https://okeowoaderemi.com/

 

 

Annotation 2019-08-28 171120.jpg

Annotation 2019-08-28 171209.jpg

Annotation 2019-08-28 171300.jpg

image.png

  • Like 12

Share this post


Link to post
Share on other sites

Nice 😀 home page nav was a bit confusing for me, eg when clicking on 'About', it scrolled to your About section but the menu disappeared. There was no obvious way to get back to the top of the page. When I scrolled up, the menu had disappeared. Using iMAC with wide screen. Going into phone mode in Chrome dev tools made it a bit easier... Otherwise, well done you!

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, psy said:

Nice 😀 home page nav was a bit confusing for me, eg when clicking on 'About', it scrolled to your About section but the menu disappeared. There was no obvious way to get back to the top of the page. When I scrolled up, the menu had disappeared. Using iMAC with wide screen. Going into phone mode in Chrome dev tools made it a bit easier... Otherwise, well done you!

Thanks Psy , I will work on that 

  • Like 1

Share this post


Link to post
Share on other sites

Yeah, the navigation is not ideal. I have to scroll 3-4 times down to see the next content below, which is counter-intuitive.

There are also JS/Vue errors in projects. I can't get past the 2nd one and get [Vue warn]: Error in render: "TypeError: Cannot read property 'title' of undefined"

 

  • Like 1

Share this post


Link to post
Share on other sites

Nice, thx for sharing and welcome back to ProcessWire 😉 I like the design and I think it gives a good impression of who you are. I also had not the best experience with the navigation. First try was to scroll down but nothing happened, only the menu disappeared. Scrolling several times more finally showed the next section.

What could be missing (if that's not intentional) is a statement what you are looking for. Are you available for hire? Or do you just want to share your projects? I don't get that from the website 🙂 

Share this post


Link to post
Share on other sites
52 minutes ago, bernhard said:

Nice, thx for sharing and welcome back to ProcessWire 😉 I like the design and I think it gives a good impression of who you are. I also had not the best experience with the navigation. First try was to scroll down but nothing happened, only the menu disappeared. Scrolling several times more finally showed the next section.

What could be missing (if that's not intentional) is a statement what you are looking for. Are you available for hire? Or do you just want to share your projects? I don't get that from the website 🙂 

Lol yes I am not sure what I was thinking when I did the navigation, I guess I got too carried away after looking at awwwards and dribbble. I will work on that

54 minutes ago, bernhard said:

What could be missing (if that's not intentional) is a statement what you are looking for. Are you available for hire? Or do you just want to share your projects? I don't get that from the website

Hmmmm this is a very interesting point, So what I aim to achieve is to have a website, where I can share my works, concepts and any crazy idea that comes to mind. I still have so much content to populate the site with, I tend to research and write things down, so I want to use my site as an avenue to share my works. Because I have been told by colleagues that I need to showcase my works and ideas more and also participate in community projects too. That's my goal. I won't mind any advice. Thanks and good to be back. 

  • Like 1

Share this post


Link to post
Share on other sites
11 minutes ago, Sephiroth said:

I have been told by colleagues that I need to showcase my works and ideas more

...to get rich? ...to find a woman? ...to get happier in life? ...just for fun? 😉 Little bit kidding here, but imho the most important question is the "why". Or the "goal" why you are showcasing that. Did you see last weeks showcase of https://siebennull.com/ ? It can be as simple as that:

JAZNQmX.png

That's what marketing people call "call to action". I didn't see one on your site

Just checked back and found it:

d1D0Dmz.png

Has it been there before? If the main goal of your website is getting possible new clients I'd say that a small single line with your e-mail is maybe not the best option 😉 If you don't want to get spammed by client requests because it's a just-for-fun-showcase website, then that would be fine - it's all about the main goal 🙂 

Share this post


Link to post
Share on other sites
9 hours ago, bernhard said:

...to get rich? ...to find a woman? ...to get happier in life? ...just for fun? 😉 Little bit kidding here, but imho the most important question is the "why". Or the "goal" why you are showcasing that. Did you see last weeks showcase of https://siebennull.com/ ? It can be as simple as that:

JAZNQmX.png

That's what marketing people call "call to action". I didn't see one on your site

Just checked back and found it:

d1D0Dmz.png

Has it been there before? If the main goal of your website is getting possible new clients I'd say that a small single line with your e-mail is maybe not the best option 😉 If you don't want to get spammed by client requests because it's a just-for-fun-showcase website, then that would be fine - it's all about the main goal 🙂 

Lol I have a good job, I am just looking to showcase my skill and I guess inspire people. Yeah it's just for fun and showcasing my thoughts. Hopefully as time goes by, there would be much more content to share. 

  • Like 6

Share this post


Link to post
Share on other sites

@Sephiroth

 

you have written a good article here : https://okeowoaderemi.com/articles/posts/wordpress-to-processwire-a-guide-for-developers/

I agree you on most points over there.. can you please share the article you have written over this ?

Quote

would be writing some ProcessWire tips and how WordPress Developers can easily migrate to ProcessWire.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Oh I never got to write about that, so I think that would be a starting point. To think that I was brainstorming on what topic to write. I will share a draft and let you know how it goes. This seems like a good starting point, because most people are missing out on the beauty of Processwire. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By abdulqayyum
      Hy everyone,
      i am using loginRegister module for front-end user login.
      In this module user can login with Email/username, i am showing with Email. done
      but not showing Email in Forgotton Password section. there still showing with username.

      i want to show Forgotton Password with Email instead username. and should reset with email.

      please help me in this section, how i can set it with Email.

      Thanks AbdulQayyum.
    • By abdulqayyum
      Markup-Google-Recaptcha is not working with LoginRegister module in Forgotton Password Form.
      Here is my code
      wire-> modules -> process -> ProcessForgotPassword.php
      protected function step1_renderForm() {
              $form = $this->modules->get("InputfieldForm");
              $form->attr('action', './?forgot=1');
              $form->attr('method', 'post');
          
              $field = $this->modules->get("InputfieldText");     
              $field->attr('id+name', 'username');
              $field->attr('class', 'redesign-field forgotPassFeild');
              $field->setAttribute('placeholder', 'Username');
              $field->required = true;
              $field->label = $this->_("Forgotton Password");
              $field->description = $this->_("If you cannot remember your password to access the affiliates portal. simply provide your username in the box below and we'll send you a reset link via email.");
              $form->add($field);
               
             // Calling MarkupGoogleRecaptcha Module.
              $captcha = $modules->get("MarkupGoogleRecaptcha");
             //  rendering form with recaptcha
              $captcha->render($form);
         
              $submit = $this->modules->get("InputfieldSubmit");
              $submit->attr('id+name', 'submit_forgot');
              $form->add($submit);
              $this->session->userResetStep = 1;
               
              // rendering form
               $out .= $form->render();
          
              // getting captcha script
              $out .= $captcha->getScript();
              return $out;
          }

      I am following this one example.

      please suggest me how i can show MarkupGoogleRecaptcha in forgotton password.
      Getting log error


      Thanks,
      Abdul Qayyum
    • By Mithlesh
      Hi there,
      My form is not getting submitted, it is showing:
      Unable to verify successful email delivery of this form submission.
      Attaching for your reference as well: 

      In the Backend, it is showing Connection timed out with smtp.gmail.com
      Pl guide me how to resolve that
    • By abdulqayyum
      hello processwire community,
      i am using LoginRegister module for front-end user registration. i am facing an issue verification email not receiving while WireMailSmtp is working perfectly and user receives message
      "Thank you, a confirmation code has been emailed to you. When you receive the email, click the link it contains, or paste the confirmation code below."
      received this message in front-end but does not receive any email relevant it.
      please help me in this case how i can solve it.
      Please check screen shots for SMTP test and message which receives user.
      Thanks AbdulQayyum,

      First screenshot SMTP test message, second when user receives message after clicking register button.
    • By abdulqayyum
      Dear processwire community,
      i have a problem in loginRegister module, i could not add custom field in login and register page.
      i read from plugin documentation. they are saying.
      " By default, the email and password fields are required for both forms. You may want to add more fields. To do this, you’ll need to add fields to your “user” template. You can add fields to your user template in the admin by going to “Setup > Templates > Show system templates > user”.

      but i could not find similar scenario like “Setup > Templates > Show system templates > user”
      i can see just "Setup > Templates" not seeing "Show system templates > user" in my admin panel.

      Please help me in this case that how i can add custom field in these two page.
      Regards AbdulQayyum

×
×
  • Create New...