joshuag

this request was aborted because it appears to be forged

Recommended Posts

Hi,

I just moved PW to a new server and now I can't login because I am getting the error:

"this request was aborted because it appears to be forged" when submitting the login form.

I tried changing the password and username with the API... thinking this is session related?

Any suggestions?

Thanks in advance,

Share this post


Link to post
Share on other sites

ok fixed this. It was permission problem... (smacks head.)

had to make sure /site/config.php was readable.

Clear case of the mondays.

  • Like 1

Share this post


Link to post
Share on other sites

I like these posts, clear titles, quick answers.

especially when someone answers their own question ;)

  • Like 2

Share this post


Link to post
Share on other sites

I've just transferred a site from localhost to a live domain and I'm having this exact same problem. Think my permissions on config.php are fine. Can someone confirm what they should be? Thanks

Share this post


Link to post
Share on other sites

Just managed to get in by changing permissions on the assets folder to 777. Not sure how much I fancy leaving it like that but for now will have to do as putting it back down to 755 for example, I get the error message again.

  • Like 1

Share this post


Link to post
Share on other sites

Don't know what they should be, but just looking at a couple of live sites they are 644 on config.php and 755 on /site/assets/.

  • Like 1

Share this post


Link to post
Share on other sites
Just managed to get in by changing permissions on the assets folder to 777. Not sure how much I fancy leaving it like that but for now will have to do as putting it back down to 755 for example, I get the error message again.

Most likely Apache is running as the same user for everybody on the server, probably with a name like "nobody". So it's not going to be able to write to a directory that is only writable to you (755)... it'll only be able to read from it. If the accounts a truly jailed from one another, and one account can't manipulate the files of another (by way of Apache) then 777 should be no problem. Likewise if it's a dedicated or VPS without untrusted accounts on it, then it should be fine. It sounds like that's the only way it'll run right now, so I would set it to that and then check with the web host what they recommend for Apache-writable directory permissions, and do what they suggest. You might also inquire if you can get an suPHP environment, where Apache/PHP would run as your account--in that case, you would only need rwx to yourself (700) or writable to you and rx to others (755).

  • Like 3

Share this post


Link to post
Share on other sites

Same here: I moved a site to a safe live hosting env' and had this error.

The fix proved to be making /site/assets/ 777 and recursively applying that to all inside /site/assets/, that fixed it :) thanks posters.

  • Like 1

Share this post


Link to post
Share on other sites

I've had two lots of hosting where I asked the host to switch it to suPHP - there are only a few minutes of downtime during the process, if that, and the permissions side of things suddenly makes infinitely more sense, so +1 to ryan.

Share this post


Link to post
Share on other sites

I just got this error too, but found that it persisted even after I double-checked my assets and config.php permissions.

I had installed the site using the ProcessWire Blank Profile, so figured I'd try it without that. Not sure why, but it did the trick. Removing the current install and reinsalling while sticking with the default site cleared up the issue.

  • Like 1

Share this post


Link to post
Share on other sites

"this request was aborted because it appears to be forged" message is also shown when try to login and cookies are disabled.

(Somewhat confusing, better to get a message to enable cookies before tying to login)

  • Like 1

Share this post


Link to post
Share on other sites

I just got this error too, but found that it persisted even after I double-checked my assets and config.php permissions.

I had installed the site using the ProcessWire Blank Profile, so figured I'd try it without that. Not sure why, but it did the trick. Removing the current install and reinsalling while sticking with the default site cleared up the issue.

I just ran into the exact same problem trying to use the Blank Profile.

Share this post


Link to post
Share on other sites

Blank profile is done using pw 2.2.0 I think so there could be the problem. However it would take u only little time creating a new one. Or just start with the default install, which is actually very nice start.

Share this post


Link to post
Share on other sites

Is it OK to just use the default install and just delete the fields, pages and templates? Anything else that should be done?

Share this post


Link to post
Share on other sites

Nope. But i pefer to use the fields and templates as a start so never ever do it. :-P

  • Like 1

Share this post


Link to post
Share on other sites
Is it OK to just use the default install and just delete the fields, pages and templates? Anything else that should be done?

This is perfectly fine. I think that's what most people do. Though those fields, pages and templates are the bare minimum foundation for nearly any site I build, so it's rare that they get deleted here. I guess you could say that the default profile is the blank profile for some of us. :)

  • Like 1

Share this post


Link to post
Share on other sites

Just managed to get in by changing permissions on the assets folder to 777. Not sure how much I fancy leaving it like that but for now will have to do as putting it back down to 755 for example, I get the error message again.

Same for me here... I don't know why that happened. Seemes to me like it has got something to do with the rights of my ftp-account - because this error popped up after I created a single ftp-account for the new pw-directory - rather than using one global ftp-account for all directories.

Anyone got a solution here? Cause I feel quite uncomfortable having site/assets/ on 777... 

Share this post


Link to post
Share on other sites
Anyone got a solution here? Cause I feel quite uncomfortable having site/assets/ on 777... 

Is it a shared hosting account, or a dedicated/vps? If it's some kind of dedicated platform where you don't have other accounts under someone else's control, then it's not as much of a concern. But I think this is a question for your hosting provider. What's probably happening is that PHP can't write to /site/assets/. Who is listed as the directory owner? It's most likely you, which would mean that Apache is running under an account other than yours that does not have write access. I would check with your hosting provider to see what permissions they recommend for CMSs that need to have a writable directory. This can very from host to host, so it's tough for us to narrow in on it here short of trying different options (that are more secure than 777) till it works. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks, Ryan. I will try to get more information from my provider. (Yes, it's a standard account, shared hosting, I guess).

Share this post


Link to post
Share on other sites

I've built a processwire website for a friend and had lots of problems with "this request was aborted because it appears to be forged" after putting it on the production server.

Now, after some weeks of searching for the problem (also at the provider...) solution was very simple and I like to share:

The Webspace on the server was full. And cause every visit creates a session (inside assets/sessions/ folder) no new session could be created (new sessions files were created, but size was zero). The result was the "forged" message. 

So perhaps this could be one more solution, if anyone else has this problem...

  • Like 5

Share this post


Link to post
Share on other sites

At the risk of 'pimping about' another thread where I've touched on /sessions/, I wonder if /sessions/ can safely be excluded in migrations and if so, then seeing no sessions created in /sessions/ would have made it easier, perhaps, in this case to spot the problem. Just a thought (here's the thread where I'm seeking to find the definitive list of stuff not to copy when migrating sites, in case it's of help anytime).

Share this post


Link to post
Share on other sites

I'm experiencing this problem on a vagrant box with nfs mapped www folder.

Changing permissions of site/assets recursively and config.php to 777 doesn't help.

I checked sessions folder. a 0 byte session file gets created. But the vagrant box has plenty of space available.

I checked out brandnew dev branch, installed it and get the error on login to admin.

All other PW sites on that vagrant box have the same problem. They used to work until recently. I'm not aware of any changes to the box that could have led to this behaviour.

Any pointers to a solution would be much appreciated.

Share this post


Link to post
Share on other sites

My issue was related to wrong apache user/group in my vagrant box. After changing those I can now login.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Peter Knight
      I have a demo site which I moved to a new VPS for client testing
      We noticed that leaving a page open and then revisiting the site can result in a 25 second(ish) to load time and will then throw a 500 Error.
      The hosting guys had a look and confirmed that the server is fine but the issue could be related to authentication or sessions.
      We are running Page Protector and ProCache so I wondered if there were any known bugs here and any recommended actions.
      My actual PW log doesn't show anything but the server log has plenty of these
       
      2018-12-06 08:14:00 Error xxx.141.1x.101 500 POST /who-we-are/ HTTP/1.0     1.58 K Apache access 2018-12-06 08:14:45 Warning xxx.141.1x.131   mod_fcgid: read data timeout in 45 seconds, referer: http://demo.abc.not/who-we-are/       Apache error 2018-12-06 08:14:45 Error xxx.141.1x.131   End of script output before headers: index.php, referer: http://demo.abc.not/who-we-are/       Apache error 2018-12-06 09:03:18 Error xxx.141.1x.131   2614#0: *667 recv() failed (104: Connection reset by peer) while reading response header from upstream       nginx error Thanks
      P
    • By Marcel
      Hey all,
      I want to customize the mywebsite/processwire/profile page. It's almost all good but I want to get rid of the sections 'Admin Theme' and 'Language' so that the user can just set a new password. (see image)
      Do I have to modify the admin template or how can I do that? Because when I go tree>Admin>Profile there are no fields to add or remove.
      Or where can I find the php file?
      I would appreciate your help.

    • By ridgedale
      Reference: PW 3.0.111 and uikit3 based site using the Regular-Master profile.
      I'm trying to automatically redirect a logged-in user to a custom profile page using $session->redirect() and need to add $user->name to the redirect path.
      All my attempts appear to have failed:
      $session->redirect('/user-profile/')->name; $session->redirect('/user-profile/')->$user->name; $session->redirect('/user-profile/' . get($user->name . '/')); $session->redirect('/user-profile/' & get($user->name)); Can anyone point out where I am going wrong?
    • By matsn0w
      Hey all,
      I am working on a website and I want to style the login page, but I'm a bit confused. 
      I want either the existing login page styled in my own way using some CSS (I guess I prefer that) or I want to create a custom page with a form to login. (Which I could style too).
      I used the code from Ryan and Renobird posted here - which works great - but that doesn't replace the original login page. 
      Is there a way to some sort of 'disable' the original login?
      I hope my question is clear and thanks in advance,
      matsn0w
    • By Lex Sanchez
      Hi everyone:
      I do not know if someone before using ProcessWire with AWS CloudFront, currently I have problems with the login, it does not work for any reason, when I check in the logs generated by ProcessWire, it only indicates This request was aborted because it appears to be forged. (in /wire/core/SessionCSRF.php line 190).
      I have allowed CloudFront to forward all headers, cookies and allow all methods (GET, POST, PUT).
      When I perform the same process from the ip server if it works or from the balancer.