Jump to content
horst

Croppable Image 3

Recommended Posts

On 12/6/2016 at 4:00 PM, horst said:

I have upgraded a site yesterday too. Here everything is working as expected. With both, existing and new created images.

(PW 3.0.39 to 3.0.43)

 I have no time to investigate further but this fixes it (line 344)

// if ($image->pagefiles === $pagefiles) {
if ($image->pagefiles->page->id === $pagefiles->page->id) {

Perhaps "===" is the culprit? PHP docs says

Quote

When using the identity operator (===), object variables are identical if and only if they refer to the same instance of the same class.

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, horst said:

This is not intended, but its previous state is only saved for jpegs, not for png or gif formats.

Thanks Horst

Just tried it with a jpeg and it works a treat.

Any plans to get this working for PNG / GIFs?

Share this post


Link to post
Share on other sites
5 hours ago, joey102030 said:

Thanks Horst

Just tried it with a jpeg and it works a treat.

Any plans to get this working for PNG / GIFs?

Plans yes, - but currently no time. It will need a complete redesign of the storage. Currently it is stored with the original files in IPTC, and thats not supported by PNG and GIF.

  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, tpr said:

 I have no time to investigate further but this fixes it (line 344)


// if ($image->pagefiles === $pagefiles) {
if ($image->pagefiles->page->id === $pagefiles->page->id) {

Perhaps "===" is the culprit? PHP docs says

Have updated it now to version 0.9.17. There was another one pending with this part of the code. I thought I had already comitted it. Sorry!

  • Like 2

Share this post


Link to post
Share on other sites

Having an issue here too after upgrading from PW 3.X to PW 3.0.44

Firstly I was getting an error about the width of a crop so I replaced the entire site>modules>CroppableImage3 folder with the latest 0.9.17

Now I'm getting the following error 

Error: Uncaught Error: Call to a member function getCrop() on null in /var/www/vhosts/site.com/httpdocs/site/templates/blog-post.php:104
Stack trace:
#0 /var/www/vhosts/site.com/httpdocs/wire/core/TemplateFile.php(268): require()
#1 /var/www/vhosts/site.com/httpdocs/wire/core/Wire.php(374): ProcessWire\TemplateFile->___render()
#2 /var/www/vhosts/site.com/httpdocs/wire/core/WireHooks.php(682): ProcessWire\Wire->_callMethod('___render', Array)
#3 /var/www/vhosts/site.com/httpdocs/wire/core/Wire.php(402): ProcessWire\WireHooks->runHooks(Object(ProcessWire\TemplateFile), 'render', Array)
#4 /var/www/vhosts/site.com/httpdocs/wire/modules/PageRender.module(514): ProcessWire\Wire->__call('render', Array)
#5 [internal function]: ProcessWire\PageRender->___renderPage(Object(ProcessWire\HookEvent))
#6 /var/www/vhosts/site.com/httpdocs/wire/core/Wire.php(376): call_user_func_array(Array, Array)
#7 /var/www/vhosts/site.com/httpdocs/wire/core/WireHooks.php(682): ProcessWire\Wire->_callMethod('___ (line 104 of /var/www/vhosts/site.com/httpdocs/site/templates/blog-post.php) 

This error message was shown because: you are logged in as a Superuser. Error has been logged.

Any suggestions on this one?

 

Share this post


Link to post
Share on other sites
On 12/16/2016 at 10:30 AM, tpr said:

Modules refresh?

Yep - worked, thanks.

It was more like 'Modules refresh' X 5 but I got there

Share this post


Link to post
Share on other sites

Anyone using this module with the latest dev (3.051)? After updating from the master branch (3.042 at the time of writing), it no longer points to the full URL of the crops, i.e.

URL in Master: "/site/assets/files/9168/death-of-a-fisherman.675x0-landscape.jpg"
Truncated URL in Dev: "/site/assets/files/9168/"

A modules refresh hasn't fixed this issue.

Share this post


Link to post
Share on other sites
On 30.1.2017 at 11:58 AM, jacmaes said:

Anyone using this module with the latest dev (3.051)? After updating from the master branch (3.042 at the time of writing), it no longer points to the full URL of the crops, i.e.


URL in Master: "/site/assets/files/9168/death-of-a-fisherman.675x0-landscape.jpg"
Truncated URL in Dev: "/site/assets/files/9168/"

A modules refresh hasn't fixed this issue.

Can't reproduce that. All is working as expected with 3.0.52 (fresh install from scratch)

How have you updated the version? Have you tried to clear / recreate other caches too? (Modules-Cache, FileCompilercache, etc.)

Share this post


Link to post
Share on other sites

That truncated URL suggests to me that you are calling an array of images rather than a single image. Is upgrading PW the only thing you did?

  • Like 1

Share this post


Link to post
Share on other sites

@horst Yes, I've refreshed the modules a couple of times, and I've made sure to clear the cache (browser cache + "cache" folder in "assets"). I've tried on three different sites that are very similar, and same problem. 

@adrian Upgrading PW is indeed the only thing I did. Reverting back to the master branch fixes the issue immediately. My field setting is as such: 

field.png

And I'm calling the image this way:

<img alt="<?= $page->title; ?>" src="<?= $page->image->first->getCrop('landscape')->url; ?>">

 

Share this post


Link to post
Share on other sites
On 30/01/2017 at 10:58 AM, jacmaes said:

Anyone using this module with the latest dev (3.051)? After updating from the master branch (3.042 at the time of writing), it no longer points to the full URL of the crops, i.e.


URL in Master: "/site/assets/files/9168/death-of-a-fisherman.675x0-landscape.jpg"
Truncated URL in Dev: "/site/assets/files/9168/"

A modules refresh hasn't fixed this issue.

I just had same issue after an upgrade to 3.0.51 and it couldn't be fixed by flushing the Modules.

 

 

 

Share this post


Link to post
Share on other sites

Has anyone managed to hide the Crop button? I tried with Admin Custom Files but with no success.

EDIT: Ok I did it with Admin Custom Files.

Share this post


Link to post
Share on other sites
On 1/31/2017 at 0:35 PM, Peter Knight said:

I just had same issue after an upgrade to 3.0.51 and it couldn't be fixed by flushing the Modules.

I have the same issue. The module was working great on 3.0.33, then i upgraded to 3.0.52 and the frontend method of getting the crop no longer works;
the images are there in the folders with the suffix, and the backend stuff all works; just can't get the crops to output on the front end for some reason; the method is just returning null;

I have another site on a different server where this is running on 3.0.52 and does work...

Share this post


Link to post
Share on other sites
15 hours ago, Macrura said:

I have the same issue. The module was working great on 3.0.33, then i upgraded to 3.0.52 and the frontend method of getting the crop no longer works;
the images are there in the folders with the suffix, and the backend stuff all works; just can't get the crops to output on the front end for some reason; the method is just returning null;

I have another site on a different server where this is running on 3.0.52 and does work...

On one server it is running after upgrading to 3.0.52, on another one not! This is not really a pattern, or is it one?

@Macrura, can you give me access to that one where it is returning null? I use it on my installs and it works all as expected.

Share this post


Link to post
Share on other sites

one of these was upgraded from the old cropping module to the new one, and one was started on 3x branch, and just added the cropping module; the module was probably installed after the upgrade to 3.0.52; not sure if any of those things make any difference;

I can get you access to the admin and the FTP - i'm assuming you need both; will PM you in a bit.

  • Like 1

Share this post


Link to post
Share on other sites

in the meantime i can see from some quick testing that the getCrop method is getting stuck here:

// return InputfieldCroppableImage3 or null if not found
$inputFieldInstance = $this->_getInputFieldInstance($event);

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Macrura said:

in the meantime i can see from some quick testing that the getCrop method is getting stuck here:

// return InputfieldCroppableImage3 or null if not found
$inputFieldInstance = $this->_getInputFieldInstance($event);

Any chance you are running an old version of the module. That method is no longer used:

https://github.com/horst-n/CroppableImage3/blob/e87b602cffbbdd648a48aa7a4975f927ff58f4d7/FieldtypeCroppableImage3/FieldtypeCroppableImage3.module#L80-L81

  • Like 3

Share this post


Link to post
Share on other sites

ok well yes, i was apparently running an older version (weird, just downloaded this from modules directory), but no idea how i had an out-of-date version, and the upgrades module shows nothing about this module...

so this is fixed, by upgrading manually to the version on github

  • Like 3

Share this post


Link to post
Share on other sites
2 minutes ago, Macrura said:

the upgrades module shows nothing about this module

I wonder if it has anything to do with using a string for the version number? I am switching my modules over to string version numbers as well, so would be good to know if that is the problem?

Share this post


Link to post
Share on other sites

@Macrura thanks, I can confirm that I no longer have the issue after downloading the module from Github manually. 

  • Like 2

Share this post


Link to post
Share on other sites

I guess we need to do some testing, with regards to the version number issue? not sure how to conveniently test it though, but could have a look at the upgrades module and try and see why it doesn't even list the CroppableImage3 module...

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mike Rockett
      Jumplinks for ProcessWire
      Release: 1.5.56
      Composer: rockett/jumplinks
      Jumplinks is an enhanced version of the original ProcessRedirects by Antti Peisa.
      The Process module manages your permanent and temporary redirects (we'll call these "jumplinks" from now on, unless in reference to redirects from another module), useful for when you're migrating over to ProcessWire from another system/platform. Each jumplink supports wildcards, shortening the time needed to create them.
      Unlike similar modules for other platforms, wildcards in Jumplinks are much easier to work with, as Regular Expressions are not fully exposed. Instead, parameters wrapped in curly braces are used - these are described in the documentation.
      Under Development: 2.0, to be powered by FastRoute
      As of version 1.5.0, Jumplinks requires at least ProcessWire 2.6.1 to run.
      View on GitLab
      Download via the Modules Directory
      Read the docs
      Features
      The most prominent features include:
      Basic jumplinks (from one fixed route to another) Parameter-based wildcards with "Smart" equivalents Mapping Collections (for converting ID-based routes to their named-equivalents without the need to create multiple jumplinks) Destination Selectors (for finding and redirecting to pages containing legacy location information) Timed Activation (activate and/or deactivate jumplinks at specific times) 404-Monitor (for creating jumplinks based on 404 hits) Additionally, the following features may come in handy:
      Stale jumplink management Legacy domain support for slow migrations An importer (from CSV or ProcessRedirects) Feedback & Feature Requests
      I’d love to know what you think of this module. Please provide some feedback on the module as a whole, or even regarding smaller things that make it whole. Also, please feel free to submit feature requests and their use-cases.
      Note: Features requested so far have been added to the to-do list, and will be added to 2.0, and not the current dev/master branches.
      Open Source

      Jumplinks is an open-source project, and is free to use. In fact, Jumplinks will always be open-source, and will always remain free to use. Forever. If you would like to support the development of Jumplinks, please consider making a small donation via PayPal.
      Enjoy! :)
    • By BitPoet
      As threatened in Ryan's announcement for 3.0.139, I built a little module for sliding toggles as a replacement for checkboxes. Styling of the input is CSS3 only (with all the usual caveats about older browsers), no JS necessary, and may still be a bit "rough around the edges", so to speak, since I didn't have much time for testing on different devices or brushing things up enough so I'd feel comfortable pushing it to the module directory. But here's the link to the GitHub repo for now:
      InputfieldSlideToggle
      Fieldtype and Inputfield that implements smartphone-style toggles as replacement for checkbox inputs. The visualization is CSS-only, no additional JS necessary.
      Status
      Still very alpha, use with caution!
      Features / Field Settings
      Size
      You can render the toggles in four different sizes: small, medium, large and extra large.
      Off Color
      Currently, "unchecked" toggles can be displayed either in grey (default) or red.
      On Color
      "Checked" toggles can be rendered in one of these colors: blue (default), black, green, grey, orange or red.
      Screenshots

      Some examples with checkbox label


      View all Size and Color Combinations
      Small toggles Medium toggles Big toggles Extra big toggles  









    • By Orkun
      Hi Guys
      I needed to add extended functionalities for the InputfieldDatetime Module (module is from processwire version 2.7.3) because of a Request of Customer.
      So I duplicated the module and placed it under /site/modules/.
      I have added 3 new Settings to the InputfieldDatetime Module.
      1. Day Restriction - Restrict different days based on weekdays selection (e.g. saturday, sunday) - WORKING

       
      2. Time Slots - Define Time slots based on custom Integer Value (max is 60 for 1 hour) - WORKING

       
      3. Time Range Rules per Weekday - Define a minTime and MaxTime per Weekday (e.g. Opening Hours of a Restaurant) - NOT WORKING PROPERLY

       
      The Problem
      Time Slots and Day Restriction working fine so far. But the Time Range Rules per Weekday doesn't work right.
      What should happen is, that when you click on a date, it should update the minTime and maxTime of the Time Select.
      But the change on the select only happens if you select a date 2 times or when you select a date 1 time and then close the datepicker and reopen it again.
      The time select doesn't get change when you select a date 1 time and don't close the picker.
      Here is the whole extended InputfieldDatetime Module.
      The Files that I have changed:
      InputfieldDatetime.module InputfieldDatetime.js jquery-ui-timepicker-addon.js (https://trentrichardson.com/examples/timepicker/) - updated it to the newest version, because minTime and maxTime Option was only available in the new version  
      Thats the Part of the JS that is not working correctly:
      if(datetimerules && datetimerules.length){ options.onSelect = function(date, inst) { var day = $(this).datetimepicker("getDate").getDay(); day = day.toString(); var mintime = $(this).attr('data-weekday'+day+'-mintime'); var maxtime = $(this).attr('data-weekday'+day+'-maxtime'); console.log("weekday: "+day); console.log("minTime: "+mintime); console.log("maxTime: "+maxtime); var optionsAll = $(this).datetimepicker( "option", "all" ); optionsAll.minTime = mintime; optionsAll.maxTime = maxtime; $(this).datetimepicker('destroy'); $(this).datetimepicker(optionsAll); $(this).datetimepicker('refresh'); //$.datepicker._selectDate($(this).attr("id"),date); //$.datepicker._base_getDateDatepicker(); // var inst = $.datepicker._getInst($(this)); // $.datepicker._updateDatepicker(inst); /*$(this).datetimepicker('destroy'); InputfieldDatetimeDatepicker($(this), mintime, maxtime); $(this).datetimepicker('refresh'); */ // $(this).datetimepicker('option', {minTime: mintime, maxTime: maxtime}); } } Can you have a look and find out what the Problem is?
      InputfieldDatetime.zip
       
      Kind Regards
      Orkun
    • By teppo
      This module tracks changes, additions, removals etc. of public (as in "not under admin") pages of your site. Like it's name says, it doesn't attempt to be a version control system or anything like that - just a log of what's happened.
      At the moment it's still a work in progress and will most likely be a victim of many ruthless this-won't-work-let's-try-that-instead cycles, but I believe I've nailed basic functionality well enough to post it here.. so, once again, I'll be happy to hear any comments you folks can provide
      https://modules.processwire.com/modules/process-changelog/
      https://github.com/teppokoivula/ProcessChangelog
      How does it work?
      Exactly like it's (sort of) predecessor, Process Changelog actually consists of two modules: Process Changelog and Process Changelog Hooks. Hooks module exists only to serve main module by hooking into various functions within Pages class, collecting data of performed operations, refining it and keeping up a log of events in it's own custom database table (process_changelog.) Visible part is managed by Process Changelog, which provides users a (relatively) pretty view of the contents of said log table.
      How do you use it?
      When installed this module adds new page called Changelog under Admin > Setup which provides you with a table view of collected data and basic filtering tools See attached screenshots to get a general idea about what that page should look like after a while.
      For detailed installation instructions etc. see README.md.
       


    • By Gadgetto
      Status update links (inside this thread) for SnipWire development will be always posted here:
      2019-08-08
      2019-06-15
      2019-06-02
      2019-05-25
      If you are interested, you can test the current state of development:
      https://github.com/gadgetto/SnipWire
      Please note that the software is not yet intended for use in a production system (alpha version).
      If you like, you can also submit feature requests and suggestions for improvement. I also accept pull requests.
      ---- INITIAL POST FROM 2019-05-25 ----
      I wanted to let you know that I am currently working on a new ProcessWire module that fully integrates the Snipcart Shopping Cart System into ProcessWire. (this is a customer project, so I had to postpone the development of my other module GroupMailer).
      The new module SnipWire offers full integration of the Snipcart Shopping Cart System into ProcessWire.
      Here are some highlights:
      simple setup with (optional) pre-installed templates, product fields, sample products (quasi a complete shop system to get started immediately) store dashboard with all data from the snipcart system (no change to the snipcart dashboard itself required) Integrated REST API for controlling and querying snipcart data webhooks to trigger events from Snipcart (new order, new customer, etc.) multi currency support self-defined/configurable tax rates etc. Development is already well advanced and I plan to release the module in the next 2-3 months.
      I'm not sure yet if this will be a "Pro" module or if it will be made available for free.
      I would be grateful for suggestions and hints!
      (please have a look at the screenshots to get an idea what I'm talking about)
       




×
×
  • Create New...