Jump to content
Mats

Module: Leaflet Map

Recommended Posts

I reinstalled the module, and now its working.
When I setup the repeater to allways open the items the map and magnifying glass icon seems to work.

Thanks for your help!

Share this post


Link to post
Share on other sites

is it possible to use an image filed for the markers instead of the fontawesome option?
my code looks like this (it works with the FontIconPicker):
 

<?php
    $options = array(
    'height' => '100%',
    'markerIconColour' => 'black',
    'popupFormatter' => function($page) {
        $out[] = "<p>$page->headline</p>";
        return implode($out);
    },
    'markerFormatter' => function($page, $marker_options) {
        $marker_options['icon'] = $page->marker_icon; // Override the default icon for this marker.
        return $marker_options;
    }
);
      $items = $lage->map_repeater; 
echo $map->render($items, 'map', $options); 
                 ?>

 

Share this post


Link to post
Share on other sites

Hi!

I have problems displaying the map. It is not showing up.

I installed all the modules, setup the field and the template and put the following in my template file (home.php with delayed output):

echo $page->map->address;   // outputs the address you entered
echo $page->map->lat;       // outputs the latitude
echo $page->map->lng;       // outputs the longitude
echo $page->map->zoom;      // outputs the zoom level
$map = wire('modules')->get('MarkupLeafletMap');
echo $map->getLeafletMapHeaderLines();
echo $map->render($page, 'map');

Address, lat, lng and zoom are printed out, but there is no map. What am I doing wrong? I am not a coder.

Looks like sonething is messed up, the source code of the page looks like this

leafletmarkersource.png

Is that the correct? It is the same problem as with the google map marker field :mellow:

Share this post


Link to post
Share on other sites

fliwatuet: Looking at the source, it seems you are echoing the map outside of your body and html elements.

Share this post


Link to post
Share on other sites

This is my home.php:
 

<?php namespace ProcessWire;

echo $page->map->address;   // outputs the address you entered
echo $page->map->lat;       // outputs the latitude
echo $page->map->lng;       // outputs the longitude
echo $page->map->zoom;      // outputs the zoom level
$map = wire('modules')->get('MarkupLeafletMap');
echo $map->getLeafletMapHeaderLines();
echo $map->render($page, 'map');

// home.php (homepage) template file.
// See README.txt for more information

// Primary content is the page body copy and navigation to children.
// See the _func.php file for the renderNav() function example
$content = $page->body . renderNav($page->children);

// if there are images, lets choose one to output in the sidebar
if(count($page->images)) {
    // if the page has images on it, grab one of them randomly...
    $image = $page->images->getRandom();
    // resize it to 400 pixels wide
    $image = $image->width(400);
    // output the image at the top of the sidebar...
    $sidebar = "<img src='$image->url' alt='$image->description' />";
    // ...and append sidebar text under the image
    $sidebar .= $page->sidebar;    
} else {
    // no images...
    // append sidebar text if the page has it
    $sidebar = $page->sidebar;
}

 

Share this post


Link to post
Share on other sites

I tried. But whenever I put

<?php
$map = wire('modules')->get('MarkupLeafletMap');
echo $map->getLeafletMapHeaderLines();
?>

in the head section of _main.php I get this error message:
 

Error: Uncaught Error: Call to a member function render() on null in /home/html/portal.dev/site/templates/home.php:14
Stack trace:
#0 /home/html/portal.dev/wire/core/TemplateFile.php(268): require()
#1 [internal function]: ProcessWire\TemplateFile->___render()
#2 /home/html/portal.dev/wire/core/Wire.php(374): call_user_func_array(Array, Array)
#3 /home/html/portal.dev/wire/core/WireHooks.php(549): ProcessWire\Wire->_callMethod('___render', Array)
#4 /home/html/portal.dev/wire/core/Wire.php(399): ProcessWire\WireHooks->runHooks(Object(ProcessWire\TemplateFile), 'render', Array)
#5 /home/html/portal.dev/wire/modules/PageRender.module(515): ProcessWire\Wire->__call('render', Array)
#6 [internal function]: ProcessWire\PageRender->___renderPage(Object(ProcessWire\HookEvent))
#7 /home/html/portal.dev/wire/core/Wire.php(374): call_user_func_array(Array, Array)
#8 /home/html/portal.dev/wire/core/WireHooks.php(549): ProcessWire\Wire->_callMethod( (line 14 of /home/html/portal.dev/site/templates/home.php)

This error message was shown because: you are logged in as a Superuser. Error has been logged.

 

Share this post


Link to post
Share on other sites

@fliwatuet could you post the content of the head section of your _main.php please. It's fine to redact anything you feel is private if you need to.

Also, I use this module on a PHP7 installation and seem to have no problems with it.

  • Like 1

Share this post


Link to post
Share on other sites

This is the original file (I took out the comments):
 

<?php namespace ProcessWire;

?><!DOCTYPE html>
<html lang="en">
<head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <title><?php echo $title; ?></title>
    <meta name="description" content="<?php echo $page->summary; ?>" />
    <link href='//fonts.googleapis.com/css?family=Lusitana:400,700|Quattrocento:400,700' rel='stylesheet' type='text/css' />
    <link rel="stylesheet" type="text/css" href="<?php echo $config->urls->templates?>styles/main.css" />
</head>

When I add

    <?php
       $map = wire('modules')->get('MarkupLeafletMap');
       echo $map->getLeafletMapHeaderLines();
    ?>

right before </head> I still get the error message mentioned above when I use "echo $map->render($page, 'map');" in home.php!

BTW: the map in the backend is working.

Share this post


Link to post
Share on other sites

@fliwatuet

Sounds like $map is undefined in the home.php file. Please try this. In _main.php...

<!DOCTYPE html>
<html lang="en">
<head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <title><?php echo $title; ?></title>
    <meta name="description" content="<?php echo $page->summary; ?>" />
    <link href='//fonts.googleapis.com/css?family=Lusitana:400,700|Quattrocento:400,700' rel='stylesheet' type='text/css' />
    <link rel="stylesheet" type="text/css" href="<?php echo $config->urls->templates?>styles/main.css" />
<?php
    $map = wire('modules')->get('MarkupLeafletMap');
    echo $map->getLeafletMapHeaderLines();
?>
</head>

in home.php...

<?php
    $map = wire('modules')->get('MarkupLeafletMap');
    echo $map->render($page, 'map');
?>

Also, are you sure your field is actually called 'map'?

Share this post


Link to post
Share on other sites

Yes, the field is called map.

This is working fine:

$page->map->address
$page->map->lat
$page->map->lng
$page->map->zoom

 

I changed the code to your suggestion, now there is no error message anymore, but still no map...

Share this post


Link to post
Share on other sites

Does the page you are viewing using the home template actually have a value for the map field saved in it? Scrub that, it sounds like it does.

Share this post


Link to post
Share on other sites

Ok, if you inspect the page displaying the map with your browser tools, are there any JS errors or 404s showing up for the linked resources?

Share this post


Link to post
Share on other sites
7 minutes ago, netcarver said:

Does the page you are viewing using the home template actually have a value for the map field saved in it?

What do you mean? I added the map field to the home template and then edited the home page, put an address into the map field. I then edited the home.php template file and the _main.php.

No errors as far as i can see.

Share this post


Link to post
Share on other sites

Hello @netcarver I'm having the same problem @fliwatuet reported above.

I supposed I've added everything correctly:

in my _init.php:

$map = $modules->get('MarkupLeafletMap');

inside the <head></head> of my top_nav.php:

echo $map->getLeafletMapHeaderLines();

and then in my template file:

<?php echo $map->render($page, 'map'); ?> // yes, the field is called "map"

Inspecting the code I see all the css and js files in the <head> after this comment:

<!-- Styles supporting the use of Leaflet.js -->
.. css and js are here ..

And the correct <div> is generated by the module:

<div id="mleafletmap1" class="MarkupLeafletMap" style="width: 100%; height: 500px;"></div>

...but unfortunately the map is blank on the front-page of the site. 

I'm working on localhost on ProcessWire 2.8.35.

....got suggestions for me?

Share this post


Link to post
Share on other sites

I have also this problem sometimes (especially when I am not logged in). Could it be possible that there is a limit on the Leaflet service which supports only a specific amount of requests to a certain domain?

Share this post


Link to post
Share on other sites

If you open up the inspection tools in your browser and reload the page, are there any resources that fail to load or any js errors reported?

Share this post


Link to post
Share on other sites

Thanks for the reply @netcarver. I appreciate.

No errors anywhere in the console/inspector.

I've also tried to manually point the module to the 1.0.2 version of the leaflet JS and css (changhing both unpkg.com urls) but without luck, same blank div.

Have you got time to try to reproduce this strange behaviour?

 

 

Share this post


Link to post
Share on other sites

@3fingers So, all the resources are loading - and there are no errors - and there is no output? Ok - is this on a local development box or on a server I can take a look at?

Edited to add: I have seen a correctly set-up map fail to load if a browser is blocking scripts using an extension like noscript/umatrix/ublock-origin etc.

  • Like 1

Share this post


Link to post
Share on other sites

...And there was the problem! I got an ad-blocker installed causing this issue on chrome. Unfortunately nowadays a lot of people have them turned on.

I'm going to investigate for a workaround, but It is kind of a remarkable issue for my project :(

In the meantime thanks for your support.

  • Like 1

Share this post


Link to post
Share on other sites

Hello, I have a question if this module can do the following.

I have a turtle that lives in one ore more states (US) or countries. I want to show this on a map on the page about that turtle. The input has to based on just the name of the state or country as I want to use the same also just for a text reference (like a tag).

Besides that I want a big map on a sperate page that combines all the turtles and shows which are located where with a hoover link to that turtle (page).

The final step is a page per state or country that show the map of that region on top and all related posts below...

It's a bit ambitious but I had to ask...

Share this post


Link to post
Share on other sites
On 30/12/2016 at 2:12 PM, webhoes said:

Hello, I have a question if this module can do the following.

I have a turtle that lives in one ore more states (US) or countries. I want to show this on a map on the page about that turtle. The input has to based on just the name of the state or country as I want to use the same also just for a text reference (like a tag).

Besides that I want a big map on a sperate page that combines all the turtles and shows which are located where with a hoover link to that turtle (page).

The final step is a page per state or country that show the map of that region on top and all related posts below...

It's a bit ambitious but I had to ask...

All possible.....for the maps you can select  what items you show on your map based on any field (for your specific turtle page):

$items = $pages->find("marker_colour=red");

My code here:

// LEAFLET MAP WITH BICYCLE ICONS
$items = $pages->find("marker_icon=bicycle");
$map = wire('modules')->get('MarkupLeafletMap');
$options = array(
    'markerFormatter' => function($page, $marker_options) {
              if ($page->marker_icon->title) {
                        $marker_options['icon'] = $page->marker_icon->title;
                    }
                    if ($page->marker_colour->title) {
                        $marker_options['markerColor'] = $page->marker_colour->title;
                    }
                    // And the icon colour. This is another text field. Colour values like White, Black or an RGB value are ok here.
                    if ($page->marker_icon_colour->title) {
                        $marker_options['iconColor'] = $page->marker_icon_colour->title;
                    }    
        return $marker_options;
    },
    'popupFormatter' => function($page) {
        $out[] = "<strong>$page->summary</strong>";
        $out[] = "<a href=\"$page->url\" ><img src=\"{$page->summary_image->url}\" class=\"image fit\"  /></a>";
        $out[] = "<img src=\"{$page->summary_image->url}\" width=\"200\" height=\"200\" />"; // ** NB: Use escaped double quotes if HTML attributes needed **
        return implode('<br/>', $out);
    }
);

 

and for items from different categories (species for your big map):

$items = $pages->find("marker_colour=red|green|blue");

 

Remember you can use:

'red', 'darkred', 'orange', 'green', 'darkgreen', 'blue', 'purple', 'darkpuple' & 'cadetblue'

and any icons from your version of Awesome icons: http://fontawesome.io/icons/

 

Beneath each map you can summarise revevant posts for each region or each species with the page find function based on an "options field type":

$features = $pages->find('species=loggerhead');

 

  • Like 1

Share this post


Link to post
Share on other sites

Does anyone know how you can populate the address field from another field on the template ? 

Eg; the title field is holding a country name, therefore would be nice if user does not need to type in country again, map just populates automagically.

Thx,

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Robin S
      A community member raised a question and I thought a new sanitizer method for the purpose would be useful, hence...
      Sanitizer Transliterate
      Adds a transliterate method to $sanitizer that performs character replacements as defined in the module config. The default character replacements are based on the defaults from InputfieldPageName, but with uppercase characters included too.
      Usage
      Install the Sanitizer Transliterate module.
      Customise the character replacements in the module config as needed.
      Use the sanitizer on strings like so:
      $transliterated_string = $sanitizer->transliterate($string);
       
      https://github.com/Toutouwai/SanitizerTransliterate
      https://modules.processwire.com/modules/sanitizer-transliterate/
       
    • By dimitrios
      Hello,
      this module can publish content of a Processwire page on a Facebook page, triggered by saving the Processwire page.
      To set it up, configure the module with a Facebook app ID, secret and a Page ID. Following is additional configuration on Facebook for developers:
      Minimum Required Facebook App configuration:
      on Settings -> Basics, provide the App Domains, provide the Site URL, on Settings -> Advanced, set the API version to 2.10, add Product: Facebook Login, on Facebook Login -> Settings, set Client OAuth Login: Yes, set Web OAuth Login: Yes, set Enforce HTTPS: Yes, add "http://www.example.com/processwire/page/" to field Valid OAuth Redirect URIs. This module is configurable as follows:
      Templates: posts can take place only for pages with the defined templates. On/Off switch: specify a checkbox field that will not allow the post if checked. Specify a message and/or an image for the post.
      Usage
      edit the desired PW page and save; it will post right after the initial Facebook log in and permission granting. After that, an access token is kept.
       
      Download
      PW module directory: http://modules.processwire.com/modules/auto-fb-post/ Github: https://github.com/kastrind/AutoFbPost   Note: Facebook SDK for PHP is utilized.


    • By thomasaull
      I created a little helper module to trigger a CI pipeline when your website has been changed. It's quite simple and works like this: As soon as you save a page the module sets a Boolean via a pages save after hook. Once a day via LazyCron the module checks if the Boolean is set and sends a POST Request to a configurable Webhook URL.
      Some ideas to extend this:
      make request type configurable (GET, POST) make the module trigger at a specified time (probably only possible with a server cronjob) trigger manually Anything else? If there's interest, I might put in some more functionality. Let me know what you're interested in. Until then, maybe it is useful for a couple of people 🙂
      Github Repo: https://github.com/thomasaull/CiTrigger
    • By Robin S
      I created this module a while ago and never got around to publicising it, but it has been outed in the latest PW Weekly so here goes the support thread...
      Unique Image Variations
      Ensures that all ImageSizer options and focus settings affect image variation filenames.

      Background
      When using methods that produce image variations such as Pageimage::size(), ProcessWire includes some of the ImageSizer settings (height, width, cropping location, etc) in the variation filename. This is useful so that if you change these settings in your size() call a new variation is generated and you see this variation on the front-end.
      However, ProcessWire does not include several of the other ImageSizer settings in the variation filename:
      upscaling cropping, when set to false or a blank string interlace sharpening quality hidpi quality focus (whether any saved focus area for an image should affect cropping) focus data (the top/left/zoom data for the focus area) This means that if you change any of these settings, either in $config->imageSizerOptions or in an $options array passed to a method like size(), and you already have variations at the requested size/crop, then ProcessWire will not create new variations and will continue to serve the old variations. In other words you won't see the effect of your changed ImageSizer options on the front-end until you delete the old variations.
      Features
      The Unique Image Variations module ensures that any changes to ImageSizer options and any changes to the focus area made in Page Edit are reflected in the variation filename, so new variations will always be generated and displayed on the front-end.
      Installation
      Install the Unique Image Variations module.
      In the module config, set the ImageSizer options that you want to include in image variation filenames.
      Warnings
      Installing the module (and keeping one or more of the options selected in the module config) will cause all existing image variations to be regenerated the next time they are requested. If you have an existing website with a large number of images you may not want the performance impact of that. The module is perhaps best suited to new sites where image variations have not yet been generated.
      Similarly, if you change the module config settings on an existing site then all image variations will be regenerated the next time they are requested.
      If you think you might want to change an ImageSizer option in the future (I'm thinking here primarily of options such as interlace that are typically set in $config->imageSizerOptions) and would not want that change to cause existing image variations to be regenerated then best to not include that option in the module config after you first install the module.
       
      https://github.com/Toutouwai/UniqueImageVariations
      https://modules.processwire.com/modules/unique-image-variations/
    • By Sebi
      I've created a small module which lets you define a timestamp after which a page should be accessible. In addition you can define a timestamp when the release should end and the page should not be accessable any more.
      ProcessWire-Module: http://modules.processwire.com/modules/page-access-releasetime/
      Github: https://github.com/Sebiworld/PageAccessReleasetime
      Usage
      PageAccessReleasetime can be installed like every other module in ProcessWire. Check the following guide for detailed information: How-To Install or Uninstall Modules
      After that, you will find checkboxes for activating the releasetime-fields at the settings-tab of each page. You don't need to add the fields to your templates manually.
      Check e.g. the checkbox "Activate Releasetime from?" and fill in a date in the future. The page will not be accessable for your users until the given date is reached.
      If you have $config->pagefileSecure = true, the module will protect files of unreleased pages as well.
      How it works
      This module hooks into Page::viewable to prevent users to access unreleased pages:
      public function hookPageViewable($event) { $page = $event->object; $viewable = $event->return; if($viewable){ // If the page would be viewable, additionally check Releasetime and User-Permission $viewable = $this->canUserSee($page); } $event->return = $viewable; } To prevent access to the files of unreleased pages, we hook into Page::isPublic and ProcessPageView::sendFile.
      public function hookPageIsPublic($e) { $page = $e->object; if($e->return && $this->isReleaseTimeSet($page)) { $e->return = false; } } The site/assets/files/ directory of pages, which isPublic() returns false, will get a '-' as prefix. This indicates ProcessWire (with activated $config->pagefileSecure) to check the file's permissions via PHP before delivering it to the client.
      The check wether a not-public file should be accessable happens in ProcessPageView::sendFile. We throw an 404 Exception if the current user must not see the file.
      public function hookProcessPageViewSendFile($e) { $page = $e->arguments[0]; if(!$this->canUserSee($page)) { throw new Wire404Exception('File not found'); } } Additionally we hook into ProcessPageEdit::buildForm to add the PageAccessReleasetime fields to each page and move them to the settings tab.
      Limitations
      In the current version, releasetime-protected pages will appear in wire('pages')->find() queries. If you want to display a list of pages, where pages could be releasetime-protected, you should double-check with $page->viewable() wether the page can be accessed. $page->viewable() returns false, if the page is not released yet.
      If you have an idea how unreleased pages can be filtered out of ProcessWire selector queries, feel free to write an issue, comment or make a pull request!
×
×
  • Create New...