Jump to content

dab

Members
  • Posts

    129
  • Joined

  • Last visited

Everything posted by dab

  1. I've been using this: 7g firewall with my Processwire sites: https://perishablepress.com/7g-firewall/ Seems to be working effectively.
  2. @jor Not sure if this is the correct way, but on my map template I wrap my code with: if($page->marker->address) { } e.g. if($page->marker->address) { $map = wire('modules')->get('MarkupLeafletMap'); $options = array( 'markerFormatter' => function($page, $marker_options) { if ($page->marker_icon->title) { $marker_options['icon'] = $page->marker_icon->title; } if ($page->marker_colour->title) { $marker_options['markerColor'] = $page->marker_colour->title; } // And the icon colour. This is another text field. Colour values like White, Black or an RGB value are ok here. if ($page->marker_icon_colour->title) { $marker_options['iconColor'] = $page->marker_icon_colour->title; } return $marker_options; }, 'popupFormatter' => function($page) { $out[] = "<strong>$page->headline</strong>"; return implode('<br/>', $out); } ); $content.= $map->render($page, 'marker', $options); } If no address is entered, no map is shown.
  3. Have a look at delayed output strategy. You have one main "template"(_main.php) & can then simply create a new template for a sub-section page where you just add code for regions/sections of your _main template where you want to show different content (summaries, other content etc.). I found the intermediate templates a good starting point to see how _main.php & e.g. home.php or basic.php interact. Once you've learnt this, look at markup regions - super powerful (once mastered)!
  4. @adrianThanks for the speedy reply. Most odd, WHM/Cpanel was reporting PHP 7.2, but I double checked with a "phpinfo" file & it showed PHP5.6! I reset the PHP version to PHP 7.2.32 & it's cleared the error. Apologies for the incorrect info & thanks for the fix for <7 (& for such a great module)!
  5. Has anyone come across this error? Parse error: syntax error, unexpected ':', expecting ';' or '{' in /home/********/public_html/site/assets/cache/FileCompiler/site/modules/TracyDebugger/includes/PwApiData.php on line 516 PW 3.0.148, Tracy Debugger 4.21.20, PHP 7.2. line 516 is private function phpdoc_params(ReflectionMethod $method) : array { Have tried a reinstall & cleared complied files from > Modules. No errors on other sites on same server with same setup.
  6. @Robin S thank you you are lifesaver - I missed this completely. With the addition to the hook it's working perfectly now!
  7. I noted that you can't add an unpublished page to the list of pages a user can edit. It results in error: "Unpublished page /en/members/test/ is not allowed in field "Pages user may edit". To allow unpublished pages, edit the “editable_pages” field and see the setting on the “Details” tab." I'm not sure where to find this - or if it is applicable as Page Edit Per User is a hook in to the system.
  8. @ryan I love this module, makes it super easy to allow users access to edit their own pages, thank you! I can't find a way to allow users to publish/unpublish their pages.... I added these lines to the module public function init() { $this->addHookAfter('Page::publishable', $this, 'hookPageEditable'); } /** * Page::publishable hook * */ public function hookPagePublishable($event) { if($event->return) return; $event->return = $this->onMyBranch($event->object); } & bingo, an "unpublish" button appears & a user can unpublish thier page. However, if they do, they lose access to it (it disappears from the page tree) & only a superuser (site admin) and republish it. Please can you help with this - page publish/unpublish would make this module just perfect! Many thanks 🙂
  9. Many thanks! Both worked. I had tried with {....} but obviously also needed the double quotes. I was outputting directly to .csv which was clearly not the best way to debug! Thanks again.
  10. Stumped with this....please can anyone help? I'm trying to find pages with a field that matches the search page's parent's title. This works $items = $pages->find('template=items-ordered,supplier=Acme Biscuits'); Not this...(did no find any pages). $items = $pages->find('template=items-ordered,supplier=$page->parent->title'); With thanks 🙂
  11. Thanks, very good to hear of other's experiences. I looked at Snipcart, but was put off by the fees (2%/ transactions + gateway fees) just made it too expensive. Yes, back end of foxy is ugly & I needed some help with some aspects of the coding, but have found it usable for simple ecommerce projects.
  12. I've used Padloper for two Processwire sites, but not found it suitable for other projects due to only working with Paypal & Stripe payment gateways; neither being the client's gateway of choice. More recently I've used Foxycart; now on 4 ecommerce sites. I've really enjoyed the challenge integrating it into my sites with the help of some amazing Processwire forum members here 🙂 (XML & JSON datafeeds). It's compatible with over 100 payment gateways & the datafeeds can be used for updating stock levels, recording orders on to your Processwire site. I think it's worth a look if your project needs to use a specific payment gateway.
  13. Sorry for the delay getting back. Let me know which bits you need help with & I can post up some code. You can make a start with the Foxy.io code from here: https://docs.foxycart.com/v/2.0/start
  14. Snipcart looks nice (though I've not tried it). I looked at it & the 2% of transactions fees on top of payment gateway fees put me off, plus only a few payment gateways are supported. I've used Foxy.io (Foxy Cart) with ProcessWire on a site & it works really well*. Fees are low (approx £16/month) & loads of payment gateways are supported. I'm happy so post/share code if anyone needs it. *Big thanks go to both @netcarver an @Macrura for helping me with some of the datafeed integrations back to ProcessWire.
  15. I'm having problems adding a second category to check for emails & save to pages no PW errors (or php errors). On "save" no new Email Category is added. Anyone else encountering difficulties? I'm using ProcessEmailToPage v. 1.3.3, PW 3.0.123 & php PHP 7.2. Thanks Nick
  16. I used this to get the access token: https://api.instagram.com/oauth/authorize/?client_id=CLIENT-ID&redirect_uri=https://www.yourdomainhere.co.uk/processwire/module/edit?name=InstagramFeed&response_type=code 1. Replace CLIENT-ID with your own CLIENT-ID code 2. I removed the trailing slash off suggested code on Processwire Module instructions http://page.dev/processwire/module/edit?name=InstagramFeed/ Works OK for me, but I am getting error code "[InstagramFeed]: No user" too, but otherwise feed working OK.
  17. This works beautifully, thanks. & if any users need help on configuring their DNS (to point 2 domains to a single install of PW) on WHM use the >cPanel > Domains > Aliases function to add your extra domains (after enabling on > Server Configuration > Tweak Settings > Domains > "Allow users to park subdomains of the server’s hostname".
  18. @psy, thanks....so sorry...... PushAlert said I had to download the .js files. Apologies for not following the README properly - thanks for being so patient!
  19. @psy, all resolved. Now working beautifully thank you @psy! Make sure, if you recreate your website entry on the PushAlert site you download a FRESH copy of the manifest.json & sw.js (oh dear, I thought I had!). The PushAlert support team were super fast & very friendly if you run in to any problems. Thank you PushAlert.
  20. @psy, many thanks, with the latest update, I can see alerts are now being sent from Processwire to pushalert.co! Thank you 🙂🙂. My next step is to find out why push deliveries back to the subscribers are shown as "attempted" & not yet "delivered".
  21. Thanks @psy, all template files are 644 - not run in to permissions problems before. Not to worry re this one. With thanks.
  22. @psy, thanks for getting back. >field_PushAlert was not found ah yes, resolved when i used lowercase for the Pushalert field name on a later try (hope I didn't miss this instruction - sorry). >push_alert_endpoint.php template. Was this created? Yes, that was created OK. I'm thinking the lack of alerts might be PHP version related. I'll await any feedback from other users. Once again, huge thanks for all the work on the module - it's absolutely fab 🙂.
  23. @psy very excited to see this, thank you! I had a few problems, on install: /processwire/setup/field/edit?id=146 SQLSTATE[42S02]: Base table or view not found: 1146 Table mydominaname_processwire.field_PushAlert' doesn't exist (in /site/modules/PushAlert/PushAlert.module line 347) and on trying to uninstall: /processwire/module/edit?name=PushAlert&collap… Method WireFileTools::unlink does not exist or is not callable in this context (in /wire/core/Wire.php line 519) I couldn't get any notification sent on publishing a page with a FieldtypePushAlert field on it, but alerts work from the PushAlert website. Has anyone else tried & had any issues/got any pointers? I've checked modsecurity on the server & no errors & am running php 5.6.40. Thanks Nick.
×
×
  • Create New...