Jump to content
justb3a

Simple Contact Form

Recommended Posts

@Travo: Thanks for the PR, I applied it to the develop and master branch. If you want to use the module with ProcessWire 3.x, you have to checkout the feature/devns branch of the module.

  • Like 2

Share this post


Link to post
Share on other sites

Hi there,

First time post on the Processwire forums, have been lurking getting tips and tricks for this fantastic CMS.

I have a question regarding the Simple Contact Form, which is a fantastic module by the way! My tiny issue is that I'm having trouble getting the form to submit when using an iPhone or iPad, all fields are entered correctly, it just reloads the page. Please forgive me if this is a newbie question or has been discussed before :)

Share this post


Link to post
Share on other sites

Hi @darcemac and welcome to ProcessWire!

I assume you're using ProcessWire version 2.x. If the page reloads: are there any messages that something is missing? If there isn't any hint at all, I guess the submission is treated as spam. Please check the simplecontactform log file to receive detailed information about what's missing. I know, this isn't the best behaviour and I changed it already in the new version supporting ProcessWire 3.x.

Share this post


Link to post
Share on other sites

Hi @darcemac and welcome to ProcessWire!

I assume you're using ProcessWire version 2.x. If the page reloads: are there any messages that something is missing? If there isn't any hint at all, I guess the submission is treated as spam. Please check the simplecontactform log file to receive detailed information about what's missing. I know, this isn't the best behaviour and I changed it already in the new version supporting ProcessWire 3.x.

Hi @justb3a, 

Thanks for the quick response, really appreciate it!

There aren't any error messages, just a clean page refresh. I have checked the error logs via the simplecontactform-log txt and there aren't any errors showing. 

I thought it might be because the IOS versions were a bit old. I will look into updating to ProcessWire 3.x to fix this, just scared of breaking things :)

Cheers for your help!

Share this post


Link to post
Share on other sites

I'm using this module with PW 2.7.2.

When submitting a form I get a success message but in the LOG file it says  [ERROR] Mail has not been sent to ... thus, the message is never delivered.

Note: I am running PW on localhost via XAMPP. Does this module work under this conditions?

Thanks in advance.

Share this post


Link to post
Share on other sites
7 hours ago, Stefanowitsch said:

Note: I am running PW on localhost via XAMPP.

It's likely your problem is due to a XAMPP/sendmail configuration issue rather than the module. You can rule out the module by attempting to send a test email using PHP's mail() function.

<?php
$subject="Test mail";
$to="myaddress@somedomain.com";
$body="This is a test mail";
if (mail($to,$subject,$body)) {
    echo "Mail sent successfully.";
} else {
    echo "Mail not sent.";
}

I found I had to jump through some hoops to get mail working in XAMPP. Here are some notes I made for getting mail to send via Gmail's SMTP server.

Quote

php.ini
-------
SMTP=smtp.gmail.com
smtp_port=587
sendmail_from=myaddress@gmail.com
sendmail_path="\"D:\xampp\sendmail\sendmail.exe\" -t"


sendmail.ini
-------
smtp_server=smtp.gmail.com
smtp_port=587
smtp_ssl=tls
auth_username=myaddress@gmail.com
auth_password=mypassword
force_sender=myaddress@gmail.com


sendmail.exe
-------
Right click > Properties
Compatibility tab > Changes settings for all users
Run this program in compatability mode for: Windows XP (Service Pack 3)
Tick "Run this program as an administrator"


Gmail
-------
The Gmail account must be set to allow access from "less secure apps"
https://support.google.com/accounts/answer/6010255

 

  • Like 2

Share this post


Link to post
Share on other sites

new version generates error:

Class 'ProcessWire\WireData' not found

on line 22 in SimpleContactForm.module

Share this post


Link to post
Share on other sites

Hi,

I installed  simple contact form module and Wire Mail Smtp module. they are working fine.

What i want to learn is

1- how can i use ajax? i tried example at the tutorial but not working on me. there must be something related with class names, i am not good at this.

 <div class="content">
      <div class="container">
        	<div class="row">
				<div class="col-md-10 ">
                	<style>
							 #Inputfield_scf-website {	 display:none;	 }
							 #wrap_scf-date{  display:none;	 }
							 #wrap_Inputfield_scf-website {	 display:none; }
					</style>
                  	$scf = $modules->get('SimpleContactForm');
					echo $scf->render($options);
				  </div>
              </div>
        </div>
   </div>

this is my code

for ajax code

if ($('.js-simplecontactform').length) {
  $.simplecontactform($('.js-simplecontactform'));
}

and for php

<?php
if ($config->ajax) {
  $modules->get('SimpleContactForm')->render();
} else {
  // html, header, nav etc.
  $modules->get('SimpleContactForm')->render();
  // html, footer etc.
}

 there must be some modifications to work this code. but i dont know how to do. 

my web site: https://www.sediremlak.com/en/contact/

 

 

 

 

 

2- second question is how can i use my own css for simple contact form?

is there a easy way to modify css? 

when i just put echo $scf->render($options); 

default options are rendering. is there a way to use instead of render function?

 

sorry for my dummy questions. i would be appriciate if any one help me.

 

Share this post


Link to post
Share on other sites

@Kemal It's not that easy how to answer your questions best. It seems that you're missing some basic knowledge about css/js. I wouldn't recommend to write inline styles. I would suggest using a single css file (or put it in the header of the html file). You can include this css file after the bootstrap one, this way you're able to override styles and add your own. Addressing the elements using classes lets you change the css. This module doesn't add any css, it just outputs a html structure with some basic classes. You can change the classes / html structure by passing different `$options`. I don't know why the ajax call isn't working, I guess the click on the submit button isn't triggered. I would add some debug statements to the javascript.

Share this post


Link to post
Share on other sites

Hi guys, 

Getting the following error: [FAILURE] Number of fields does not match. 

Any thoughts?

I have the following fields in Simple Contact Form settings:

scf_fistname
scf_surname
scf_email
scf_company
scf_enquiry

and in the message template:

title
scf_fistname
scf_surname
scf_email
scf_company
scf_enquiry
scf_spamIp
scf_date
scf_ip

I'm not however saving messages at the moment.

Thank you for any help

Share this post


Link to post
Share on other sites

Look at your  anitSpamCountAdditionalInputs. I have not played with the version that is compatible for PW 3.0, but I run into this message often and usually its just an oversite of fields. Also in your markup, make sure you name fields match those in the template or else you will get that message.

Share this post


Link to post
Share on other sites
1 hour ago, RyanJ said:

Look at your  anitSpamCountAdditionalInputs. I have not played with the version that is compatible for PW 3.0, but I run into this message often and usually its just an oversite of fields. Also in your markup, make sure you name fields match those in the template or else you will get that message.

Hey @RyanJ Where is this field/setting? I don't see it anywhere.

Share this post


Link to post
Share on other sites

It may not be in the latest version, but if so, I am assuming it would be in the same place in the modules settings page at the bottom under Spam. By default there are 5 spam fields. From your list, you are missing a few (again, this may have changed in the latest version of the module). Glancing at the latest documentation, it looks like you are missing " scf-website " field.  

Also, check the names on your input fields in your markup. A typo could throw the error too I believe. 

Share this post


Link to post
Share on other sites

Thanks for this info @RyanJ I haven't had chance to go over this as am just on another project, but will take a look later and see if I can get it working with your pointers!

Share this post


Link to post
Share on other sites

First of all, thank you for this great module!!

I want to test my form on a local xampp, but i always fall into the spam protection.

Quote

Sorry, but your message didn't pass our giraffe test. Please prepare another blueberry.

 

Spam > Minimum Time and Maximum Time: is it in seconds?

Share this post


Link to post
Share on other sites

@maxf5

Quote

Spam > Minimum Time and Maximum Time: is it in seconds?

yes. Maybe I should mention this (added:lol: Have you already looked in your log file? The detailed reason should be listed there.

 

@alexmercenary Which version of ProcessWire and SimpleContactForm do you use? There is no anitSpamCountAdditionalInputs in the latest version. In earlier versions you had to write the form/html on your own, now the module generates the form. So there is no need to specify this because you're not able to add more fields as needed. But I guess, you're not using the latest version?! EDIT: Found and fixed it!

Share this post


Link to post
Share on other sites
On 2.12.2016 at 9:46 PM, justb3a said:

@maxf5

yes. Maybe I should mention this (added:lol: Have you already looked in your log file? The detailed reason should be listed there.

 

Ahhhh. thank you! my log said: [FAILURE] Number of fields does not match. IP: xxx

I had two fields for the email input ( one for confirmation ). deleted it, now it works fine :)

 

Share this post


Link to post
Share on other sites

Installing the module on another site, i get the following errror message:

Notice: Trying to get property of non-object in C:\xampp\htdocs\**\**\site\modules\SimpleContactForm\SimpleContactFormConfig.php on line 125

ProcessWire 3.0.42

Share this post


Link to post
Share on other sites

At which point do you get this error message? After clicking install? Or after submitting module configuration data?

It seems you choose an invalid field in the section `Select page name fields` (which shouldn't be possible, I tried different variants but cannot reproduce the issue). Are you able to reproduce this behaviour? Does the field you've selected have a field name and of which type is it?

Share this post


Link to post
Share on other sites

Hello,

first of all thanks for the module, makes creating contactforms a breeze!

I have a just a minor question, is it possible to alter the markup of the submit button?

I tried it like this:
 

$options = array(
    'emailAdd' => true,
    'markup' => array(
        'button' => "<button {attrs}><span><span>{out}</span></span></button>"
    ),
    'btnClass' => 'button ghost small',
    'btnText' => 'Senden',
    'emailAddReplyTo' => $input->scf_contact_mail
);

But the markup part, wasen't applied to the form.

Is there a way, I know I could archive whtat I want also with css but I'd rather like to have consistant buttons.

Share this post


Link to post
Share on other sites

Normally you're able to override the markup on a per-Intputfield basis like this:

'markup' => array(
   // @see: https://github.com/processwire/ProcessWire/blob/master/wire/core/InputfieldWrapper.php#L44
  'InputfieldSubmit' => array(
    // any of the properties above to override on a per-Inputifeld basis
  )
),

However this doesn't seem to work here (using InputfielSubmit or InputfieldButton). But you can override the `render` function of class `InputfieldSubmit` (for example in `init.php`):

$this->addHook('InputfieldSubmit::render', function(HookEvent $event) {
  if ($this->page->template->name === 'contact') { // adapt template name to compare with
    $parent = (object)$event->object;
    $attrs  = $parent->getAttributesString();
    $value = $parent->entityEncode($parent->attr('value'));
    $out = "<button $attrs><span><span>$value</span></span></button>";
    $event->return = $out; 
  }
});

 

  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, floridaDev said:

How does one change the page it's redirected to after submission. 

Just to be sure: You want to redirect to another page after successfully submitting the form data? This is not possible at the moment, but shouldn't be that difficult to implement. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Macrura
      PrevNextTabs Module
      Github: https://github.com/outflux3/PrevNextTabs
      Processwire helper modules for adding page navigation within the editor.
      Overview
      This is a very simple module that adds Previous and Next links inline with the tabs on the page editor. Hovering over the tab shows the title of the previous or next page (using the admin's built in jqueryUI tooltips.)
      Usage
      This module is typically used during development where you or your editors need to traverse through pages for the purpose of proofing, flagging and/or commenting. Rather than returning to the page tree or lister, they can navigate with these links.
      Warnings
      If you are using PW version 2.6.1 or later, the system will prevent you from leaving the page if you have unsaved edits.
      For earlier versions, to avoid accidentally losing changes made to a page that might occur if a user accidentally clicks on one of these, make sure to have the Form Save Reminder module installed.
      http://modules.processwire.com/modules/prev-next-tabs/
    • By Gadgetto
      SnipWire - Snipcart integration for ProcessWire
      Snipcart is a powerful 3rd party, developer-first HTML/JavaScript shopping cart platform. SnipWire is the missing link between Snipcart and the content management framework ProcessWire.
      With SnipWire, you can quickly turn any ProcessWire site into a Snipcart online shop. The SnipWire plugin helps you to get your store up and running in no time. Detailed knowledge of the Snipcart system is not required.
      SnipWire is free and open source licensed under Mozilla Public License 2.0! A lot of work and effort has gone into development. It would be nice if you could donate an amount to support further development:

      Status update links (inside this thread) for SnipWire development
      2020-03-21 -- SnipWire 0.8.5 (beta) released! Improves SnipWires webhooks interface and provides some other fixes and additions 2020-03-03 -- SnipWire 0.8.4 (beta) released! Improves compatibility for Windows based Systems. 2020-03-01 -- SnipWire 0.8.3 (beta) released! The installation and uninstallation process has been heavily revised. 2020-02-08 -- SnipWire 0.8.2 (beta) released! Added a feature to change the cart and catalogue currency by GET, POST or SESSION param 2020-02-03 -- SnipWire 0.8.1 (beta) released! All custom classes moved into their own namespaces. 2020-02-01 -- SnipWire is now available via ProcessWire's module directory! 2020-01-30 -- SnipWire 0.8.0 (beta) first public release! (module just submitted to the PW modules directory) 2020-01-28 -- added Custom Order Fields feature (first SnipWire release version is near!) 2020-01-21 -- Snipcart v3 - when will the new cart system be implemented? 2020-01-19 -- integrated taxes provider finished (+ very flexible shipping taxes handling) 2020-01-14 -- new date range picker, discount editor, order notifiactions, order statuses, and more ... 2019-11-15 -- orders filter, order details, download + resend invoices, refunds 2019-10-18 -- list filters, REST API improvements, new docs platform, and more ... 2019-08-08 -- dashboard interface, currency selector, managing Orders, Customers and Products, Added a WireTabs, refinded caching behavior 2019-06-15 -- taxes provider, shop templates update, multiCURL implementation, and more ... 2019-06-02 -- FieldtypeSnipWireTaxSelector 2019-05-25 -- SnipWire will be free and open source Plugin Key Features
      Fast and simple store setup Full integration of the Snipcart dashboard into the ProcessWire backend (no need to leave the ProcessWire admin area) Browse and manage orders, customers, discounts, abandoned carts, and more Multi currency support Custom order and cart fields Process refunds and send customer notifications from within the ProcessWire backend Process Abandoned Carts + sending messages to customers from within the ProcessWire backend Complete Snipcart webhooks integration (all events are hookable via ProcessWire hooks) Integrated taxes provider (which is more flexible then Snipcart own provider) Useful Links
      SnipWire in PW modules directory SnipWire Docs (please note that the documentation is a work in progress) SnipWire @GitHub (feature requests and suggestions for improvement are welcome - I also accept pull requests) Snipcart Website  
      ---- INITIAL POST FROM 2019-05-25 ----
       
    • By horst
      Croppable Image 3
      for PW 3.0.20+
      Module Version 1.2.0
      Sponsored by http://dreikon.de/, many thanks Timo & Niko!
      You can get it in the modules directory!
      Please refer to the readme on github for instructions.
       
      - + - + - + - + - + - + - + - + - + - NEWS - 2020/03/19 - + - + - + - + - + - + - + - + - + - 
      There is a new Version in the pipe, that supports WebP too: 
       
      - + - + - + - + - + - + - + - + - + - NEWS - 2020/03/19 - + - + - + - + - + - + - + - + - + - 
       
       
      -------------------------------------------------------------------------
       
      Updating from prior versions:
       
      Updating from Croppable Image 3 with versions prior to 1.1.7, please do this as a one time step:
      In the PW Admin, go to side -> modules -> new, use "install via ClassName" and use CroppableImage3 for the Module Class Name. This will update your existing CroppableImage3 module sub directory, even if it is called a new install. After that, the module will be recogniced by the PW updater module, what makes it a lot easier on further updates.
      -------------------------------------------------------------------------
       
      For updating from the legacy Thumbnail / CropImage to CroppableImage3 read on here.
       
      -------------------------------------------------------------------------
       
    • By Robin S
      Inspired by a recent question.
      Image Crop Ratios
      Allows preset aspect ratios to be defined per image field for the ProcessWire image crop tool.
      The module adds a select dropdown to the crop tool. Choose an aspect ratio and the crop area will be fixed to that ratio.
      Screencast

      Installation
      Install the Image Crop Ratios module.
      Configuration
      Default aspect ratios for all image fields can be defined in the module config. Aspect ratios for specific image fields can be defined on the Input tab of the field settings. You can override the ratio settings in template context if needed. Insert a hyphen as the first item in the ratio settings unless you want to force a ratio to be applied to the crop tool. The hyphen represents a blank option that allows a free crop area to be drawn. Usage
      Click the "Crop" link on the details view of an image thumbnail. Click the "Crop" icon at the top of the editor window. Choose an option from the "Ratio" select dropdown.  
      https://github.com/Toutouwai/ImageCropRatios
      https://modules.processwire.com/modules/image-crop-ratios/
×
×
  • Create New...