Jump to content
ryan

Module: CKEditor

Recommended Posts

Yes, solved. Thanks.

Removed and readded entire folder. Check for update does not work because old version was 450 and now is 102.

Share this post


Link to post
Share on other sites
Removed and readded entire folder. Check for update does not work because old version was 450 and now is 102.

You must have had the original HTMLPurifier module, which I mistakenly based the version number of the HTMLPurifier version number. I fixed that in the next one. Sorry about that. 

Other common issue issue is the white are around text: not highlighted and doesn't fill the dashed area (Teflon theme).

I just now pushed an update to CKEditor that should fix this. 

  • Like 1

Share this post


Link to post
Share on other sites

Did anyone find a solution for this? Having same issue and it's kind of a bugger.. I find myself constantly dragging CKEditor windows larger :)

Same here. Bit of a bugger I agree, may have another go at overriding the CSS.

Share this post


Link to post
Share on other sites

Did anyone find a solution for this? Having same issue and it's kind of a bugger.. I find myself constantly dragging CKEditor windows larger  :)

 

I've been using CKEditor almost exclusively for the last couple of months, but haven't ever run into this. Maybe that's because I'm always using inline mode, which automatically sizes the height of the editor to the text within it. But I think the same thing may be possible even in regular mode (I can find out). Just want to make sure I understand how to reproduce the issue. Does this only occur in regular mode?

Share this post


Link to post
Share on other sites

@ryan: yes, it's an issue of regular mode only. I've been using inline mode since mentioning that here, so it hasn't been a problem for me anymore. It is still a bit odd, especially since there's still a config option for row number.. it just doesn't affect anything :)

  • Like 1

Share this post


Link to post
Share on other sites

Thanks, I understand now. I've updated the InputfieldCKEditor to populate the config.height property based on the rows value. 

  • Like 3

Share this post


Link to post
Share on other sites

There was a bug in the InputfieldCKEditor module that made the "Anchor" tool not work. In fact, if you clicked on it, it basically freezes the page and you can't do anything but reload. This is a result of the Anchor tool now requiring the Link plugin in CKEditor (as of version 4.1.2 I think). Since the Link plugin was in our default "Removed Plugins" configuration setting, the Anchor tool is broken.

In order to fix it, edit your field settings, click the "input" tab, and remove "link" from the "Removed Plugins" list. 

Alternatively, you can just update your InputfieldCKEditor to the latest version v1.1.1 and it will take care of this for you. 

The latest version of InputfieldCKEditor also updates the CKEditor version from 4.1.2 to 4.2.0 and has a few more tweaks as well, so it's worth the upgrade even if you don't use the Anchor tool.

  • Like 4

Share this post


Link to post
Share on other sites

Glad you found that one Ryan. It was real mystery to me. Kind of bug in ckeditor though to allow that kind of config...?

  • Like 1

Share this post


Link to post
Share on other sites

Noticed that on a test install the other day and just assumed I had messed something up. I gave up and switched it to tinyMCE.

Glad you found that, I really like CKEditor.

Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
Kind of bug in ckeditor though to allow that kind of config...? 

I wouldn't consider it a bug necessarily, but it sure would be nice if it would throw a JS error or something. This was a difficult one to track down. 

  • Like 2

Share this post


Link to post
Share on other sites

I'm using OS X Chrome (Version 28.0.1500.95) and each time I 'save and keep unpublished' using a CKEditor field it goes completely blank. When I refresh I get it all back. Is anyone else having this issue?

Share this post


Link to post
Share on other sites

I'm using OS X Chrome (Version 28.0.1500.95) and each time I 'save and keep unpublished' using a CKEditor field it goes completely blank. When I refresh I get it all back. Is anyone else having this issue?

I've started having this issue recently Marty. 

Share this post


Link to post
Share on other sites

I can't seem to duplicate this one (using same version of Chrome and InputfieldCKEditor). I've tested both regular and inline mode. Are there any other factors, modified CKEditor settings, etc., you can think of?

Share this post


Link to post
Share on other sites

@adamspruijt

Have the same issue, but when I ad a link to an external js file. ( Custom Editor JS Styles Set )

Then the issue is gone, even if the file is empty. (weird)

  • Like 1

Share this post


Link to post
Share on other sites

Just testing out this module and noticed that the codemirror plugin icons folder is missing, so when you are viewing source, there are 4 blank buttons at the top. Grabbing the icons directory from https://github.com/w8tcha/CKEditor-CodeMirror-Plugin mostly fixes the problem, except the first button image is referenced as searchCode.png, but is named SearchCode.png

The other thing I noticed was that codemirror plugin.js file and the lang folder was also missing from this module's installation.

Share this post


Link to post
Share on other sites

Have the same issue, but when I ad a link to an external js file. ( Custom Editor JS Styles Set )

Then the issue is gone, even if the file is empty. (weird)

I still can't duplicate the issue here. Let me know if you guys can think of any other factors that would enable me to duplicate it. Also, double check that your InputfieldCKEditor directory was replaced in full (rather than replaced into) when upgrading the editor. 

Just testing out this module and noticed that the codemirror plugin icons folder is missing, so when you are viewing source, there are 4 blank buttons at the top. Grabbing the icons directory from https://github.com/w...deMirror-Plugin mostly fixes the problem, except the first button image is referenced as searchCode.png, but is named SearchCode.png

I noticed this too, though didn't realize why it was doing that (thanks for figuring it out). Maybe I should leave CodeMirror out of the installation, as it sounds like the current version is missing some things. Though I'll try updating the assets that you mentioned, but these types of errors make me wonder if there might be other problems with the current version of CodeMirror. 

Share this post


Link to post
Share on other sites

@adamspruijt

Have the same issue, but when I ad a link to an external js file. ( Custom Editor JS Styles Set )

Then the issue is gone, even if the file is empty. (weird)

Been getting those blank fields too. A refresh seems to work for a while, but for no apparant reason the issue reappears. Will try your fix asap. Thanks!

Share this post


Link to post
Share on other sites

@arjan, I really don't know if it is a "fix".

The field I use is almost completely stripped. I only allow, <strong> <em> and <link> ( the CKEditor one, not the pw )

But so far, no issue anymore.

  • Like 1

Share this post


Link to post
Share on other sites

Sorry, if repost, but I couldn't find a suitable answer to my question:

I'd like to insert a download link in a richtext field using the ckeditor. The control lets me select contents of image fields throughout my page, but not the contents of file fields (which I need to select a zip file as download target).

So what is the designated way to specify download targets other than image files?

..........................

SOLVED: Was my fault completely. Seems that the file I'd liked to target wasn't uploaded due to an excluded file extension (.zip).

Sorry again for spaming here.

Edited by marco

Share this post


Link to post
Share on other sites
So what is the designated way to specify download targets other than image files?

It sounds like you already solved this, but I just wanted to mention that the "link" option in CKEditor is the way you link to files on your page. When you highlight some text and click the link icon, you'll have a choice of linking to a URL or a file. It'll give you a select box of files attached to your page. If you want to link to a file attached to another page, you can click the link to select another page from within the modal window. 

Share this post


Link to post
Share on other sites

Is there a way to make the pwlink plugin only allow links to published/viewable pages?

I have some users confused by unpublished/hidden pages, they are creating links to them and then well...you know....

Share this post


Link to post
Share on other sites

This may have been answered, but I can't find it.

When pasting from Word, CKEditor seems to insert <div> tags where there should be <p> tags.

I checked the CKEditor docs and tried to change the enter mode in the config — no luck.

I found this comment in InputfieldCKEditor.module

// for some reason CKEditor insists on pasting DIVs sometimes when they should be paragraphs
// so we attempt to fix that issue here 
// $value = str_replace(array('<div>', '</div>'), array('<p>', '</p>'), $value); 

Is this a common problem?  A bug?

  • Like 1

Share this post


Link to post
Share on other sites
I have some users confused by unpublished/hidden pages, they are creating links to them and then well...you know....

Being able to link to hidden pages is important. Often times we make pages hidden specifically because we'd rather make our own contextual links in text rather than have them in the site's navigation. As for unpublished pages, there are situations where we may be working on a group of pages that get published together, so not sure it's good to prevent linking. I think the best thing to do here is inform the client what it means when a page has a strikethrough. If it's a strong need there, I can show you how to accomplish it now with a hook. 

Is this a common problem?  A bug?

I don't know if it's a bug in CKEditor or not, but I couldn't find another way around it. DIVs aren't acceptable replacements for <p> tags, so that's why I put in that fix. Hackish I know, but solved the issue here. I'm always on the hunt for a better solution though. 

  • Like 1

Share this post


Link to post
Share on other sites
Being able to link to hidden pages is important.

I know what you mean. I guess I was thinking on an instance specific basis so I could create a version that didn't allow it for some low-level editors. Educating can be a difficult task when you have so many users (200+).

If it's a strong need there, I can show you how to accomplish it now with a hook. 

Thanks. I'll give it try myself and see how far I get. If you hear whimpering, check in on me. ;)

I don't know if it's a bug in CKEditor or not, but I couldn't find another way around it. DIVs aren't acceptable replacements for <p> tags, so that's why I put in that fix. Hackish I know, but solved the issue here. I'm always on the hunt for a better solution though.

That line appears to be commented out in the latest version of the module 1.1.1.

I uncommented it, but I'm still getting the <div> tags on paste.

Share this post


Link to post
Share on other sites

Is there a way to control tag useage like in tinymce with the valid elements option? The extra allowed content option seems to be as the name suggests, just a second layer of control.

I would like to restrict the tags to just the basics. I would also like to force some values to my headings, which I accomplished in tinymce like this:

h2[role:heading|aria-level:2]

I searched the documentation, which wasn't to much help at all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...