Jump to content

Continually disconnected (random)

Chris B

Recommended Posts


My name is Chris, i have been using Processwire for several months. I had the opportunity to create several sites with this one. Despite being great tool, I often encounter the same problem in the administration.
I am continually disconnected (logout) for no specific reason. It's every time: after a page change. Ex: I send a form or simply a page change via a link.

I checked the logs, messages, etc. but there is nothing related to this problem.

Thank you for your support ?

Link to comment
Share on other sites

These threads discuss similar issues: 


While developing you might want to disable fingerprinting from within config.php - it's explained and discussed in the threads above.

Another thing you can and might want to doublecheck:

  • CDNs can be sometimes an issue as well; saw this with Cloudflare CDN a few times
  • some browser extensions (privacy and adblock-related ones) can cause those issues as well
  • Pi-Hole can be an issue too
  • Operas built-in-VPN causes these conflicts/problems (especially in tools like Asana and Slack - and PW)

And those things are just the few I remembered from similar situations I had to deal with on my own.

  • Like 4
Link to comment
Share on other sites

Hi @Christophe Badoux

It sound like a permission or maybe a server cache issue, but we need more information about your hosting.

Things to check :

  • browser cache
  • disk space available
  • value of session.save_path and permission of this value
  • permission of site/assets
  • server caching (depending on the server setup, could be NGINX, Squid, Varnish, Memcached, etc..)


I bet on the last one.

Oh and Welcome to the forum ?

  • Like 3
Link to comment
Share on other sites

10 hours ago, Rudy said:

If you put your site behind Cloudflare, you have to exclude your backend URL (using Page rules) otherwise it will be cached and will disconnect you. 

@Rudy Can you explain in more details or post a screenshot of your settings? Disabling cache with the following page rule for the admin URL actually makes things a lot worse…



Link to comment
Share on other sites

Thank you all!

I waited a few hours before pronouncing the verdict ^^

The problem was indeed the change of IP.

I added this line in: /site/config.php

$config->sessionFingerprint = 1; /* 1 or true: Fingerprint on default / recommended setting (currently 10). */


$config->sessionFingerprint = 8; /* 8: Fingerprint only the useragent */

I was able to test this solution on all the sites I created. It works.

Thx you to everyone !!!

  • Like 3
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...