Jump to content
BFD Calendar

Error loading GitHub branches

Recommended Posts

I'm still wrestling with the upgrade troubles on OVH.com hosting. I manually upgraded to PW 3.0.98 and Upgrade module 0.0.7. Checking upgrades gives me an "Error loading GitHub branches - https://api.github.com/repos/processwire/processwire/branches - HTTP error(s): 2: fsockopen(): SSL operation failed with code 1. OpenSSL Error messages: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version, 2: fsockopen(): Failed to enable crypto, 2: fsockopen(): unable to connect to ssl://api.github.com:443 (Unknown error) - Check that HTTP requests are not blocked by your server.".

Upgrading or installing other modules doesn't work either. I know it probably has to do with some provider setting on OVH.com, but I've tried several things mentioned in the ProcessWireUpgrade support forum, all to no avail. Server is configured to use PHP 7.0. If anyone here is also on OVH.com and knows a solution I'd be most happy to hear about it.

Share this post


Link to post
Share on other sites

I'm having this same error. I've exported an existing live site and recreated it locally with PW 3.0.116 to do some experimenting, but on the upgrades page I get this error, and the site doesn't display images correctly. Any help would be much appreciated.

Share this post


Link to post
Share on other sites

SSL operation failed 

On Mac? This is due to OpenSSL changes by Apple.

Share this post


Link to post
Share on other sites
19 hours ago, Soma said:

SSL operation failed 

On Mac? This is due to OpenSSL changes by Apple.

Ah. Bugger. Yes, I'm on a Mac. I'll have to look into that then. Any ideas how to (if it can be?) resolve it?

Share this post


Link to post
Share on other sites
2 hours ago, houseofdeadleg said:

Ah. Bugger. Yes, I'm on a Mac. I'll have to look into that then. Any ideas how to (if it can be?) resolve it?

I tried but not luck.

Share this post


Link to post
Share on other sites

I finally solved the problem by setting PHP 7.0 from 'development' to 'production', it had nothing to do with my Mac.

  • Like 1

Share this post


Link to post
Share on other sites

same trouble with MAMP / MAC + PHP 7.3..... reverting to 7.2 solved it

  • Like 1

Share this post


Link to post
Share on other sites
On 5/16/2019 at 8:50 PM, ceberlin said:

same trouble with MAMP / MAC + PHP 7.3..... reverting to 7.2 solved it

No joy for me on any version of PHP (7.2.1, 7.1.31, 7.0.33 or previous)

 I'll reboot, clear caches and try again tomorrow. Interestingly I also cannot download any new versions of PHP 

Quote

Error
Connecting to the update server failed, please try again later.

😕

Share this post


Link to post
Share on other sites

I'm having the same problem again. PW 3.098 PHP 7.2.19 (or other versions) with OVH hosting.

At the root of the server is this .ovhconfig file:

app.engine=php
app.engine.version=7.2
http.firewall=none
environment=production
container.image=stable

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Clemtre
      I'm designing a portfolio website for a friend with a bit of p5. Adapting the css to all device formats and pixel density is driving me crazy so I'd like to use a CMS
      Website and sql database are hosted on the same domain at OVH
      When I try to set up processwire, I get this error message
       

       
      Here is the sql database I use (I have no idea if these informations are confidential)

      I understand this post might be cringeworthy as I'm completely noob to this domain, my apologies.
      Thanks a lot for your help 
    • By dragan
      A neat new Github feature: 
      https://help.github.com/en/articles/navigating-code-on-github
      And while I'm at it: If you're frequently navigating through GH repos, I can highly recommend this browser add-on: https://www.octotree.io/
    • By Peter Knight
      Occasionally when I goto Modules > Upgrades I get the following type of error.
      There's actually about three of them and each one mentions a different line. In the example below, line 266 is
      $new = version_compare($versions[$name]['remote'], $versions[$name]['local']);  
      ( ! ) Notice: Undefined index: local in /Users/peterknight/Sites/mysite.com/site/assets/cache/FileCompiler/site/modules/ProcessWireUpgrade/ProcessWireUpgradeCheck.module on line 266 Call Stack # Time Memory Function Location 1 0.0011 405040 {main}( ) .../index.php:0 2 0.2602 5197688 ProcessWire\ProcessPageView->execute( ) .../index.php:55 3 0.2602 5198064 ProcessWire\ProcessPageView->__call( ) .../index.php:55 4 0.2602 5198064 ProcessWire\WireHooks->runHooks( ) .../Wire.php:442 5 0.2603 5198480 ProcessWire\ProcessPageView->_callMethod( ) .../WireHooks.php:733 6 0.2603 5198480 ProcessWire\ProcessPageView->___execute( ) .../Wire.php:383 7 0.3009 5463888 ProcessWire\Page->render( ) .../ProcessPageView.module:209 8 0.3009 5463944 ProcessWire\Page->__call( ) .../ProcessPageView.module:209 9 0.3009 5463944 ProcessWire\WireHooks->runHooks( ) .../Wire.php:442 10 0.3015 5465248 ProcessWire\PageRender->renderPage( ) .../WireHooks.php:834 11 0.3015 5465624 ProcessWire\PageRender->__call( ) .../WireHooks.php:834 12 0.3015 5465624 ProcessWire\WireHooks->runHooks( ) .../Wire.php:442 13 0.3016 5466040 ProcessWire\PageRender->_callMethod( ) .../WireHooks.php:733 14 0.3016 5466040 ProcessWire\PageRender->___renderPage( ) .../Wire.php:383 15 0.3032 5470760 ProcessWire\TemplateFile->render( ) .../PageRender.module:514 16 0.3032 5470816 ProcessWire\TemplateFile->__call( ) .../PageRender.module:514 17 0.3032 5470816 ProcessWire\WireHooks->runHooks( ) .../Wire.php:442 18 0.3033 5471848 ProcessWire\TemplateFile->_callMethod( ) .../WireHooks.php:733 19 0.3033 5471848 ProcessWire\TemplateFile->___render( ) .../Wire.php:380 20 0.3036 5493112 require( '/Users/peterknight/Sites/mysite.com/site/assets/cache/FileCompiler/site/templates/admin.php' ) .../TemplateFile.php:287 21 0.3038 5493616 require( '/Users/peterknight/Sites/mysite.com/wire/modules/AdminTheme/AdminThemeUikit/controller.php' ) .../admin.php:15 22 0.3038 5495120 require( '/Users/peterknight/Sites/mysite.com/wire/core/admin.php' ) .../controller.php:15 23 0.3085 5586144 ProcessWire\ProcessController->execute( ) .../admin.php:135 24 0.3085 5586200 ProcessWire\ProcessController->__call( ) .../admin.php:135 25 0.3085 5586200 ProcessWire\WireHooks->runHooks( ) .../Wire.php:442 26 0.3085 5586616 ProcessWire\ProcessController->_callMethod( ) .../WireHooks.php:733 27 0.3085 5586616 ProcessWire\ProcessController->___execute( ) .../Wire.php:380 28 0.3108 5596744 ProcessWireUpgrade->execute( ) .../ProcessController.php:333 29 1.2224 8773000 ProcessWireUpgradeCheck->getVersions( ) .../ProcessWireUpgrade.module:187 30 1.2227 8776256 ProcessWireUpgradeCheck->getModuleVersions( ) .../ProcessWireUpgradeCheck.module:185 I've been living with it for a while and while it doesn't seem to stop me upgrading etc, I'd love to fix it.
      Anyone recognise this type of error?
    • By louisstephens
      So I recently upgraded my sandbox environment to the latest master version from .62(?). I logged in and received the following error:
      "There appear to be multiple copies of module "AdminThemeUikit" on the file system."
      Unfortunately, in my haste, I removed the theme from site->modules so it doesnt exist anymore, and the theme has defaulted somewhat to the old theme. Is there a way to restore UIkit as the theme for processwire natively, or do I need to completely re-install?
    • By FrancisChung
      I stumbled across this on Github ... just breathtaking .... piece of history right there.
      A good place to brush up on your Assembly Language
      https://github.com/chrislgarry/Apollo-11
       
      By the way, Margaret Hamilton who worked on the module is considered a programming genius.
      https://www.wired.com/2015/10/margaret-hamilton-nasa-apollo/
×
×
  • Create New...