Jump to content
Wanze

ProcessGoogleAnalytics

Recommended Posts

I have been using this module for some years. Every now and then one of my sites is loosing the Google authentication of the module. I have to authenticate again for the module to start working again. Has anybody seen this kind of problem and what could cause the need to reauthenticate?

Share this post


Link to post
Share on other sites

@Ipa I've been using it for years too (on one site) and it's been AOK, no reconnect needed, sorry that doesn't help much :/

Share this post


Link to post
Share on other sites

Hi @Wanze, I'm doing a 2.7 site (that can't currently go to 3.x), do you think your GA module will become 2.7 (or 3.x?) compatible one day? Tks again for this great module ^_^ Cheers, -Alan

Share this post


Link to post
Share on other sites
On 19/08/2016 at 8:59 PM, alan said:

Hi @Wanze, I'm doing a 2.7 site (that can't currently go to 3.x), do you think your GA module will become 2.7 (or 3.x?) compatible one day? Tks again for this great module ^_^ Cheers, -Alan

I just integrated this module in a ProcessWire 3.0.30 project and it works.

  • Like 3

Share this post


Link to post
Share on other sites

Hi,
sorry for the noobie question, but how do I install this module in 2016?
I can't find anything in the Google Console.

Thanks!

Share this post


Link to post
Share on other sites

Hi,

I just tried to install this module in ProcessWire 3.0.44 and everything works fine to the point where i have to log in with google and authenticate. Right after that step comes the following error: Could not fetch the accessToken

Is this a problem with the current Version or did I miss something?

I hope anyone can help to make this great addon working.

Thanks in advance!

  • Like 1

Share this post


Link to post
Share on other sites

The Google api console is changed,

in follow the installation instructions, but because some things are changed is there probably a setting i in the API console i missed. The Analytics API is activated in the API console.

In the module in processwire i can autenticate, but see only older projects i made in the api console, not the new just activated project.

 

Share this post


Link to post
Share on other sites

@Wanze Could you please add an icon to the module? Cause in mobile menu it doesn't look good without an icon.

Inside getModuleInfo function add this: 'icon' => 'bar-chart'. Thanks.

mobile-menu.jpg

Share this post


Link to post
Share on other sites

Is this module still be maintained?

btw, this module seems to work on the latest PW version, but I can't install on a https site... PW keeps logging me out.

Share this post


Link to post
Share on other sites
7 hours ago, videokid said:

Is this module still be maintained?

btw, this module seems to work on the latest PW version, but I can't install on a https site... PW keeps logging me out.

The latest update of the module was on 1 April 2014. My above simple request to add a missing icon hasn't fulfilled yet! Maybe @Wanze isn't available. I'm using the module on both PW2 & PW3 with https and it's working fine.

You can install a module with 3 methods:

1. Add Module From Directory
2. Add Module From URL
3. Add Module From Upload

Go to Admin > Modules and click on the tab "New" to check all the methods.

  • Like 1

Share this post


Link to post
Share on other sites

Hey guys, I'm sorry for currently not finding the time to maintain the module. I think it should still work with ProcessWire 3, at least I'm using it on one site running on PW 3.

@PWaddict

If you find time, could you send a pull request for the icon? Thanks :)

Share this post


Link to post
Share on other sites

Thanks, merged :)

  • Like 2

Share this post


Link to post
Share on other sites
32 minutes ago, Wanze said:

Thanks, merged :)

Nice! Do you have to change your module version from 1.2.1 to 1.2.2 to appear on ProcessWire Upgrades?

  • Like 2

Share this post


Link to post
Share on other sites
On 1/4/2017 at 12:23 PM, Tobi C. said:

Hi,

I just tried to install this module in ProcessWire 3.0.44 and everything works fine to the point where i have to log in with google and authenticate. Right after that step comes the following error: Could not fetch the accessToken

Is this a problem with the current Version or did I miss something?

I hope anyone can help to make this great addon working.

Thanks in advance!

@Tobi C. I had the same issue.

After I checked the "Revoke Authentication" button in the settings of the GA-Module I finally saw the drop-down with the domains and everything is working now.

Not sure what caused the problem...but hey it's working now.

Awesome module @Wanze and greetings from Switzerland ^_^

Share this post


Link to post
Share on other sites

On 25 May the Data Retention will take effect on Google Analytics.

If I understand correctly the module reads aggregated data and it will not affected by the Data Retention. Can someone please confirm it?

Share this post


Link to post
Share on other sites

I'm currently running PW 3.0.98 with Google Analytics 1.2.1 and confirm that it still works.

The url for Google API Credentials is https://console.developers.google.com/apis

Share this post


Link to post
Share on other sites

Hi,

Everything went fine installing this module, but after completing the proces it doesn't find my google-account.
Anyone else out here who had the same problem or knows a fix?

Thanks in advance...

Schermafbeelding 2018-09-06 om 16.59.52.png

Share this post


Link to post
Share on other sites
On 9/6/2018 at 5:07 PM, joris_ross said:

Hi,

Everything went fine installing this module, but after completing the proces it doesn't find my google-account.
Anyone else out here who had the same problem or knows a fix? 

Thanks in advance...

Schermafbeelding 2018-09-06 om 16.59.52.png

You have to enable the Analytics API in the Google console

 

Share this post


Link to post
Share on other sites

Hi, everyone.

I have the same problem. The module cannot find any accounts.

I've checked the Analytics API is enabled in Google console.

I've got Google Analytics gtag and module found the account.

Edited by gizomo
Problem was solved.

Share this post


Link to post
Share on other sites

Just a heads up that might hopefully help save someone some time.

Browser adblockers don't like "google-analytics" in ajax calls these days which breaks all the ajax calls in this module. I changed the name (not title) of the Admin > Google Analytics page in the PW admin and also changed the PAGE_NAME constant on this line: https://github.com/wanze/ProcessGoogleAnalytics/blob/c97c170485ff91f81d8a67e72b968a1c8e25165e/ProcessGoogleAnalytics.module#L25

In my case I changed them both to "stats" because I didn't want to mess around figuring out whether it was "google" or "analytics" that was causing the problem, but other names should also work.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By bernhard
      --- Please use RockFinder3 ---
    • By MoritzLost
      Cacheable Placeholders
      This module allows you to have pieces of dynamic content inside cached output. This aims to solve the common problem of having a mostly cacheable site, but with pieces of dynamic output here and there.  Consider this simple example, where you want to output a custom greeting to the current user:
      <h1>Good morning, <?= ucfirst($user->name) ?></h1> This snippet means you can't use the template cache (at least for logged-in users), because each user has a different name. Even if 99% of your output is static, you can only cache the pieces that you know won't include this personal greeting. A more common example would be CSRF tokens for HTML forms - those need to be unique by definition, so you can't cache the form wholesale.
      This module solves this problem by introducing cacheable placeholders - small placeholder tokens that get replaced during every request. The replacement is done inside a Page::render hook so it runs during every request, even if the response is served from the template cache. So you can use something like this:
      <h1>Good morning, {{{greeting}}}</h1> Replacement tokens are defined with a callback function that produces the appropriate output and added to the module through a simple hook:
      // site/ready.php wire()->addHookAfter('CachePlaceholders::getTokens', function (HookEvent $e) { $tokens = $e->return; $tokens['greeting'] = [ 'callback' => function (array $tokenData) { return ucfirst(wire('user')->name); } ]; $e->return = $tokens; }); Tokens can also include parameters that are parsed and passed to the callback function. There are more fully annotated examples and step-by-step instructions in the README on Github!
      Features
      A simple and fast token parser that calls the appropriate callback and runs automatically. Tokens may include multiple named or positional parameters, as well as multi-value parameters. A manual mode that allows you to replace tokens in custom pieces of cached content (useful if you're using the $cache API). Some built-in tokens for common use-cases: CSRF-Tokens, replacing values from superglobals and producing random hexadecimal strings. The token format is completely customizable, all delimiters can be changed to avoid collisions with existing tag parsers or template languages. Links
      Github Repository & documentation Module directory (pending approval) If you are interested in learning more, the README is very extensive, with more usage examples, code samples and usage instructions!
    • By Craig
      I've been using Fathom Analytics for a while now and on a growing number of sites, so thought it was about time there was a PW module for it.
      WayFathomAnalytics
      WayFathomAnalytics is a group of modules which will allow you to view your Fathom Analytics dashboard in the PW admin panel and (optionally) automatically add and configure the tracking code on front-end pages.
      Links
      GitHub Readme & documentation Download Zip Modules directory Module settings screenshot What is Fathom Analytics?
      Fathom Analytics is a simple, privacy-focused website analytics tool for bloggers and businesses.

      Stop scrolling through pages of reports and collecting gobs of personal data about your visitors, both of which you probably don't need. Fathom is a simple and private website analytics platform that lets you focus on what's important: your business.
      Privacy focused Fast-loading dashboards, all data is on a single screen Easy to get what you need, no training required Unlimited email reports Private or public dashboard sharing Cookie notices not required (it doesn't use cookies or collect personal data) Displays: top content, top referrers, top goals and more
    • By daniels
      This is a lightweight alternative to other newsletter & newsletter-subscription modules.
      You can find the Module in the Modules directory and on Github
      It can subscribe, update, unsubscribe & delete a user in a list in Mailchimp with MailChimp API 3.0. It does not provide any forms or validation, so you can feel free to use your own. To protect your users, it does not save any user data in logs or sends them to an admin.
      This module fits your needs if you...
      ...use Mailchimp as your newsletter / email-automation tool ...want to let users subscribe to your newsletter on your website ...want to use your own form, validation and messages (with or without the wire forms) ...don't want any personal user data saved in any way in your ProcessWire environment (cf. EU data regulation terms) ...like to subscribe, update, unsubscribe or delete users to/from different lists ...like the Mailchimp UI for creating / sending / reviewing email campaigns *I have only tested it with PHP 7.x so far, so use on owners risk
      EDIT:
      Since 0.0.4, instructions and changelog can be found in the README only. You can find it here  🙂
      If you have questions or like to contribute, just post a reply or create an issue or pr on github, thanks!
    • By MoritzLost
      Sorry for the convoluted title. I have a problem with Process modules that define a custom page using the page key through getModuleInfo (as demonstrated in this excellent tutorial by @bernhard). Those pages are created automatically when the module is installed. The problem is that the title of the page only gets set in the current language. That's not a problem if the current language (language of the superuser who is installing the module) is the default language; if it isn't, the Process page is missing a title in the default language. This has the very awkward effect that a user using the backend in the default language (or any other language) will see an empty entry in the setup menu:

      This screenshot comes from my Cache Control module which includes a Process page. Now I realize the description sounds obscure, but for us it's a common setup: We a multiple bilingual sites where the default language is German and the second language is English. While the clients use the CMS in German, as a developer I prefer the English interface, so whenever I install a Process module I get this problem.
      As a module author, is there a way to handle this situation? I guess it would be possible to use post-installation hooks or create the pages manually, but I very much prefer the declarative approach. The page title is already translatable (through the __ function), but of course at the time of installation there is no translation, and as far as I'm aware it's not possible to ship translations with a module so they are used automatically. Could this situation be handled better in the core? I would prefer if the module installation process would always set the title of the Process page in the default language, instead of the language of the current user.
×
×
  • Create New...