Jump to content
Wanze

ProcessGoogleAnalytics

Recommended Posts

That's because the results were getting cached. But you still don't see any Statistics, right?

I think there has to be an error in your setup somewhere. Tested also the date "d-m-Y", works fine here on my local installation.

Will check if Google reports back some error codes in case something went wrong with the query params...

Edit:

If you want to do some more testing, you should disable caching the output:

1) Delete the folders starting with "ga_" in site/assets/cache/MarkupCache

2) In the Module Options, set Cache Time to "0"

Maybe i got the problem. I'm displaying the statistic of a new website...so no rows have been created, that's why i can see the notices and warning...but meanwhile i made some visitors and now i can see statistics except the mobile block that is still displaying those notices...

You have to manage this case. ;)

Share this post


Link to post
Share on other sites

If I had to wish for anything it would only be that I could get more detail on the referrers. Like when I see a new referrer show up, I'd love to click to see the URL where the referring link actually exists.

I remember seeing this somewhere, should be possible to implement with the GA api. Will be there in the next version :)

I'm not sure what the best behavior would be here, as I'm guessing everyone has their own workflow and timeline they want to look at in GA. But I do know that the first thing I do when I get into GA is to set a date range. It's rare that I want to look at the last month or year. Usually I want the last 24 hours, last 2 days, last week, etc. I've often wished that GA had a select box where I could choose "last 24 hours" for instance, rather than having to select starting and ending dates.

I think another module option to define the default date range makes sense. Currently, this is always a month back from "today". I will add a dropdown one can choose the the date range (24 hours, 2 days, 3 days... 1 week, 2 weeks etc.)

Maybe i got the problem. I'm displaying the statistic of a new website...so no rows have been created, that's why i can see the notices and warning...but meanwhile i made some visitors and now i can see statistics except the mobile block that is still displaying those notices...

You have to manage this case. ;)

Thank you for testing, glad it turned out to be this simple! ;-)

Will add the check in the next version. One quick fix for you is to visit the site with your mobile phone :grin:

  • Like 1

Share this post


Link to post
Share on other sites

Just commited version 1.1.1

  • Fixed PHP notices when debug mode is enabled (thanks Sevarf2!)
  • If no results are returned from GA, display "no results found"
  • Added module config option for a default date range: last 24 hours, last 2 days, last 3 days etc. If you want to look back more than 2 months by default, tell me... i'll add more values :)
  • Traffic Sources: Added Referral Sources by URL. Provides also a link to visit the referral page, but as Ryan mentioned earlier, sometimes uri-variables are stripped resulting in invalid links!

When you set a custom date range in the options section, you are "overwriting" the default date range. This can still be handy, for example if you want to look quickly at statistics from the past. Reset the custom date range to display stats again from the default one.

  • Like 3

Share this post


Link to post
Share on other sites

I'm getting a strange error when I go to the GA page (after authenticating) that shows up for each section were data is supposed to show up. The end of the errors say:

Values must match the following regular expression: 'ga:[0-9]+'"}

It is referencing the Google Analytics Account ID that I provided, which is in the format of UA-XXXXXXXX-X. That's the right GA Account ID to provide, correct?

The installation instructions say to "Choose a Google Analytics Account from the Dropdown". However, I didn't see any place to do that. Is that related to the problem I'm having?

Share this post


Link to post
Share on other sites

@hani you have to enter it in this format ga:xxxxxxx as mentioned before by wanze, though still not sure what numbers.

When I try ga:5735834-7 it doesn't work (regex not matching), when I enter ga:5735834, it seems to recognize it but still an error that access is not configured is shown. I also never come to select any account as mentioned in the description.

@wanze, I'm trying since hours to get this module working and no luck so far.

I got the same problem with entering the account id as mentioned above. After reading your posts again I still can't see what would be wrong. I entered all key and secrets and the account id, but it always returns some 400,403, or 500 or whatever.

The get is shown like this: "Error calling GET https:\/\/www.googleapis.com\/analytics\/v3\/data\/ga?ids=ga%3A5735834&start-date=2012-08-09&end-date=2012-09-09&metrics=ga..." (403) Access Not Configured"

So I wanted to uninstall the module, and I've seen that it will also uninstall the MarkupCache module in PW, which is a bad thing. It may be required by the module but a simple $modules->get will load it if installing you module, no need to make it required and uninstall it when uninstalling your module.

Share this post


Link to post
Share on other sites

Finally I seem to have it working after 1000 try and error. I create a new project on google API page, the one I already had was from another test I did a while ago. After entering the new key's I got still an error saying I don't have the permission... I'm not sure what I have done that it works now, but after authenticate, I can select an account after redirect.

OMG! But after selecting an account I again get the same error "(403) Access Not Configured"}". Can it be really that hard?

Share this post


Link to post
Share on other sites

Guys,

Sorry for the problems, let's find out why it isn't working.

The correct ID you must provide is really hard to find out and the docs from Google suck! If you can't see the dropdown to select an GA-Account, then we need to debug together because I just tested and it works on my installation.

Please try this:

Enter the ID manually and check if the module works.

You can find the ID in the Browsers URL when you are watching the statistics inside the normal Google Analytics page.

The ID is build with the numbers after the "p":

post-582-0-43538800-1347191796_thumb.png

Add these numbers in the module settings (Google Analytics Account Id) and add "ga:" in front -> Format: ga:xxxxxxx

Does it work?

Normally, the module should do this step for you by detecting all your accounts and then display the dropdown:

post-582-0-81537000-1347191968_thumb.png

Share this post


Link to post
Share on other sites

After a long time trying the account id I enter was always right. Though suddenly I've come to the select dropdown, but after selecting one I see again the error as before. Metioned in my previous post.

Share this post


Link to post
Share on other sites

After a long time trying the account id I enter was always right. Though suddenly I've come to the select dropdown, but after selecting one I see again the error as before. Metioned in my previous post.

Can you delete all the cache files startin with "ga_" in "site/assets/cache/MarkupCache/"

Just to make sure that the 403 errors are not cached!

If this doesn't work, I have to look in the docs from Google in which cases this error is returned...

Think I need to do some more error checking in the whole module...

Share this post


Link to post
Share on other sites

Please try this:

Enter the ID manually and check if the module works.

You can find the ID in the Browsers URL when you are watching the statistics inside the normal Google Analytics page.

The ID is build with the numbers after the "p":

post-582-0-43538800-1347191796_thumb.png

Add these numbers in the module settings (Google Analytics Account Id) and add "ga:" in front -> Format: ga:xxxxxxx

- Well is it meant to NOT enter the account ID in the module settings?

- When I don't enter a account ID the analytics page in PW throws error without continuing. When I enter any, I get to auth via google and after redirect back to PW there's not select at all (only once it was there) and the 403 is shown in each panel.

- The ID after the "p" is always different to every sub account.

- What ID really is supposed to go there?

Does it work?

- NO matter what ID I take it doesn't work.

- I always get a "403 access not configured"

Normally, the module should do this step for you by detecting all your accounts and then display the dropdown:

post-582-0-81537000-1347191968_thumb.png

- I don't have any

- I cleared cache any time I tried something.

And please take out the MarkupCache dependencies. Not sure you've read my first post from today completely. It shouldn't install or uninstall MarkupCache core module at all. If your module is using it no need to install it, as the first $modules->get("MarkupCache") ... will install it on demand. ;)

Share this post


Link to post
Share on other sites
@hani you have to enter it in this format ga:xxxxxxx as mentioned before by wanze

Oops! Totally missed that. Thanks. :)

But, like Soma, after I put that number in like Wanze instructed I'm getting the "403 access not configured" error. I've never seen the drop down.

Wanze, thanks for all your efforts on this module! I'll play around to see if I can figure out the solution.

Share this post


Link to post
Share on other sites

By the way - I figured out a straightforward way to get your Google Analytics Profile ID.

  1. Go to your Google Analytics Account and select the domain you're working with.
  2. Click on Admin near the top right
  3. Click on the Profile tab
  4. The number is located next to "Profile ID"

Like Soma mentioned, this is different for each domain you have in Google Analytics.

Share this post


Link to post
Share on other sites

- Well is it meant to NOT enter the account ID in the module settings?

And please take out the MarkupCache dependencies. Not sure you've read my first post from today completely. It shouldn't install or uninstall MarkupCache core module at all. If your module is using it no need to install it, as the first $modules->get("MarkupCache") ... will install it on demand. ;)

No it's not. After authenticating with Oauth, the Module should give you a Dropdown to choose your Analytics Account (Domain!). It grabs the ID and stores it.

If you delete the ID in the modules setting, you should be able to choose an Account from the dropdown again.

Thank you for your tip, i will remove the dependency for MarkupCache, didn't know that it will be installed by Pw!

By the way - I figured out a straightforward way to get your Google Analytics Profile ID.

  1. Go to your Google Analytics Account and select the domain you're working with.
  2. Click on Admin near the top right
  3. Click on the Profile tab
  4. The number is located next to "Profile ID"

Like Soma mentioned, this is different for each domain you have in Google Analytics.

Thanks. But if the module would work correctly, it would set this Id for you after you have chosen the GA-Account from the dropdown. No need to find it out by yourself!

Please note that you can only display statistics from one Domain.

There's definitely something going wrong :(

Tomorrow: I'll grab a fresh copy of Pw, create a new Google API's Project and finally install the module. Hope I can reproduce what's not working...

Share this post


Link to post
Share on other sites

Oh! Okay - I didn't know that you're supposed to leave the Profile ID blank and allow the module to set it for you once you select a domain from the drop down.

So, I revoked access, deleted the cached folders and re-authenticated. When I expected to see the drop down, I now see this error:

Error calling GET https://www.googleapis.com/analytics/v3/management/accounts/~all/webproperties?key=AIzaSyCrlnK06s5YWsui7VWnH62GFYjBqjAGpZw: (403) Access Not Configured

Share this post


Link to post
Share on other sites

I figured it out! :)

I noticed the AJAX queries to grab the data are including the API Developer key in the URL. However, according to Google (https://developers.g...rence#q_summary) it says that the parameter is optional and that you should do that when authenticating with OAuth 1.0. Since the module uses OAuth 2.0 for authentication, that query parameter should be left out.

I commented out this line in the module (line 930 under the _loadGoogleApi function):

$this->ga_client->setDeveloperKey($this->developerKey);

That seems to have done the trick! It's loading the data beautifully! (And it also allows me to select the domain in the drop down correctly too.)

  • Like 2

Share this post


Link to post
Share on other sites

I figured it out! :)

Yeah that's great thank you for finding this one! :)

Seems like Google does not accept this parameter anymore, worked fine some weeks ago... I will update the source on Github today.

Share this post


Link to post
Share on other sites

Thanks Hani for finding the issue. It works here too when changing.

Share this post


Link to post
Share on other sites

Finally comitted the fix to Git!

I hope to make some other improvements in the next few weeks.

By the way, I found a stupid mistake. You were not supposed to see the "Google Analytics Account Id" in the module config, unless already chosen from the Dropdown. It's clear that people get confused when this setting exists right after the install...

Check this code out:

//Ga Account ID - only display when Account was chosen with dropdown before
$field = ($data['accountId']) ? $modules->get("InputfieldText") : $modules->get("InputfieldHidden");
$field = $modules->get("InputfieldText");

Aaaaaaaaaaargh >:( :-

  • Like 1

Share this post


Link to post
Share on other sites

One thing I noticed is that it can take quite some time to load the statistics and I think there should be some ajax loader indicator animation while it's loading.

  • Like 1

Share this post


Link to post
Share on other sites

Just wanted to say a huge thanks for the time you've put into this Wanze!

One tiny thing, can you tell me which line of code you set the admin heading. Just wanted to change from Google Analytics to Analytics to save some space in the menu!

I'm in awe of just how much code has gone into this, thanks again :)

Share this post


Link to post
Share on other sites

Thanks onjegolders, you're welcome! :)

You can change the title field of the GA-Page which is in your Site-Tree under "Admin".

Actually i hope to implement some planned improvements over the next week.

Share this post


Link to post
Share on other sites

Thanks onjegolders, you're welcome! :)

You can change the title field of the GA-Page which is in your Site-Tree under "Admin".

Actually i hope to implement some planned improvements over the next week.

Thanks Wanze, you know I didn't even realise I could access admin pages from the tree?! Cheers!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Gadgetto
      Status update links (inside this thread) for SnipWire development will be always posted here:
      2019-11-15 2019-10-18 2019-08-08 2019-06-15 2019-06-02 2019-05-25 If you are interested, you can test the current state of development:
      https://github.com/gadgetto/SnipWire
      Please note that the software is not yet intended for use in a production system (alpha version).
      If you like, you can also submit feature requests and suggestions for improvement. I also accept pull requests.
      ---- INITIAL POST FROM 2019-05-25 ----
      I wanted to let you know that I am currently working on a new ProcessWire module that fully integrates the Snipcart Shopping Cart System into ProcessWire. (this is a customer project, so I had to postpone the development of my other module GroupMailer).
      The new module SnipWire offers full integration of the Snipcart Shopping Cart System into ProcessWire.
      Here are some highlights:
      simple setup with (optional) pre-installed templates, product fields, sample products (quasi a complete shop system to get started immediately) store dashboard with all data from the snipcart system (no change to the snipcart dashboard itself required) Integrated REST API for controlling and querying snipcart data webhooks to trigger events from Snipcart (new order, new customer, etc.) multi currency support self-defined/configurable tax rates etc. Development is already well advanced and I plan to release the module in the next 2-3 months.
      I'm not sure yet if this will be a "Pro" module or if it will be made available for free.
      I would be grateful for suggestions and hints!
      (please have a look at the screenshots to get an idea what I'm talking about)
       




    • By Robin S
      I have had this module sitting in a 95% complete state for a while now and have finally made the push to get it out there. Thanks to @teppo for his Hanna Code Helper module which I referred to and borrowed from during development.
      http://modules.processwire.com/modules/hanna-code-dialog/
      https://github.com/Toutouwai/HannaCodeDialog
      HannaCodeDialog
      Provides a number of enhancements for working with Hanna Code tags in CKEditor. The main enhancement is that Hanna tags in a CKEditor field may be double-clicked to edit their attributes using core ProcessWire inputfields in a modal dialog.
      Requires the Hanna Code module and >= ProcessWire v3.0.0.
      Installation
      Install the HannaCodeDialog module using any of the normal methods.
      For any CKEditor field where you want the "Insert Hanna tag" dropdown menu to appear in the CKEditor toolbar, visit the field settings and add "HannaDropdown" to the "CKEditor Toolbar" settings field.
      Module configuration
      Visit the module configuration screen to set any of the following:
      Exclude prefix: Hanna tags named with this prefix will not appear in the CKEditor toolbar dropdown menu for Hanna tag insertion. Exclude Hanna tags: Hanna tags selected here will not appear in the CKEditor toolbar dropdown menu for Hanna tag insertion. Background colour of tag widgets: you can customise the background colour used for Hanna tags in CKEditor if you like. Dialog width: in pixels Dialog height: in pixels Features
      Insert tag from toolbar dropdown menu
      Place the cursor in the CKEditor window where you want to insert your Hanna tag, then select the tag from the "Insert Hanna tag" dropdown.

      Advanced: if you want to control which tags appear in the dropdown on particular pages or templates you can hook HannaCodeDialog::getDropdownTags. See the forum support thread for examples .
      Edit tag attributes in modal dialog
      Insert a tag using the dropdown or double-click an existing tag in the CKEditor window to edit the tag attributes in a modal dialog.

      Tags are widgets
      Hanna tags that have been inserted in a CKEditor window are "widgets" - they have a background colour for easy identification, are protected from accidental editing, and can be moved within the text by drag-and-drop.

      Options for tag attributes may be defined
      You can define options for a tag attribute so that editors must choose an option rather than type text. This is useful for when only certain strings are valid for an attribute and also has the benefit of avoiding typos.
      Add a new attribute for the Hanna tag, named the same as the existing attribute you want to add options for, followed by "__options". The options themselves are defined as a string, using a pipe character as a delimiter between options. Example for an existing attribute named "vegetables":
      vegetables__options=Spinach|Pumpkin|Celery|Tomato|Brussels Sprout|Potato You can define a default for an attribute as normal. Use a pipe delimiter if defining multiple options as the default, for example:
      vegetables=Tomato|Potato Dynamic options
      Besides defining static options as above, you can use one Hanna tag to dynamically generate options for another. For instance, you could create a Hanna tag that generates options based on images that have been uploaded to the page, or the titles of children of the page.
      Your Hanna tag that generates the options should echo a string of options delimited by pipe characters (i.e. the same format as a static options string).
      You will probably want to name the Hanna tag that generates the options so that it starts with an underscore (or whatever prefix you have configured as the "exclude" prefix in the module config), to avoid it appearing as an insertable tag in the HannaCodeDialog dropdown menu.
      Example for an existing attribute named "image":
      image__options=[[_images_on_page]] And the code for the _images_on_page tag:
      <?php $image_names = array(); $image_fields = $page->fields->find('type=FieldtypeImage')->explode('name'); foreach($image_fields as $image_field) { $image_names = array_unique( array_merge($image_names, $page->$image_field->explode('name') ) ); } echo implode('|', $image_names); Choice of inputfield for attribute
      You can choose the inputfield that is used for an attribute in the dialog.
      For text attributes the supported inputfields are text (this is the default inputfield for text attributes so it isn't necessary to specify it if you want it) and textarea. Note: any manual line breaks inside a textarea are removed because these will break the CKEditor tag widget.
      Inputfields that support the selection of a single option are select (this is the default inputfield for attributes with options so it isn't necessary to specify it if you want it) and radios.
      Inputfields that support the selection of multiple options are selectmultiple, asmselect and checkboxes.
      You can also specify a checkbox inputfield - this is not for attributes with defined options but will limit an attribute to an integer value of 1 or 0.
      The names of the inputfield types are case-insensitive.
      Example for an existing attribute named "vegetables":
      vegetables__type=asmselect Descriptions and notes for inputfields
      You can add a description or notes to an attribute and these will be displayed in the dialog.
      Example for an existing attribute named "vegetables":
      vegetables__description=Please select vegetables for your soup. vegetables__notes=Pumpkin and celery is a delicious combination. Notes
      When creating or editing a Hanna tag you can view a basic cheatsheet outlining the HannaCodeDialog features relating to attributes below the "Attributes" config inputfield.
      Advanced
      Define or manipulate options in a hook
      You can hook HannaCodeDialog::prepareOptions to define or manipulate options for a Hanna tag attribute. Your Hanna tag must include a someattribute__options attribute in order for the hook to fire. The prepareOptions method receives the following arguments that can be used in your hook:
      options_string Any existing string of options you have set for the attribute attribute_name The name of the attribute the options are for tag_name The name of the Hanna tag page The page being edited If you hook after HannaCodeDialog::prepareOptions then your hook should set $event->return to an array of option values, or an associative array in the form of $value => $label.
      Build entire dialog form in a hook
      You can hook after HannaCodeDialog::buildForm to add inputfields to the dialog form. You can define options for the inputfields when you add them. Using a hook like this can be useful if you prefer to configure inputfield type/options/descriptions/notes in your IDE rather than as extra attributes in the Hanna tag settings. It's also useful if you want to use inputfield settings such as showIf.
      When you add the inputfields you must set both the name and the id of the inputfield to match the attribute name.
      You only need to set an inputfield value in the hook if you want to force the value - otherwise the current values from the tag are automatically applied.
      To use this hook you only have to define the essential attributes (the "fields" for the tag) in the Hanna Code settings and then all the other inputfield settings can be set in the hook.
      Example buildForm() hook
      The Hanna Code attributes defined for tag "meal" (a default value is defined for "vegetables"):
      vegetables=Carrot meat cooking_style comments The hook code in /site/ready.php:
      $wire->addHookAfter('HannaCodeDialog::buildForm', function(HookEvent $event) { // The Hanna tag that is being opened in the dialog $tag_name = $event->arguments(0); // Other arguments if you need them /* @var Page $edited_page */ $edited_page = $event->arguments(1); // The page open in Page Edit $current_attributes = $event->arguments(2); // The current attribute values $default_attributes = $event->arguments(3); // The default attribute values // The form rendered in the dialog /* @var InputfieldForm $form */ $form = $event->return; if($tag_name === 'meal') { $modules = $event->wire('modules'); /* @var InputfieldCheckboxes $f */ $f = $modules->InputfieldCheckboxes; $f->name = 'vegetables'; // Set name to match attribute $f->id = 'vegetables'; // Set id to match attribute $f->label = 'Vegetables'; $f->description = 'Please select some vegetables.'; $f->notes = "If you don't eat your vegetables you can't have any pudding."; $f->addOptions(['Carrot', 'Cabbage', 'Celery'], false); $form->add($f); /* @var InputfieldRadios $f */ $f = $modules->InputfieldRadios; $f->name = 'meat'; $f->id = 'meat'; $f->label = 'Meat'; $f->addOptions(['Pork', 'Beef', 'Chicken', 'Lamb'], false); $form->add($f); /* @var InputfieldSelect $f */ $f = $modules->InputfieldSelect; $f->name = 'cooking_style'; $f->id = 'cooking_style'; $f->label = 'How would you like it cooked?'; $f->addOptions(['Fried', 'Boiled', 'Baked'], false); $form->add($f); /* @var InputfieldText $f */ $f = $modules->InputfieldText; $f->name = 'comments'; $f->id = 'comments'; $f->label = 'Comments for the chef'; $f->showIf = 'cooking_style=Fried'; $form->add($f); } }); Troubleshooting
      HannaCodeDialog includes and automatically loads the third-party CKEditor plugins Line Utilities and Widget. If you have added these plugins to your CKEditor field already for some purpose and experience problems with HannaCodeDialog try deactivating those plugins from the CKEditor field settings.
    • By horst
      Wire Mail SMTP

      An extension to the (new) WireMail base class that uses SMTP-transport

      This module integrates EmailMessage, SMTP and SASL php-libraries from Manuel Lemos into ProcessWire. I use this continously evolved libraries for about 10 years now and there was never a reason or occasion not to do so. I use it nearly every day in my office for automated composing and sending personalized messages with attachments, requests for Disposition Notifications, etc. Also I have used it for sending personalized Bulkmails many times.

      The WireMailSmtp module extends the new email-related WireMail base class introduced in ProcessWire 2.4.1 (while this writing, the dev-branch only).
       
      Here are Ryans announcement.



      Current Version 0.4.2
      Changelog: https://github.com/horst-n/WireMailSmtp/blob/master/CHANGELOG.md
      get it from the Modules Directory Install and Configure

      Download the module into your site/modules/ directory and install it.

      In the config page you fill in settings for the SMTP server and optionaly the (default) sender, like email address, name and signature.
      You can test the smtp settings directly there. If it says "SUCCESS! SMTP settings appear to work correctly." you are ready to start using it in templates, modules or bootstrap scripts.


      Usage Examples
      The simplest way to use it:
      $numSent = wireMail($to, $from, $subject, $textBody); $numSent = wireMail($to, '', $subject, $textBody); // or with a default sender emailaddress on config page This will send a plain text message to each recipient.
       
      You may also use the object oriented style:
      $mail = wireMail(); // calling an empty wireMail() returns a wireMail object $mail->to($toEmail, $toName); $mail->from = $yourEmailaddress; // if you don't have set a default sender in config // or if you want to override that $mail->subject($subject); $mail->body($textBody); $numSent = $mail->send(); Or chained, like everywhere in ProcessWire:
      $mail = wireMail(); $numSent = $mail->to($toEmail)->subject($subject)->body($textBody)->send(); Additionaly to the basics there are more options available with WireMailSmtp. The main difference compared to the WireMail BaseClass is the sendSingle option. With it you can set only one To-Recipient but additional CC-Recipients.
      $mail = wireMail(); $mail->sendSingle(true)->to($toEmail, $toName)->cc(array('person1@example.com', 'person2@example.com', 'person3@example.com')); $numSent = $mail->subject($subject)->body($textBody)->send(); The same as function call with options array:
      $options = array( 'sendSingle' => true, 'cc' => array('person1@example.com', 'person2@example.com', 'person3@example.com') ); $numSent = wireMail($to, '', $subject, $textBody, $options); There are methods to your disposal to check if you have the right WireMail-Class and if the SMTP-settings are working:
      $mail = wireMail(); if($mail->className != 'WireMailSmtp') { // Uups, wrong WireMail-Class: do something to inform the user and quit echo "<p>Couldn't get the right WireMail-Module (WireMailSmtp). found: {$mail->className}</p>"; return; } if(!$mail->testConnection()) { // Connection not working: echo "<p>Couldn't connect to the SMTP server. Please check the {$mail->className} modules config settings!</p>"; return; }  
      A MORE ADVANCED DEBUG METHOD!
      You can add some debug code into a template file and call a page with it:
      $to = array('me@example.com'); $subject = 'Wiremail-SMTP Test ' . date('H:i:s') . ' äöü ÄÖÜ ß'; $mail = wireMail(); if($mail->className != 'WireMailSmtp') { echo "<p>Couldn't get the right WireMail-Module (WireMailSmtp). found: {$mail->className}</p>"; } else { $mail->from = '--INSERT YOUR SENDER ADDRESS HERE --'; // <--- !!!! $mail->to($to); $mail->subject($subject); $mail->sendSingle(true); $mail->body("Titel\n\ntext text TEXT text text\n"); $mail->bodyHTML("<h1>Titel</h1><p>text text <strong>TEXT</strong> text text</p>"); $dump = $mail->debugSend(1); } So, in short, instead of using $mail->send(), use $mail->debugSend(1) to get output on a frontend testpage.
      The output is PRE formatted and contains the areas: SETTINGS, RESULT, ERRORS and a complete debuglog of the server connection, like this one:
       
      Following are a ...


      List of all options and features


      testConnection () - returns true on success, false on failures


      sendSingle ( true | false ) - default is false

      sendBulk ( true | false ) - default is false, Set this to true if you have lots of recipients (50+)


      to ($recipients) - one emailaddress or array with multiple emailaddresses

      cc ($recipients) - only available with mode sendSingle, one emailaddress or array with multiple emailaddresses

      bcc ($recipients) - one emailaddress or array with multiple emailaddresses

       
      from = 'person@example.com' - emailaddress, can be set in module config (called Sender Emailaddress) but it can be overwritten here

      fromName = 'Name Surname' - optional, can be set in module config (called Sender Name) but it can be overwritten here


      priority (3) - 1 = Highest | 2 = High | 3 = Normal | 4 = Low | 5 = Lowest

      dispositionNotification () or notification () - request a Disposition Notification


      subject ($subject) - subject of the message

      body ($textBody) - use this one alone to create and send plainText emailmessages

      bodyHTML ($htmlBody) - use this to create a Multipart Alternative Emailmessage (containing a HTML-Part and a Plaintext-Part as fallback)

      addSignature ( true | false ) - the default-behave is selectable in config screen, this can be overridden here
      (only available if a signature is defined in the config screen)

      attachment ($filename, $alternativeBasename = "") - add attachment file, optionally alternative basename


      send () - send the message(s) and return number of successful sent messages


      debugSend(1) - returns and / or outputs a (pre formatted) dump that contains the areas: SETTINGS, RESULT, ERRORS and a complete debuglog of the server connection. (See above the example code under ADVANCED DEBUG METHOD for further instructions!)


      getResult () - returns a dump (array) with all recipients (to, cc, bcc) and settings you have selected with the message, the message subject and body, and lists of successfull addresses and failed addresses,


      logActivity ($logmessage) - you may log success if you want

      logError ($logmessage) - you may log warnings, too. - Errors are logged automaticaly
       
       
      useSentLog (true | false) - intended for usage with e.g. third party newsletter modules - tells the send() method to make usage of the sentLog-methods - the following three sentLog methods are hookable, e.g. if you don't want log into files you may provide your own storage, or add additional functionality here

      sentLogReset ()  - starts a new LogSession - Best usage would be interactively once when setting up a new Newsletter

      sentLogGet ()  - is called automaticly within the send() method - returns an array containing all previously used emailaddresses

      sentLogAdd ($emailaddress)  - is called automaticly within the send() method
      Changelog: https://github.com/horst-n/WireMailSmtp/blob/master/CHANGELOG.md
       
       
    • By Robin S
      Sanitizer EasySlugger
      Allows the use of the EasySlugger library as Sanitizer methods.
      Installation
      Install the Sanitizer EasySlugger module.
      Usage
      The module adds four new sanitizer methods.
      slugger($string, $options)
      Similar to $sanitizer->pageName() - I'm not sure if there are any advantages over that method. Included because it is one of the methods offered by EasySlugger.
      $slug = $sanitizer->slugger('Lorem Ipsum'); // Result: lorem-ipsum utf8Slugger($string, $options)
      Creates slugs from non-latin alphabets.
      $slug = $sanitizer->utf8Slugger('这个用汉语怎么说'); // Result: zhe-ge-yong-han-yu-zen-me-shuo seoSlugger($string, $options)
      Augments the string before turning it into a slug. The conversions are related to numbers, currencies, email addresses and other common symbols.
      $slug = $sanitizer->seoSlugger('The price is $5.99'); // Result: the-price-is-5-dollars-99-cents See the EasySlugger readme for some more examples.
      seoUtf8Slugger($string, $options)
      A combination of utf8Slugger() and seoSlugger().
      $slug = $sanitizer->seoUtf8Slugger('价钱是 $5.99'); // Result: jia-qian-shi-5-dollars-99-cents $options argument
      Each of the methods can take an $options array as a second argument.
      separator (string): the character that separates words in the slug. Default: - unique (bool): Determines whether a random suffix is added at the end of the slug. Default: false $slug = $sanitizer->utf8Slugger('这个用汉语怎么说', ['separator' => '_', 'unique' => true]); // Result: zhe_ge_yong_han_yu_zen_me_shuo_3ad66c4  
      https://github.com/Toutouwai/SanitizerEasySlugger
      https://modules.processwire.com/modules/sanitizer-easy-slugger/
    • By Robin S
      If you've ever needed to insert links to a large number of files within CKEditor you may have found that the standard PW link modal is a somewhat slow way to do it.
      This module provides a quicker way to insert links to files on the page being edited. You can insert a link to an individual file, or insert an unordered list of links to all files on the page with a single click.
      CKEditor Link Files
      Adds a menu to CKEditor to allow the quick insertion of links to files on the page being edited.

      Features
      Hover a menu item to see the "Description" of the corresponding file (if present). Click a menu item to insert a link to the corresponding file at the current cursor position. The filename is used as the link text. If you Alt-click a menu item the file description is used as the link text (with fallback to filename if no description entered). If text is currently selected in the editor then the selected text is used as the link text. Click "* Insert links to all files *" to insert an unordered list of links to all files on the page. Also works with the Alt-click option. Menu is built via AJAX so newly uploaded files are included in the menu without the page needing to be saved. However, descriptions are not available for newly uploaded files until the page is saved. There is an option in the module config to include files from Repeater fields in the edited page. Nested Repeater fields (files inside a Repeater inside another Repeater) are not supported. Installation
      Install the CKEditor Link Files module.
      For any CKEditor field where you want the "Insert link to file" dropdown menu to appear in the CKEditor toolbar, visit the field settings and add "LinkFilesMenu" to the "CKEditor Toolbar" settings field.
       
      http://modules.processwire.com/modules/cke-link-files/
      https://github.com/Toutouwai/CkeLinkFiles
×
×
  • Create New...