Jump to content

planmacher

Members
  • Content Count

    16
  • Joined

  • Last visited

Community Reputation

4 Neutral

About planmacher

  • Rank
    Jr. Member

Profile Information

  • Gender
    Not Telling
  • Location
    Braunschweig - Germany

Recent Profile Visitors

832 profile views
  1. Hello - Thanks for your great module! I have a special need for the side, I'm working on right now: Is there a possibility not to show the "result_summary_field" in the rendered results, but the 'near' content of the search-match in the search field itself - with the match highlited? So lets say there is this content in the search_index field: ' Hey - this is just a simple little test for the search engine!' I am searching for the phrase 'little'. The rendered result now should show me lets say: '... just a simple little test for the s...' To be honest: My php-skills are not that good to understand all the files of your module - but as far as I can see, I am afraid that it will not be possible in an easy way to change the code for my needs!? Thanks for any reply!
  2. Hey! I just installed this module on a fresh PW 3.0.123 Everything works fine - thanks for that! Little Issue when the size of the description field is set to "0": After upload of an image, the input fields of the extrafields also are missing - only the labels are visible. After first save everything works correct! Hope, this was not discussed before ... - thanks for any help!
  3. Hello, this warning still is shown on the modules page in the backend. Or am I doing something wrong? I have just upgraded from 2.7 to 2.8. Thanks for any reply!
  4. Hello, I am using PW 3.0.62 and have trouble with inputfield type file. After uploading a file the icons for deleting and moving-up are lying over each other - so deleting is not possible. Found this problem in two different installations - so I think its a bug?! Any help? Thanks!
  5. Thanks alot and please excuse my late response!! You are right - not a good Idea - I realised it by myself, that there is an new repeater Item created by opening the input mask. Nevertheless its good to know, how to do it - will give it a try - and its great to see, that there is such a great community with a lot of help here.
  6. Hi! Hope somebody can help me ... I don't want the user to have to click on the "add new repeater item link" but would like to open it automaticly when loading the edit page. (Best would be, if this only happens if the new item would be the first item) Tried to do it with triggering the click of the add-new-item-link with javascript. But this does'nt seem to work. My java script knowledge is really poor :-( Or do I just missed something in the settings of the repeater-field??? Thanks for any feedback!
  7. Hello, very stupid - sorry! I played arround with permissions on system templates - now I cannot login anymore. Always get redirected to 404 Page. Even more stupid: Can't really remember what I did last. Tried to give a special role access to the roles Page. My thought was, that I would have to give this role access to the system templates (roles/admin/...) , but this did not work. So I set everything back to its default. At that time I did something wrong. Frontend is working fine - backend allways 404 Page PW Version 2.7 As I said: Very stupid. Any suggestions??? Thanks alot! Edit: Helped myself by restoring a database backup ...
  8. Thanks everyone for help and explanation. Everything is working fine with ready.php! So I will use this for my ppurposes...
  9. Thanks netcarver - this works! Cann you please give me a little explanation about the differences between admin.php and ready.php. Because on "https://processwire.com/api/hooks/" I found this: if you are defining hooks specific to the ProcessWire admin, you should define them at the very top of the /site/templates/admin.php. And that is what I tried to do - adding functionality to admin pages ...
  10. Hello, I am new to hooks... - so help is very appreciated! Found a lot of examples for hooks but not for hooking from the site/templates/admin.php. What would be the right syntax - for example i have tried this at the top of admin.php: $page->addHookAfter('render', 'testFunction'); function testFunction($event){ // add a "Hello World" paragraph right before the closing body tag $event->return = str_replace("</body>", "<p>Hello World!</p></body>", $event->return); } But nothing happens. Also tried it with wire()->addHookAfter('Page::render', 'testFunction'); What is wrong?? Thanks for helping!
  11. Very appreciated! Sent you PM ... I am very new to PW - so perhaps I am thinking/doing something wrong very basicly. Thanks!
  12. Hello and thanks for reply! So again... Module User: Hometemplate: And the name of the "projekte" page is really "projekte". Tried it even with another role and template name. Always the same: The permissions to the user are the same for all the pages. Anny ideas??
  13. Sorry for late resonse!! And thanks for the link - I will give it a try!
  14. Hello, I can't get this module to work - perhaps you can help me. I have a very simple page tree: All of the first level pages (under "home" ) have the same template. So it is not possible to restrict a branch via user roles. But AdminRestrictBranch sholud do this... - but how? Lets say I woluld like to restrict the user "test" to the branch "projekte". So in the module under "how to match user t branch" I choose "Role Name: Then I add a new role "projekte": Which boxes do I need to check there? Then I add this role to the user "test: What do I have to set in the template options? Are there other permissions the user should get in oder to get this module to work? Whatever I tried - the result is: The users have same permissions to all the first level pages in the tree. Would be great if you can give me some help ...!
×
×
  • Create New...