Jump to content
neophron

Can't login, but no error message (solved)

Recommended Posts

Hi there,

a few weeks ago I completed a 3.098 installation (server php 7.2). Yesterday I wanted to login but failed. I tried different browsers, meanwhile on two different PCs, but no login.

Then I realized, that after hitting the »Login« button, there was no message (admin name – Login failed). I also tried all procedures (https://processwire-recipes.com/recipes/resetting-admin-password-via-api/). Then I checked the errors.txt (site/assets/logs) – nothing.

The frontend works fine. Is there a way to check this Processwire installation? Could be something missing?

 

Share this post


Link to post
Share on other sites

Activate debug mode in config.php, and also check your server's error log files. With something like the web development browser extension you could at least see if the server returns HTTP 200 or 500 - that would be a start for further debugging. You could also copy everything to another server, and try if you can login there (of course, do a mySQL dump, adjust config.php file etc.)

  • Like 2

Share this post


Link to post
Share on other sites

Thanks,

the debug mode is active.
These are the server logs statistics:

[Sat Nov 24 02:56:21 2018] [php7:error] [pid 31827] [client 2c0f:f038:208:8e00:453:7af4:3aa7:c8dc] [host robin-shillcock.com] script '/is/htdocs/wp1155705_7UFJDYJEXF/www/processwire_10-2018/wp-login.php' not found or unable to stat
[Sat Nov 24 03:02:46 2018] [php7:error] [pid 27344] [client 198.44.228.85] [host xxx.com] script '/is/htdocs/wp1155705_7UFJDYJEXF/www/processwire_10-2018/fuck.php' not found or unable to stat
[Sat Nov 24 03:02:48 2018] [php7:error] [pid 27384] [client 198.44.228.85] [host xxx.com] script '/is/htdocs/wp1155705_7UFJDYJEXF/www/processwire_10-2018/coon.php' not found or unable to stat
[Sat Nov 24 04:56:06 2018] [php7:error] [pid 19825] [client 111.93.22.58] [host xxx.com] script '/is/htdocs/wp1155705_7UFJDYJEXF/www/processwire_10-2018/wp-login.php' not found or unable to stat
[Sat Nov 24 14:33:27 2018] [php7:error] [pid 8407] [client 87.142.120.228] [host xxx.com] script '/is/htdocs/wp1155705_7UFJDYJEXF/www/processwire_10-2018/reset.php' not found or unable to stat

 The last entry is from my attempt to change the login with a reset.php. But someone tried to check, if this is Wordpress site.

Share this post


Link to post
Share on other sites

When we submit the login form of your admin page, the response is a 404 error code. Also your attempt to visit the reset.php failed, you might have an issue with the .htaccess file.

 

You could try the following :

  1. backup everything
  2. create a file - disable-procache.php - on the root web dir (along the index.php file) with this code:
    <?php namespace ProcessWire;
    require_once('./index.php');
    // get the module
    $pc = $modules->get('ProCache');
    // turn off procache
    $pc->cacheOn = false; 
  3. visit the page at http://yourwebsite.com/disable-procache.php
  4. replace the .htaccess file with this https://github.com/processwire/processwire/blob/master/htaccess.txt (do not forget to rename it to .htaccess)
  5. try to login - result ?
  • Like 2

Share this post


Link to post
Share on other sites

Thanks for your suggestion.

Thanks god, I had a backup (the Duplicator saved my ass). I extracted it and installed it in a subdomain. Login was no problem. Then I replaced the old htaccess with new one and – et voilla – I'm in. I remember, that I had to deactivate some rules in the htaccess file, cause Processwire had some problems with this hoster (Host Europe).

I think the reason was, that I added some rewriting stuff to the htaccess.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By daniel_puehringer
      Hi Community,

      Sadly I cannot intall ProcessWire on my webserver (Hosted at https://www.world4you.com/de/startseite.html, a small hosting provider in Austria)
      Here is the Problem: 
      1. I downloaded the current masterbranch as a .zip file (After a few tries I also downloaded the code via the git clone command, that led to the same error), unzipped it and transferred it to my server. Since there is already a wordpress site installed on the root directory, I transferred the processwire files into /relaunch and created a subdomain.
      2. I tried to install the language starter kit. As soon as I navigate to that folder Screenshot1 (see attached file 'processWireBug1') is shown. Everything looks nice, except the red text referring to the 'mod_rewrite' rule. The webserver provides the 'apache mod_rewrite' rule.
      3. As soon as I want to press 'Check again' or 'Continue to next step' an error Page with 500 error (see Screenshot 'processWireBug2') occurs.
      4. You can find my .htaccess file attached to this post..htaccess

      How could I solve this issue?

      Some additional information:
      1) the webserver provides the apache mod_rewrite (I checked that several times) and has php version 7.3. installed.
      2) since there is a wordpress site installed on the root directory, there is also a .htaccess file on the root directory. Could this .htaccess file have an impact on the .htaccess file for my processwire website?

      Thanks for your help and greetings from Austria,
      Daniel


    • By horst
      Hi, on a site I want to disable access to original images and only allow to access thumbnails and watermarked image variations.
      EDIT:
      A good solution for protecting original images can be found a bit down in this thread:
       
      Old content of this initial post:
       
    • By Peter Knight
      Hi all
      My .htaccess file is correctly redirecting all requests to
      https:// www. That's great until I want to work locally.
      I thought I had seen a blog post by Ryan where there was a new config setting to ignore both of these if working from localhost?
      I can't find it now so wondering if I was imagining 😕
       
       
    • By ce90
      Hello everyone,
      hopefully this is the right place to ask and is not a duplicate question.
      I'm pretty new to processwire, so... if this question is kind of funny for some of you, you're welcome 😄 
      I have the following issue and can't find anything understandable about it. Maybe I'm searching the wrong way, but anyways.. here is my question:

      How is it possible to rewrite the URLs, that I'll get a *.php ending?
      Example:
      https://www.mysite.de/urlsegment/ -> https://www.mysite.de/urlsegment.php
      https://www.mysite.de/urlsegment/urlsegment/ -> https://www.mysite.de/urlsegment/urlsegment.php
      Because I've read a lot about "Why do you wanna do this or have that?" – here my answer for that in advance:
      I've built a processwire installation inside or around an existing website. Therefore, we want to keep the existing *.php Google entries. Sure, we could redirect via 301 Redirect, but would prefer to keep the *.php ending.
      If you have further questions, please do not hesitate to ask.
      Thank you in advance for your help.

      Best regards
      ce90
    • By Orkun
      Hi Guys
      How can I make a redirect inside the .htaccess to my custom maintenance.html file when any URL of my Website is accessed except the processwire admin (www.example.com/processwire/).
      Because I want that my User's still can access the website when they are loggedin in Processwire.
      When the current url starts with /processwire or if there is a processwire-login-cookie (Is there a cookie when user is logged in Processwire?) available the redirect should not work. Otherwise it should work.
      How can I achieve this?
×
×
  • Create New...