Jump to content
buothz

Admin area problem after server migration

Recommended Posts

Hi, i've changes server, linux to linux, but i have a problem...

- i have reload all files from old server

- i have reload all db from old server

- i have configurated only file ../site/config.php to new database user, pass...

site is ok but when i go to mysite.com/processwire

give to me this errore (debug: true):

Strict Standards: Declaration of Pdfcomposer::___execute() should be compatible with that of Process::___execute() in /htdocs/public/www/site/modules/Pdfcomposer.module on line 3 Warning: Cannot modify header information - headers already sent by (output started at /htdocs/public/www/site/modules/Pdfcomposer.module:3) in /htdocs/public/www/wire/core/Session.php on line 272 Warning: Cannot modify header information - headers already sent by (output started at /htdocs/public/www/site/modules/Pdfcomposer.module:3) in /htdocs/public/www/wire/core/Session.php on line 273 Warning: Cannot modify header information - headers already sent by (output started at /htdocs/public/www/site/modules/Pdfcomposer.module:3) in /htdocs/public/www/wire/core/Session.php on line 274

but i don't see the site admin panel, a blank page with only the error.. where is the error?

Share this post


Link to post
Share on other sites

soundas pdfcompsar have.meinor problemo

yo.must edit /site/config.php, changes

$config->debug=true;

to $config->debug=false;

  • Like 2

Share this post


Link to post
Share on other sites

soundas pdfcompsar have.meinor problemo

yo.must edit /site/config.php, changes

$config->debug=true;

to $config->debug=false;

resolved with debug off and pdfcomposer uninstall... thank u!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rolisx
      Hi Guys,
      Just finished a website locally and wanted to upload it on the webserver of my customer. I got a server 500 error. Now, the guidelines of the hoster (world4you.com) does not allow "Options" in the htaccess-file. So, when I uncomment these:
      Options -Indexes
      Options +FollowSymLinks
      the site is visible, but the content won't show and no links are available. Not sure if I need the Symlinks-part but I guess I need a workaround for the Index-part. Can anybody help here? I need the website up and running asap....
      Thanks!
      Roli
    • By jploch
      Hi folks!
      For a website Iam working on I need to (pre)load a huge amount of images (100-500) from a folder in assets (wich I upload via FTP).
      To preload them I want to add them to the DOM inside a container, that I hide with css.
      This images will be use for a frame by frame animation (that animates with scrolling) so they should be loaded parallel and if the user clicks a cancel button, the loading should be canceled. (My website is using ajax to load pages with different animations, and the loading of the second animation waits till the loading of the first animation is loaded completly, wich I want to prevent). 

      I want to use ajax to do this, so I can cancel the loading with xhr.abort();
      Here is my code:
      var folder = '{$config->urls->assets}sequenzen/test/'; xhr = $.ajax({ url : folder, success: function (data) { $(data).find("a").attr("href", function (i, val) { if( val.match(/\.(jpe?g|png|gif)$/) ) { $(".preloader").append( "<img src='"+ folder + val +"'>" ); } }); } }); this will give me a 403 forbidden error.
      After some research I found out that I have to put a .htaccess in my assets folder.
      I also tried putting it in the sub folder "test", where the files are, but Iam still getting the error.

      Is there anything else Iam missing? Is there a configuration in PW i have to change to do that?
    • By sirhc
      Hi all,
      I got a Internal Server Error when accessing de /setup/fields in my back end...
      Also when i try to reach it through the page tree, i can't edit the 'fields' page, same error.
      I do modify a image field through the api, i don't know if that has something to do with it, below the code i use to upload an image through the api, I deleted the parts that are not important. If anyone can help me that would be great.
      To clarify; the code below works fine, my image and page is created as expected, the only thing is that I can't access my /setup/fields/ page in my CMS anymore due to the Internal Server Error.
       
       <?php              if($input->post->submit) {             $photoPage = new Page(); // create new page object             $photoPage->template = 'photo'; // set template             $photoPage->parent     = wire('pages')->get('/foto/'); // set the parent                          $photoPage->name     = urlBuilder($input->title_photo); // give it a name used in the url for the page             $photoPage->title     = $input->title_photo; // set page title (not neccessary but recommended)                          $photoPage->save();                              // next: process photo upload                          // Set a temporary upload location where the submitted files are stored during form processing             $upload_path = $config->paths->assets . "files/photos/";                          // New wire upload             $file_upload = new WireUpload('file_upload'); // References the name of the field in the HTML form that uploads the photo             $file_upload->setMaxFiles(1);             $file_upload->setOverwrite(true);             $file_upload->setDestinationPath($upload_path);             $file_upload->setValidExtensions(array('jpg', 'jpeg', 'png', 'gif'));                          // execute upload and check for errors             $files = $file_upload->execute();                          // Run a count($files) test to make sure there are actually files; if so, proceed; if not, generate getErrors()             if(!count($files)) {                 $file_upload->error("Sorry, but you need to add a photo!");                 return false;             }             //success                          //echo 'photos stored';exit;                                  $photoPage->save();             //$session->redirect($locationPage->url);         } else {      ?> <section class="add-location">     <div class="container">         <div class="row">             <div class="col-xs-12">                      <h2>Spot toevoegen</h2>                 <form id="add-form" action="" enctype="multipart/form-data" method="post">                     <input type="hidden" name="MAX_FILE_SIZE" value="<?php echo $max_file_size; ?>" />                                          <div class="col-xs-12 col-md-6">                             <label for="fileselect">Upload jouw foto:</label>                         <p>                                                          <input type="file" name="file_upload" id="file_upload" accept="image/*"  class="inputfile" />                             <label for="file_upload">                                 <span></span> <strong><i class="fa fa-upload" aria-hidden="true"></i>                                 Kies je foto…</strong>                             </label>                                                      </p>                         </div>                                                  <input type="submit" name="submit" value="Upload" />                     </div>                 </form>                  </div>         </div>     </div> </div> <?php } } include('./includes/foot.php');?>  
    • By panx
      Has anybody installed a server on a android tablet to run processwire?
      I found KSWEB (server + PHP + MySQL) for android.
      KSWEB includes:
      - lighttpd server v1.4.35
      - nginx v1.9.3
      - PHP v5.6.12
      - MySQL v5.6.19
      - msmtp v1.6.1
      - Web Interface v1.2
      - KSWEBFTP v1.0
      - scheduler
      Does it have everything what processwire need?
      Thanks in advance
    • By szabesz
      I am subscribed to MacUpdate's daily newsletter, and there is a new promotion: https://www.macupdate.com/app/mac/56703/gopanel
      I'm sharing the link of my email, since there is no sign of the 50% off on the site: normally the promotional offers of apps at MacUpdate are also indicated on these pages as well, but this time it is not for some reason (human error?).
      Anyway, reading up a bit on goPanel, some of you might be interested in it. Check out the "user guide" for a quick overview of the features: http://gopanel.io/user_guide and the FAQ: http://gopanel.io/faq
      Currently goPanel provides basic functionality but for the current $12.49 offer (one time payment, unlimited servers, lifetime access) it looks like a good utility for those interested (they say they are planning to add more features.)
      Edit: I removed my email's link from this post, because in the meantime they updated the app's page, so you can get the discount by going there.
×
×
  • Create New...