Jump to content

Switch from ssl to non-ssl in frontend does not work anymore


Recommended Posts

I tried to update one of my websites from 2.3.8 to 2.3.9 and noticed a problem. I'm using some contact forms, which templates are set up to use ssl only. The other templates are configured to use http only.

If I'm moving back from ssl to non-ssl pages in frontend, I get the following error:

"Moved Permanently
The document has moved here."
URL of this page shown in browser is like: http://www.mydomain.com:443/mypage/
(should be for sure: http://www.mydomain.com/mypage)
It worked with 2.3.8, so I suppose the problem is somewhere in the file "/wire/core/ProcessWire.php", in function "getHttpHost(Config $config)" - this is one of the places of which "diff -r" is telling me that is has be changed between 2.3.8 and 2.3.9.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...