Jump to content

Search the Community

Showing results for tags 'text'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to ProcessWire
    • News & Announcements
    • Showcase
    • Wishlist & Roadmap
  • Community Support
    • Getting Started
    • Tutorials
    • FAQs
    • General Support
    • API & Templates
    • Modules/Plugins
    • Themes and Profiles
    • Multi-Language Support
    • Security
    • Jobs
  • Off Topic
    • Pub
    • Dev Talk

Product Groups

  • Form Builder
  • ProFields
  • ProCache
  • ProMailer
  • ProDrafts
  • ListerPro
  • ProDevTools
  • Likes
  • Custom Development

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 11 results

  1. Hello guys. I feel a bit ashamed of this fact but I just needed to add an image with some text wrapped around it using CKEditor and I simply can't achieve that. I have an image field attached to the template (called images) and it is showing promptly the uploaded images. I am able to manipulate the image and I set its alignment to left side. Then I add some text and I can see in CKEditor that the text is properly surrounding the image. However, once I save the page and view it, it shows the text under the image or only a line is staying asside the image and the rest is under the image again. As far as the field used for the text (body) is set to TextMultiLang and I did not added any text formatters and chose the content type to be HTML/Markup. In my CSS I've added some of the PW styles for the alignement as per some posts here but that did not help either. Something I am missing again?
  2. I have a few fields which are using the textField filedtype. Some of the data for these fields contain LaTeX code. However, the CKEditor does not have the abilities to parse it. Is there any solution for this problem? I am currently using Processwire 2.7
  3. Another dumb question: Is there a field type for a text-based array? In my case I need to store an array of RSS feeds for SimplePie. Storing that list of links in a textarea - text formatted to look like an array - doesn't work with the script. It works with one link. The images field is an array. I assumed there would be an equivalent for URLs or text in general. Or is there another approach for these cases? Edit: I guess using the optional (module) Repeater field type is the best solution in this case? I have now a working solution based on that. Still curious about other ideas.
  4. Hi all, Just wondering if its possible to just add some basic output to my modules config page. I was wanting to output a bulleted list of some information which I will be pulling from a third party. Retrieving the data is fine i'm just not sure how to output it to the config page? From what I can see in the link below, it only seems like you can append form items to the page. https://processwire.com/blog/posts/new-module-configuration-options/
  5. I'm sure the answer is fairly simple but I was wondering if there's an easy way to define the number of lines for a textfield in a template. I know you can set size limits for images fairly easily using $image->size(100, 100); but wondered if there was the equivalent for text?
  6. Hello everyone, My Website works just fine beside the one field which behaves strangely and I can't figure out why. I have a template called "main-subpage" which I use for most subpages. All of them have a header and on every other Page it works just fine. But on the one page it displays the first few letters random and sometimes the last ones corectly, sometimes the last ones are wrong as well. What iritates me is that this is only on the one Page and all the other pages with the same template don't have that issue. The rest of the page is displayed just fine. I tried different content in the field but it doesnt seem to help anything. Code in the template: <h1> <?php echo $page->header | $page->title; ?> </h1> on the page it should display: "Das Konzept des ZiSMed" but what I see is (attachement): Thank you for your help! display.tiff
  7. Hello everyone. I am having an issue with navigating the Processwire site, as well as the web to find anything useful to help me get a text editor installed in Processwire. I am not new to development whatsoever, but this is the sort of thing that makes people go to craptastic Wordpress, because its super easy to find what you need. Does anyone have any suggestions whatsoever on how to get a text editor field(exactly like the one I am using to write this thread, if at all possible)? I am building a site and all my beautifully written Processwire PHP hooks work great, but when it comes to something simple like setting up and using a module, nothing good is easily found.
  8. Hi there, Bit of a rookie question. It appears that one of my users tried to store some Markup in a Textarea field for some SEO Text, but it was stored as HTML Entity chars (< >) I checked the field type details (TextArea, No Formatters, Content-Type:Unknown) and tried a few things (TinyMCE, Markup/HTML Type) to no avail. I was wondering if there's a quick fix for this as I'm almost resigned to writing a on-the-fly formatter to fix this. I'm hoping some one can point me to a more CMS centric solution?
  9. Hello - Total newbie here. I'm using the Profields module to make a table for settings. I would like for one row to contain a "copyright date" with a corresponding integer value according to https://processwire.com/talk/topic/8373-use-delimited-texarea-table-or-yaml-for-settings/ I have this code (courtesy of @Macrura) $copyYear = 2015; // Set your website start date $curYear = date('Y'); // Keeps the second year updated echo $copyYear . (($copyYear != $curYear) ? '-' . $curYear : ''); I want to set the value for $copyYear in a text field. Will it be parsed as an integer? Thanks!!
  10. Hello, Just starting. I've tried to look to the files head.inc and foot.inc. I'm trying to find the way to assign text from CMS to the html. I already have applied this as a template and it works. I have the images working and all links working. In this website there are several different parts which I need to put text which can be transformed with PW. I need to do: Intro News About me Booking info Contact Therefore, as you can see there will be several independent text boxes. My html/css is a horizontal layout so everything is one one file index.php. Each div is a section. I think this is quite easy so please let me know... Thank you.
  11. Does anyone have suggestions on how to put in formatted sample text in a textarea editor? For example, I want to have several templates and for each body content textarea field, I would place in sample text that is formatted accordingly. Then a user would simply highlight the text, put in their text, and everything is nice and formatted. Would I need to create my own textarea module to do this?
×
×
  • Create New...