Jump to content

Installed SSL cert, path to assets are now 404


Recommended Posts

Hello community,

This is the first time I have enabled SSL with PW powered site so forgive the question.

Templates are set to HTTP or HTTP so content is being processed. However all the assets do not load correctly eg.

Failed to load resource: the server responded with a status of 404 (Page Not Found)



Any tips?

Thank you!

Link to comment
Share on other sites

Hi szabesz,

I don't need the entire site to be https just a segment/page. I would like to have HTTP as fallback in case SSL certs laps and expire. So at this point I could turn the entire site towards https (I see that .htaccess can be used) but I can't find how to adjust https vs. http for asset path processing. 


Thank you.

Link to comment
Share on other sites

If I'm not mistaken, browsers will complain if pages are being served as HTTPS with insecure resources. Further, I understand that Google is beginning a process that marks non HTTPS sites (or pages) as insecure. As such, my recommendation is simply to turn it on for everything and ensure it never expires.

Reference: Google Chrome to start marking HTTP connections as insecure

  • Like 3
Link to comment
Share on other sites

On 12/12/2016 at 4:13 PM, Gideon So said:

The .htaccess file come with ProcessWire should work out of the box.

The only reason I can think of is that the web server doesn't allow you to override it's default setting values.

Do you have access right to the web server config??




Thanks for the tip!

Turns out my host had to add https URLs to the list of allowed URLs for Hotlink protection option. All is good now! 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...