Jump to content

antpre

Members
  • Posts

    124
  • Joined

  • Last visited

Everything posted by antpre

  1. Sorry to come back on the issue again. It works fine when there is only one repeater field in the db migration. As soon as I add more than one the warning message comes again (I have tested these repeater independently in one db migration and then it works).
  2. Thanks a lot MarkE, I had no idea that there was a system template created for every repeater field (it make sense when you think about it). It works fine. Thanks a lot for your support and the module.
  3. Hi @MarkE, here is the screen shot. regards
  4. Hi, I ve been testing the module a bit today. Could export/import : fields (date, text,page ref), templates, pages. It worked well. Great However I have had a problem with repeater fields. I get this error message when I add a repeater field migration item at the time when i click the "export data" button. I am a bit confused cause no template are related to repeater field. I m not understanding if i am doing something wrong. I first tried a migration with all the fields included in the repeater plus the repeater field itself. Then I tried a migration with only a few repeater fields. Same result. In the screen shoot each item is a repeater field (title_workflow...). Any idea. Thanks a lot
  5. Hi MarkE, Thanks a lot for your response. with the latest DbMigrationPage.class.php eveything went fine. I was impatient to try this module that adds a set of features that I was realy missing in PW. Hope the module will go on the PW module page at some point. Thanks again. Bye
  6. Hi, Sorry for the previous message. It seems to be my environment that is not working fine. I could set up the module in two other environments. Got a warning message (see screen shot below). Same message in both case. But module was installed but the dbmigration page were not installed. So not realy usable. Is there something I am missing in the installation process ? Regards
  7. Hi, Tks for the module. Wanted to install it to give it a try. I got this error message when the installation started. I have installed the Fieldtype Runtime Only module before. do you have any suggestion ? I am running it on ProcessWire 3.0.164 and php 7.4 Thanks a lot
  8. Hi thanks for the module, Tried a fresh install of v2.0 with PW 3.0.168, I works well when I am logged in and navigating the pages. But as soon as I browse not logged in, the pages hits are not recorded. Any idea. Nothing fancy on my side : templates don't have url semgent activated, it is not a multilanguage install, the pages are not cached at present. The js plugin of the module seems to be loading properly.... No specific configuration as been made. I have not install the pagehit field type for now, rest of the module conf is standard (as it comes after install). I just have list edthe template I wanted to track and set the session life time to 0 for testing purpose. On an other topic, just saw that you answered my question about multilingual install. Thanks you and sorry I missed your answer. This is why I didnt' react. I will surely test it again in my multilanguage set up. Regards
  9. Hi, just bump into an issue and the impossibility to configure an option for no extension (via the admin or the wireUpload API) would have been handy. On Android if you upload a audio file, the file is uploaded without extention (that's not a bug but an inteded thing saw a few stackoverflow threads on that). As a result I am unable to offer the possibility to upload mp3 files from a android device without some extra js code. In my use case only one admin would have had access to this uploading functionality. As a result no possibility to upload an audio file from the processwire admin if you are trying to do it from an android device. Therefore yes an option would have been nice. But I do understand the security related issues.
  10. Hi, Found a stackoverflow thread. It seems that on Android when you upload an audio file the extension is not present in the file name. This explains. Still searching for a solution. Regards
  11. Hi, Little update. I tested on a samsung S9 with firefox. Same issue, the mp3 file is rejected (before the upload starts). I will try with an Iphone also.
  12. Hi, I bump into this exact same issue (5 years later !) I run PW 3.0.168, php 7.4. tested with Uikit and standard Admin UI theme. I tested on android 10. phone is a xiaomi mi mix 2S With two browsers : chrome and firefox. my file field is set up like this see pict. I tested with other files extension types and it worked (pdf, jpeg). Only with MP3 do I have this problem. The file browser (that opens when you want to select the file) is the Xiaomi proprietary app. What Hellmoto mentionned is also happening. When the file manager app opens to select the file you want to upload, the extension doesnt appear in the file name for MP3 whereas the file extensions appears in the displayed named for other types of extension. I ll will try to test with some other android file manager. Any Idea ? Thanks
  13. Hi, tks for the module. I am triggering the db Backups using a script and a server cron job. The code of the script is this namespace Processwire; require_once(__DIR__ . '/../../../index.php'); $cron_backup =$wire->modules->get('CronjobDatabaseBackup'); $cron_backup->cronBackup(); With this script the db backup file is created but when I access the db backup admin screen. I get these notifications (see screen shoot) and it seems that the db file cannot be read. I checked the rights on the db files created this way but they are the same than the other backup files (created with the db backup module). If I use the 'normal' lazy cron way with this module there is no problem. Any idea ? Tks a lot
  14. Hi thanks for the module, It 's seems the permission issue mentioned earlier (if user doesn't have an edit permission error messages show up in the modal window) is still there. It would be great if the create button would be permissions aware and not been displayed if user doesn't have the edit rigths. Is this something that can be added at some point ? Thanks
  15. OK thanks for your response, I ll check that.
  16. Thanks a for your answer. Sorry If I was unclear in my explanation. I am aware of what you mentioned. I am just trying to figure out why, when the admin template has access control on and only super user can see admin template based pages, why non super user in the back end still see the Admin Custom Pages I ve created and no other admin pages. These custom admin pages should be equally hidden in the same way than the other admin pages. But I guess that your module does not interact with access control. So I ll keep searching. Regards
  17. Hi, I have a question, can't get to pass option to a chart panel. Whatever option are not getting apply. must be a synthax probleme maybe. Here is the code. for instance with this code the legend is still below the doughnut (it should be rigth to it) and the dougnut is fairly thin and it should be 50%. Thanks for your help. $panels->add( ['panel' => 'chart', 'title' => 'Tags Status', 'data' => [ 'chart' => [ 'type' => 'doughnut', 'data' => [ 'labels' => ['Doc without tag','Doc not reviewed','Docs tags OK'], 'datasets' => [ [ 'data' => [$noTag, $TagNotReviewed, $TagReviewed] ] ], 'options' => [ 'cutoutPercentage' => '50', 'position' => 'right', ] ] ] ] ] );
  18. HI, Tks for the userfull module. I bumped into a funny issue related to role and permission. I have added a role for editors that can access backend with limited permissions (page view, page edit, some listers). For some reason, the admin custom page are shown in the setup menu. These are the only admin pages that are displayed to the editor. I realy don't understand why. I have not change any access parameter on the admin template thats only accessible to superuser. Any idea what going on (it's a multilanguage site). Tks for your help
  19. Hi, I am trying to run a script on my processwire installation (custom admin page). This script has to work with external files (hosted on S3). The php fopen command returns a "failed to open stream: HTTP request failed! HTTP/1.1 400 Bad Request " On my php ini the allow_url_fopen is on . I guess it is not an issue with php conf If I copy the url of the file I am trying to open, in a browser, I can access the file. I guess it is not a permission issue on the S3 bucket. Any idea would be welcome Thanks a lot
  20. @d'Hinnisdael : Thks a lot for the module. It's a real saving grace and makes it a breeze to present good looking admin dashboard. And the documentation is very well done too. Thanks again for all the good work.
  21. Thanks horst and Krlos, By generic user name you mean using one single user account with a generic name and then distribute the password to every member. This is what I was trying to explain (the first option in my initial post)... but was not clear enough ! I can do this but I was wondering if having multiple users connected at the same time with the same user account would be problematic. If it can work that way, that's the best for me.
  22. Tks Krlos for your answer. The module you mentioned leverages the PW user system wich is what I am trying to avoid because I don't want to ask users to create a user account to log in. Regards
  23. Hello everyone. I have a "newby"'s question regarding password protecting the front end of on one of my website. The web site in question is for the members of a small scale non profit organisation. It should not be easily accessed by non members but they don't want to force their members to create a personal user account. From their point of view a simple common password should be enough. Here is my question : Can I use a newly created user and in the login form only ask for the password (I will feed the username in the code). In this case many users will potentially log with the same user at the same time. Is this approach correct, are there any drawbacks (performance ?)... or is it realy a bad idea 🙂 Otherwise I can just implement a simple password protection function without using the user system (didn't find a module addressing that need). Thanks for your help
×
×
  • Create New...