Jump to content

php 7 issues

Martin Wuehr

Recommended Posts

Hello everybody,

a clients server was updated to php7. 

As a result, the php code used with processwire isn't interpreted correctly any more. The foreach loops are commented out so as a result a part of the php code is displayed in the browser.

I tried to use <?php instead but the result was the same.

Any ideas? Thank you for your help!




Link to comment
Share on other sites

  • 2 weeks later...

Thank you so much for your replies

The addition to the php.ini did the job!

(The server guys are't the fastest...)

But now there is a different problem. Now only the index site will be displayed. Every link to a different site is dead and promted  an error. The server-guys think, that this is related to the changes in the php.ini. I can't believe that. Also the backend can't be entered. 

Before the changes in the php.ini everythings runs perfectly...

Here is the site:


Any Ideas?

Thank you


Link to comment
Share on other sites


I already checke the RewriteBase in the .htaccess file. It was activated so I commented it out for testing but with no success concerning the Link Problem.

So the Browser prompt show the correct URL. Could it be something with the local Port443?

Thank you 



Link to comment
Share on other sites

Look like there is still a problem with your .htaccess or as @kongondo said, a language issue. Is your website a multi-language one ?

What happen if you activate the .htaccess directive RewriteBase / ?

# -----------------------------------------------------------------------------------------------
  # 11. OPTIONAL: Set a rewrite base if rewrites aren't working properly on your server.
  # And if your site directory starts with a "~" you will most likely have to use this.
  # -----------------------------------------------------------------------------------------------

  RewriteBase /
  # RewriteBase /pw/
  # RewriteBase /~user/


Link to comment
Share on other sites


the site isn't  a multi-language one.

I activated and deactivated the RewriteBase with no success. I was already aware of this potential issue.

The server was updated to php7 (from 5.2). After that we had the Problem with the php Short Code.

At this point, the site ran perfectly well, besides the php short code issue. This was solved via php.ini thanks this thread.

After fixing the short code, the link problem occured. The server guys blame the php.ini short code change for that, but I can't believe that. 

There were no changes on the ProcessWire Installation or .htaccess File from my side over the entire process.

In the Links above I found the hint to enable mod_rewrite on apache and AllowOverride. I will give that to the server guys, hoping to fix the problem...

Thanks Martin

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...