Jump to content

installation step 4 missing or not working

Recommended Posts

During the install process I can never get to Step 4 for setting up an admin account.

It creates the database and in the screen it shows it installed the database and imported the SQL

and under that it shows "Profile Import" but nothing else.

I have the same result with master & dev branch.

I looked in the database and do not see a user table of any kind, unless it has some other name than "users"

Share this post

Link to post
Share on other sites

Hi @neosin

Are there errors in PW and server logs? 

There is the similar thread


  • Like 2

Share this post

Link to post
Share on other sites

thanks, it seems that same issue was never resolved.

I guess I am out of luck trying to test this locally

Share this post

Link to post
Share on other sites

What's your environment like? If you're on xampp, check the logs for clues or maybe try laragon. I find it easier to work with and haven't had problems with the last few (10+) machines that I had to install/setup ProcessWire on.

  • Like 1

Share this post

Link to post
Share on other sites

I managed to resolve the installation issue by installing on a windows machine with no ACL. Now the installation went just fine.


thank you for your time

Share this post

Link to post
Share on other sites

What do you mean by "windows machine with no ACL"?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Nik Groningen
      Currently I'm developing a platform and use Processwire for some of the backend. Everything is working very well on localhost, but the installation on namecheap does not complete. I've read some comments on this forum that mentioned hosting on namecheap (without mentioning issues). 
      Attached is a screenshot of the last step of the installation. It looks very similar to the problem mentioned in this thread: https://processwire.com/talk/topic/15516-processwire-do-not-complete-installation/. Unfortunately, this didn't help me. I also attached a picture of the server. In the error_log, i do get some error messages related to includes and requires like:
      [18-Jun-2020 03:42:32 America/New_York] PHP Fatal error:  require(): Failed opening required '/home/niklcicr/public_html/wire/config.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/niklcicr/public_html/wire/core/ProcessWire.php on line 1199
      On the last screen, the console outputs a internal server error 500.
      That's what I tried: Installation on another server (freeinfinity) and it worked fine, installation on another namecheap account (did not work), and I adjusted the .htaccess file according to other threads in this forum that had similar problems (did not work).
      Is there anyone who got Processwire to work on namecheap hosting or can point me in the right direction? 
      Thanks in advance,

    • By mushmush45
      Could anyone advise me on the following system requirements, which I am missing for ProcessWire installation:
      DO (pdo_mysql) is required (for MySQL database)
      Fail: GD 2.0 or newer  Fail: JSON support ZipArchive support was not found. This is recommended, but not required to complete installation.    
    • By godmok
      Hi everyone,
      I can't get my head around this, so maybe someone can help: I want to know how install the dev branch of processwire with composer.
      I use laragon and the "quick create" function and there you can run composer like this: "composer create-project processwire/processwire %s". OK, this is working, so I will get the master branch from it, but how about dev? I found some examples for laravel on this question, but no luck with it. Here some examples:
      composer create-project processwire/processwire %s --prefer-dist --stability=dev composer create-project processwire/processwire:dev %s composer create-project processwire/processwire:dev %s --stability=dev composer create-project processwire/processwire:dev %s --prefer-dist --stability=dev composer create-project processwire/processwire:dev-master %s --prefer-dist --stability=dev composer create-project processwire/processwire:dev-branch %s --prefer-dist --stability=dev composer create-project processwire/processwire:@dev %s --prefer-dist --stability=dev and so on... Maybe someone got this already and would like to share?
    • By devlisa
      Hello. I'm not new to Processwire (I've been using it on a Mac environment for multiple site builds), but I am new to installing it on a Windows environment. I have unsuccessfully installed Processwire 3.0.62 both via downloaded zip file and GitHub on my Windows machine. The Site Installation Profile and Compatibility Checks are successful, and I am able to get past the MySql Database screen. However, this is where the installation process stops (step 3). The Test Database and Save Configuration screen says my database connection was successful and the configuration was saved to ./site/config.php and that's it, but I know from my ProcessWire experience I should also see fields for setting up the admin login etc. on this screen. I can't go any further after this. I've redone this process multiple times. I am running XAMPP, if that helps. Any clue what could be stopping the installation process?
    • By rushy
      I've got off to a bad start trying to install PW on my local offline server, I must be doing something wrong as I have a bit of experience with Wordpress and it's running fine on my server, but I like the look of PW and hope to try it. Anyway I downloaded and unzipped the PW installation, the installation seemed to go right through ok, everything passed on the check lists. I selected the Default profile, and then when I try to click on Admin access or view the site I get "Not Found - The requested URL /processwire-master/about/ was not found on this server. Apache/2.4.10 (Ubuntu) Server at localhost Port 80"   Simply because the /about folder does not exist! It seems the profile has not been installed by the installation process despite everything else being ok? If I type localhost/processwire-master in the browser I get the Minimal Site Profile  "What is ProcessWire?" page but the links work "About" & "Site Map" don't work as the folders are not there. Bit confused as to why this is missing.
      Please put me out of my misery if it's something obvious I am doing / not doing!
      Many thanks - rushy
  • Create New...