Sign in to follow this  
Followers 0
modifiedcontent

Get the same 'set password' form on the front-end

2 posts in this topic

How do you get the same 'set password' form/input fields on the front-end as in the admin area?

I have a working front-end version, but the admin version has some nifty stuff around it. Should be easy to get the same on the front-end, right?

Share this post


Link to post
Share on other sites

The nifty code:

$base = wire('config')->urls;
$cssUrl = $base->InputfieldPassword."InputfieldPassword.css";
echo '<link rel="stylesheet" href="'.$cssUrl.'">';

$jsUrls = array();
$jsUrls[] = $base->InputfieldPassword."complexify/jquery.complexify.min.js";
$jsUrls[] = $base->InputfieldPassword."complexify/jquery.complexify.banlist.js";
$jsUrls[] = $base->JqueryCore."xregexp.min.js";
$jsUrls[] = $base->InputfieldPassword."InputfieldPassword.min.js";

foreach ($jsUrls as $jsUrl) {
	echo "<script src='$jsUrl'></script>";
}

 

2 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Slav
      Hey guys... Ok so I have a problem with a registration form password inputfield... The problem is that InputfieldPassword.js and InputfieldPassword.css are not loaded/fired. Or I dont even know exactly what is happening... Im pretty new to processwire and the website was not created by me so Im trying to figure out what has been done and how processwire works. Anyway this is how the form looks right now:

      ...and as you can see the styling is off (password validation check in particular)... this is what I see when page is loaded (without adding any input)... it looks like js and css files from wire/modules/Inputfield/InputfieldPassword are not firing... I dont know how it is supposed to work exactly so I dont even know where to start.
      Maybe someone has had similar problem and know an easy fix or can navigate me to what could cause this situation in PW.
      Oh by the way this problem occured when upgrading the PW version (current version 3.0.65)... everything else is ok... this is the only problem that has been found after upgrade...
      Appreciate all the help!
      Cheers!
    • By jen
      Yesterday we somehow lost access to all current admin, superuser/passwords to processwire.  We tried using the reset password form and nothing was sent.  We began noticing some of the menu buttons went missing as well as some photos.  Any suggestions how to resolve the login issue?
       
       
    • By modifiedcontent
      I have a simple front-end password update form like this:
      In the browser the label of the second field shows up as follows:
      WTH?!
      I can't figure out what is changing the label, what is inserting /processwire/ and reformatting the thing. Is this something in PW? A "helpful" thing that browsers do?
      Edit:
      The problem disappears if I simply rename the second field to 'Confirm Password'.
      So my problem is solved, but I'll leave this here in case this is some kind of bug.
    • By alan
      I just ran into Web Experience Toolkit (WET).
      About to go and look at WET more, just wondered if anyone had tried WET with ProcessWire?
    • By webhoes
      Hello,
      Is there a module of way to have the images that are added in the body (field) to popup when clicked on?
      I have made a fotogallery and implemented this as a function. But have no clue how to do this the other images.
      Sanne