Jump to content

Soma

Moderators
  • Content Count

    6,798
  • Joined

  • Last visited

  • Days Won

    158

Soma last won the day on November 3 2018

Soma had the most liked content!

Community Reputation

6,589 Excellent

4 Followers

About Soma

  • Rank
    Dreamer
  • Birthday 03/31/1975

Contact Methods

  • Website URL
    http://philipp.urlich.ch

Profile Information

  • Gender
    Male
  • Location
    SH, Switzerland

Recent Profile Visitors

43,167 profile views
  1. Hey, just btw - I added a pull request on your ModulesManager github page that would add support for the pagination that got added to the modules API.

     

    (You seem more active on here than github, so I figured I'd let you know lol)

  2. The dev2 I made to the master couple months ago. So the new commit is just a minor addition to the url parser. I think I had difficulties with making the dev2 to master and I couldn't delete the dev2 branch. 😢
  3. Soma

    Looking for a new Job

    I just wanted to mention. I found a new job as a front-end dev at https://backslash.ch. Since 2 months there already and enjoy it. We work with in-house CMS specially targeted to governments. So a lot less PW for me in the future, but I'll use it as my tool for private projects.
  4. Glad you found it yourself. What's also possible is to just add a page-{name} or page-{id} to the item template and use them to style.
  5. I have a config-dev.php for dev server or local setup. and the "root" stays the same just the domains are different.
  6. I don't have cats 😛 Yes that's true. I know the "redirect if domain name is found in url" would need even a much more sophisticated parsing method, but it gets too complicated for my brain. I think having random strings as root name would be a much easier solution.
  7. Yes the problem is most likely that both sites share the same names in it. abelt.test is in both setups and even in the root name. Just rename the root to something else more unique would do the trick. It's not something you would see anyway. "abelt.test" => array( // domain name is used to map to root page "root" => "abelt", // page name for the root page "http404" => 1031 ), "alexander-abelt.test" => array( // funktioniert nicht mit /en/ auf Home "root" => "alexander", "http404" => 1029 ),
  8. Ah reading againg. Ah reading again, I'm not 100% sure why this happens in your case. (but most likely what i said anyway :)) What is the setup config? And what Module version?
  9. I think this can happen if your multisite root page name has also the domain name in it. You should avoid that. Just rename it to something else My guess is that this comes from the fact you have domain.com and www.domain.com. You want to avoid that, cause the script isn't clever enough to know which is which. In any case you want to avoid having two domains setup for the same site. You should redirect your www to non www or the other way around.
  10. Then if $wire works for the hook $wire inside the funtion doesn't work, need to use wire(). And yes the lock file is most likely the problem cause of using $wire inside your function.
  11. $wire is not available in site/init.php .... You need to use wire().
  12. Have you debug mode on? I think $wire is not available in site/init.php.
  13. I think you looking for this https://processwire.com/api/ref/inputfield/get-errors/ ?
  14. Yeah good point. The way to do it is simple. If javascript is deferred, add the classes like uk-grid etc and not just the data attribute. https://getuikit.com/docs/grid#usage
  15. Yeah that's not anymore. There's a parser on page render now.
×
×
  • Create New...