Jump to content
modifiedcontent

Force ckeditor.js to load

Recommended Posts

Is there a way to force ckeditor.js to load? Maybe put something in the footer?

It seems to be hit or miss in my installation. Not sure why. It is causing problems with front-end editing and other things. I also got an ugly pop-up once that 'ckeditor.js failed to load'.

Share this post


Link to post
Share on other sites

Good day!

  1. I do not know what exactly is happening, just trying to move the topic forward.
  2. Please provide more details. I understood that you got a ckeditor.js failed to load message in your browser console on some non-admin url of your site when trying to open a front-end editing popup. Is that right? Please provide more details/context/screenshots to make it easier to answer.
  3. Seems to be PW unrelated problem. Did you check some ckeditor related answers? I know, it's close to "go google it", but that is how I would start.
  • Like 2

Share this post


Link to post
Share on other sites

Thanks for the response Ivan Gretsky

It could very well be unrelated to PW.

I don't necessarily get the 'ckeditor.js failed to load' pop-up when I try to use front-end editing. I think I get that every now and then when I click away from a page with any ckeditor; I have the impression ckeditor loads late/slow.

When I try to use front-end editing, by double-clicking on editable text, I sometimes get the toolbar, sometimes not. Usually I have to fiddle about with it a bit, click Cancel and try again, and then the toolbar finally shows up.

I think the front-end editing module inserts this:

<script src="/wire/modules/Jquery/JqueryUI/JqueryUI.js"></script>

But after a bunch of other javascript. Shouldn't jQueryUI come first?

I also see typeof jQuery.ui == 'undefined' just above the jqueryui.js insert. Does that mean it can't find it?

Is there a blunt way to force ckeditor to load, maybe by placing <script>ckeditor.replace('something')</script> in the footer?

 

Share this post


Link to post
Share on other sites

There was a suggestion here in the forum recently that front-end editing works best when you are using the same version of jQuery in your template that PW uses in the admin back-end. So that is something to try.

  • Like 3

Share this post


Link to post
Share on other sites

I'm seeing this error and the site doesn't use jQuery at all on the front-end. It does have caching enabled on some templates (the type of caching offered natively by ProcessWire, not ProCache). Do I have to conditionally load ckeditor's jQuery on the front-end when edit-access users log in?

Share this post


Link to post
Share on other sites

Hi all, first post here but in case anyone else is experiencing this issue, I'd suggest checking if you are trying to use plain old http: instead of shiny yummy https:

While taking my first test site out for its first spin in the wild I noticed this message, then immediately after visiting this post realized I hadn't yet enforced https on the site.
As soon as I used https instead, the popups disappeared, and as soon as I switched back to http there they were again.

Naturally can't say for sure what anyone else is experiencing, but it surely worked for me.
 

  • Like 2

Share this post


Link to post
Share on other sites

Same issue here!

Installation run on xampp.
I think shortly after i updated from 3.0.98 to 3.0.123 it started with these "failed to load ckeditor.js: Page Not Found" alert.

What i recognized than was that the ckeditor.js in fact isn't in the requested directory under wire/modules/Inputfield/InputfieldCKEditor/ckeditor-4.10.1
How could that be?
What do i have to do?
Am i the only one whis these kind of errormessage?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Guy Incognito
      Hi all,
      Having a strange problem with my CKeditor custom styles.
      Trying to add standard bootstrap classes to the image alignment options. But for some reason if I add multiple classes to the centred image option it disappears from the editor drop down. But with only one class it works.
      So this works:
      { name: 'Left Aligned Photo', element: 'img', attributes: { 'class': 'float-md-left img-fluid' } }, { name: 'Right Aligned Photo', element: 'img', attributes: { 'class': 'float-md-right img-fluid' } }, { name: 'Centered Photo', element: 'img', attributes: { 'class': 'img-fluid' } }, But this doesn't:
      { name: 'Left Aligned Photo', element: 'img', attributes: { 'class': 'float-md-left img-fluid' } }, { name: 'Right Aligned Photo', element: 'img', attributes: { 'class': 'float-md-right img-fluid' } }, { name: 'Centered Photo', element: 'img', attributes: { 'class': 'w-100 img-fluid' } }, Note the slight difference to the last line.
      I've tried escaping the hyphens in case it was that but doesn't help.
      Any ideas.... #puzzled!
×
×
  • Create New...