Jump to content
Orkun

CKeditor and fontawesome plugin problem

Recommended Posts

I tried to implement the fontawesome plugin with the help of this mini-tutorial. The problem is when go to the "Plugins" section and check the box for the "fontawesome" plugin, then I still get an white body field. What I am doing wrong?

post-3125-0-10964200-1447323262_thumb.pn

Share this post


Link to post
Share on other sites

Yeah you are right, i get this js error:

uncaught exception: [CKEDITOR.resourceManager.load] Resource name "widget" was not found at "http://blabla.ch/wire/modules/Inputfield/InputfieldCKEditor/ckeditor-4.4.6/plugins/widget/plugin.js?t=2015030801.143".

Share this post


Link to post
Share on other sites

I forgot all the depencie plugins which the fontawesome-plugin needs to work.

So i also installed these plugins:

 Widget

 Line Utilities

 Color Dialog

but with no effect. Then i realised that i dont edited the config-body.js.

So i write this lines of code in the config-body.js:

config.extraPlugins = 'fontawesome';
config.contentsCss = 'https://maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css';
config.allowedContent = true; 

And i also write "FontAwesome" in the toolbar section.

but i still get this error: 

post-3125-0-05091800-1447834931_thumb.pn

I don't know what I'm missing...

Share this post


Link to post
Share on other sites

Am resurrecting this topic because I noticed after adding the plugin 'CodeSnippet' it tries to read from the wire folder rather than the site modules, but if there's an update won't the folder be deleted ? 

http://okeowoaderemi.com/wire/modules/Inputfield/InputfieldCKEditor/ckeditor-4.5.5/plugins/widget/plugin.js?t=2015030801.156 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fruid
      I doubt nobody has seen this issue before…
      when I have an <h2> or <h3> or the likes in a CKEditor-body-field and I delete that header, the h-tag is applied to whatever comes next in line. I'm obviously talking about the WYSIWYG-view. Similar bugs occur when applying an h-tag, that tag sometimes encloses the next line as well. Could be that this happens when the next line is in the same "block"-element and not technically a new line but separated with a <br> but not always…
      When will a new version of CKEditor for PW be released or what's a competitive alternative at this point?
    • By Liam88
      Hello all,
      I'm having a moment with CKeditor and hoping someone will be able to assist.
      I want to change the structure of the table plugin to automatically add the following:
      Schema.org markup to signify it's a table. Aria-label and roles for each of the table elements. At the moment if I add them in manually, the plugin removes them. I'd like to have this as default.  Here is an example: Additional classes. The plugin has the option for a table ID, but where possible I'd rather use classes. I have searched far and wide on the ol Google but struggling on this. I'm not the most experienced and would appreciate any direction on this.
      It's mainly a case of where best to make said adjustments. 
      Thank you in advance!
      Liam
       
    • By Jennifer Stock
      Hi. Sometimes when I select text in a textarea field outfitted with CK Editor, it fails to register as a "Block Style" and therefore the custom styles I have specified for block-level elements are not displayed in the Styles drop-down menu. If I open the page in an incognito window and select the same elements, the Block Style styles appear as expected in the Styles menu.
      Is this a caching issue of some kind? I've played with turning on and off the HTML "quality assurance" options as well as putting my custom styles directly within the CKEditor folder in the /wire directory. Once the field stops registering the selection of block-level elements, it also seems to have simultaneously stripped the custom styles that had been successfully applied to these block-level elements previously.
      Not sure what to do next.
    • By prestoav
      Hi all and thanks for the great work on PW!

      One thing I find I have to do on any new site is add the Justify plugin to textarea fields as it is such a widely required feature for text headings in content.

      ANy chance this could be added to the core an automatically be installed on new textarea fields using CKEditor?

      Thank you!
    • By AndréPortuga
      Does anyone knows if there is a way of selecting a iframe inside a textfield(using ckEditor)? 
      I mean I have a Iframe with this code:
      <iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="315" scrolling="no" src="https://www.youtube.com/embed/PMaFJjZDrYM" width="100%"></iframe></p>
       
      but it's not getting responsive in iPhones.. So anyone know how can I select it via code for making it responsive?
       
      Thank you,
×
×
  • Create New...