Jump to content

gmclelland

Members
  • Content Count

    495
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by gmclelland

  1. All credit goes to Macrura, it is his module. Can you post the code you are using?
  2. Hi Peejay, What happens when you go to /processwire/module/ and click on the "clear compiled files" button? I just upgraded my local install and I'm not seeing this problem.
  3. Faster start up times, less RAM usage, etc.. It seems to be used a lot in the JavaScript community. In the PHP community, I mostly here of people using PhpStorm. It's been a long time since I've used NB, but I think NB maybe Java based?
  4. Here's what I use. Here is the contents of ~/.vscode/extensions I just like that VSCode is faster than an IDE and it has a ton of plugins. The outline feature is new to VSCode, but NetBeans has had it for a long time.
  5. Glad I could help someone! Another thing to keep in mind is your admin url. In most cases it is mydomain.com/processwire/, but it can also be customized to something else like mydomain.com/admin/. In that case you will also have to update your Cloudflare page rules.
  6. http://www.flamingruby.com/blog/mapping-processwire-page-render-process/
  7. Thanks netcarver! Coming from a Drupal background... If an issue has been fixed by the module maintainer, then he/she marks it with a status of "Fixed" see https://www.drupal.org/issue-queue/status#fixed. After two weeks the issue automatically changes to "Closed (Fixed)" see https://www.drupal.org/issue-queue/status#closed. Drupal's issue queues are different than Processwire's. On drupal.org, anybody can change an issue status at anytime. On github/processwire, only the issue creator or admins can the issue status. Although 200 open issues seems like a big number, check out https://www.drupal.org/project/drupal 🤩 Although with Wordpress it's hard to tell what the number is https://core.trac.wordpress.org/tickets/latest
  8. Maybe some kind of Bot can automate the closing of issues that have been marked as "Resolution: fixed (close when ready)" after 2 weeks of applying the label? That would at least clean up those issues.
  9. I'm looking forward to the 2FA updates. I'm hearing of more and more companies forcing 2FA with their email systems(GSuite or Office365). We've had these discussions and will probably do this at our company as well. Once people start getting used to using it with their email and banks, they will start to expect it with their websites as well. I agree with Ryan, I think it will look good if Processwire already has this security built in. It builds trust with larger organizations. As a website administrator, I currently have to set up a secure password for each of my site editors so they don't get hacked. I can't rely on them doing it. I also have to disable them from reseting their password to something easier to remember. With 2FA, I don't care what they set their password to. It would be nice if we could somehow require/force 2FA for specific roles like Site Editors. I'm not sure if this is a different technology then 2FA, but when using G-Suite, you also have the option to use the Google Prompt. https://support.google.com/accounts/answer/7026266 This makes it much easier to sign into accounts. I wonder if that is just a Google thing, or if that is something that Processwire can utilize as well? They also offer several different ways to authenticate https://support.google.com/a/answer/175197?hl=en including Yubi Keys, Google Authenticator App, Google Prompt, SMS text message codes, and backup codes.
  10. vscode now includes an outline feature, but to get it to work with php files you will need to install https://marketplace.visualstudio.com/items?itemName=linyang95.php-symbols
  11. Thanks Macrura. I just tested and it looks like you can do this: // in site-settings.php // note the toolbar line and inlineMode line [ 'name' => 'ckeditor_test', 'label' => 'CK Editor Test', 'type' => 'InputfieldCKEditor', 'width' => '100', 'description' => 'Some Formatted Test', 'collapsed' => 0, 'value' => '', 'toolbar' => "Bold, Italic", 'inlineMode' => 1, ], Doing that will only show the Bold and Italic buttons in the CKeditor toolbar. It will also use inline mode. I'm not sure about the other stuff yet. I found those settings in wire/modules/Inputfield/InputfieldCKEditor/InputfieldCKEditor.module Hope that helps someone.
  12. When you use a CKeditor field in Settings Factory. Is there anyway to specify text formatters or markup options like "Link abstraction"? I also noticed an error when I clicked the Ckeditor image button on a CKeditor field on my Settings Factory page. Is there also a way to simplify the CKeditor's buttons?
  13. Thanks Adrian, I'm currently using MarkupSEO. I haven't tried your fork yet, but probably will switch at some point since MarkupSEO doesn't seem to be maintained anymore. Although it may be possible that Settings Factory can do the job as well?
  14. Hi @Macrura, I was just testing out this module and it seems to work great! Thank you for making this module. Is there any way to access control individual settings factory pages? I see there is an "settings-factory" permission included with the module. I don't know if it is feasible, but maybe a permission could somehow be created for each settings factory page? For example, you might want a client to be to make changes to a "Theme settings" page, but you don't want them to mess with the "API settings" page. Also, I'm curious if and how you use this module for SEO? or do you use something like the MarkupSEO module? Would you create a settings page for each type of template to override the general seo settings page as needed?
  15. Can you describe what is not working with Batch Child Editor or PageTable? ie the last 10%?
  16. Hi @Matze This request sounds similar to You might want to check there. It looks like Robin has posted a possible solution.
  17. You can also use http://modules.processwire.com/modules/module-settings-import-export/. Works great for me.
  18. Here you go https://github.com/processwire/processwire/commit/c7dfb37a7ece9d1a2e0369a92263e7c18663502a Looks like it was fixed in 3.0.100
  19. I think this was a bug in a past version of Processwire that has been fixed. What version are you running?
  20. Strange... I tried making the same changes in production and on another site, but that didn't fix the TemplateEngingTwig module's config page.
  21. Many thanks Robin! I was able to add a php comment in the TemplateEngineTwig.module which forced a recompile. Now all the text on that module's config page appears correctly. However, I tried the same with FormBuilder module but couldn't get the text to correct on the modules page.
  22. For some reason on two of my sites, the module pages at mysite.com/processwire/module/ look like they are getting compiled. Also on another module config page "TemplateEngineTwig", I get the following: Does anyone know of anything I can check to prevent this from happening? I have tried clearing the compiled files button on the modules page and I have manually deleted the contents of the site/assets/cache/FileCompiler/ folder. I'm running the latest dev version of Processwire 3.0.106, but I have noticed this with older versions as well. No problems with the frontend of the website.
  23. Happens to me as well with LastPass, not only in Processwire but with Drupal.
×
×
  • Create New...