Jump to content

'Maximum nesting level reached' at each edit in backend


Recommended Posts


Since a few days I get a 'Maximum nesting level reached (100)' at each page I click to edit in de backend. After a refresh F5 it loads.

It talks about line 114 of Data.php and sometimes 291. I looked up 114 and that part is in the getter.

It happens not always, but often, and on all kinda templates... Funny thing is that after I F5ed the page, I can edit it directly again after it. A bit strange I think. 

Any clues where I can start searching for the problem? I cannot imagine it is a bug in PW because then others had major problems so it must have to do with a module I installed or whatsoever. I didn't build one myself and they're all from the repository, no manual additions.

Link to comment
Share on other sites

Thanks for the quick reply!

So...this is one of these rare occasions (I never met them in my 10+ years experience) that a nestinglevel > 100 is really needed? Wow...

I'll put the level up in the ini file..

Have I missed this somewhere in the docs/prerequisites? Otherwise should be noted somewhere. A search at google and/or forum didn't gave me any clues.

By the way: it doesn't explain to me why the refresh make it 'work' :) So what happens behind the scenes that the second load of that page doesn't need a nesting level > 100?

Link to comment
Share on other sites


It doesn't work. I see you wrote input nesting level. And this isn't about input nesting level I guess but about recursion. So... Input nesting won't work/apply here I think.

Any other clues?

Link to comment
Share on other sites

You was just a little bit faster than me, but I had to restart apache to see if this was the case.. ;)

And yes I use xdebug. I found this entry earlier on, searched my php.ini for 'xdebug' (no results) but forgot to look into conf.d/ directory..... stupid!

So there it was and now solved indeed.

So just for others who search the forum it might come in handy :)

Thanks y'all :)

Solution is to add xdebug.max_nesting_level=200 to your php.ini or xdebug.ini (after the xdebug.so is called of course)

Or disable xdebug at all.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...