Jump to content

Weekly update – 3 June 2022


Recommended Posts

The ProcessPageList module now has a configuration setting where you can select pages that should not be shown in the page list. For example, maybe once you've set up your 404 page, you don't really need it to display there anymore, except maybe in debug mode. Or maybe you don't ever need the "Admin" page to display in the page list. This new feature lets you do that, and for any page that you decide.

Screen Shot 2022-06-03 at 4.14.58 PM.png

Next, a "Usage" fields has been added to the "Basics" tab in the Field editor, just like the one in the Template editor (requested feature #445). This shows you what fields are using the template. It's essentially the same information that you'll find in the "Actions > Add or remove from templates" feature, but easier to find, especially for people newer to PW. That's all for this week, I hope you have a great weekend!

Screen Shot 2022-06-03 at 4.14.27 PM.png

 

  • Like 22
  • Thanks 5
Link to comment
Share on other sites

15 hours ago, ryan said:

The ProcessPageList module now has a configuration setting where you can select pages that should not be shown in the page list.

Very nice addition, thanks Ryan! 🙂

This is actually one of the features of a general purpose utility module we install on all our client sites, so will definitely be using this option in the future.

  • Like 5
Link to comment
Share on other sites

On 6/3/2022 at 10:17 PM, ryan said:

The ProcessPageList module now has a configuration setting where you can select pages that should not be shown in the page list.

I'm evaluating this handy addition, but it looks like it's not working as intended. I hid the page, and I left all checkboxes unchecked. As expected, the hidden page is not shown in the page list. Then I checked the "System in debug mode" checkbox and expected to see the hidden page again, as the site is in debug mode. But it's not the case; the hidden page is not shown in the page list. Am I doing something wrong?

Link to comment
Share on other sites

On 6/5/2022 at 6:11 PM, matjazp said:

I'm evaluating this handy addition, but it looks like it's not working as intended. I hid the page, and I left all checkboxes unchecked. As expected, the hidden page is not shown in the page list. Then I checked the "System in debug mode" checkbox and expected to see the hidden page again, as the site is in debug mode. But it's not the case; the hidden page is not shown in the page list. Am I doing something wrong?

Same here.

1. When System in debug mode is checked with $config->debug = true, the hidden pages do not show up in the page list. Switching to $config->debug = false the hidden pages are shown in page list.
2. When Current user is superuser is checked being logged in as a superuser, the hidden pages do not show up in the page list.

Except i misunderstand the feature, i guess the except condition just has to be swapped/needs a little adjustment.

Apart from that, thank you @ryan. This really is a very helpful new setting!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...