SIERRA

To display the web site in English and Chinese

Recommended Posts

I want to display the web site in English and Chinese. I have the ‘English’ version of the site. After following attached steps the both versions are displayed in English only. Could you please suggest on this. Thanks.

pw-reference-09052018.docx

Share this post


Link to post
Share on other sites

Moderator Note:

Please don't double post

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry. By mistake this happened. Actually I thought to post this in 'Multiti language Support forum'. 

Edited by SIERRA

Share this post


Link to post
Share on other sites
5 hours ago, SIERRA said:

Actually I thought to post this in 'Multiti language Support forum'. 

I've moved it for you.

  • Like 1

Share this post


Link to post
Share on other sites

How do the URLs look? Are there /en/ and /cn/ in them? Is the page available in all languages under settings? 

Share this post


Link to post
Share on other sites

Hi,

Thanks for your reply

The field that you referred inside 'Setting' was empty. Then I updated with the value 'cn' as referred in attached screen shot. Now in view->New window/Tab->Chinese this is displaying the Chinese version that I created. And in view->New window/Tab-> English this is displaying the English version.

Actually I would like to have the front of the site alone in both 'English' and 'Chinese' version. I have attached the steps what I am doing in my first post (pw-reference-09052018.docx). Could you please confirm what I am doing is the correct way. Thanks

ref-24042018.docx

Share this post


Link to post
Share on other sites
44 minutes ago, SIERRA said:

the front of the site alone in both 'English' and 'Chinese' version

So you want the homepage to be displayed in both languages at the same time?
Please refer to this article about multi-language fields. There are lot of examples that will guide you through the handling of multi-language fields/sites/setups.

https://processwire.com/api/multi-language-support/multi-language-fields/

44 minutes ago, SIERRA said:

Could you please confirm what I am doing is the correct way.

As far as I understand your goal you want to achieve and the settings I see it looks pretty well so far.

Share this post


Link to post
Share on other sites

So you want the homepage to be displayed in both languages at the same time? - Yes I would like to have all pages of the website (the front end of the website alone not admin panel) in both 'English' and 'Chinese' with a language switcher provision. 

 

Share this post


Link to post
Share on other sites

So not at the same time. The user has to decide/switch to its favourite language.

To get this done please read the article I linked above. You may although want to create a new ProcessWire instance with the Multi-Language Profile. In that profile you will find almost everything you want and need.

This will help you to understand how ProcessWire handles everything.

Share this post


Link to post
Share on other sites

So not at the same time. The user has to decide/switch to its favourite language.

-- Yes

To get this done please read the article I linked above. You may although want to create a new ProcessWire instance with the Multi-Language Profile. In that profile you will find almost everything you want and need.

-- Ok, will check on this. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.