Jump to content
suntrop

phpMyAdmin export -> import errors

Recommended Posts

Hi all

I have big troubles with my DB backups and phpMyAdmin. I can't manage to import a backup.

The phpMyAdmin export settings are left to the defaults. The error message I get:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INSERT INTO `caches` (`name`, `data`, `expires`) VALUES
('ModulesUninstalled.in' at line 11

When I delete the complete 'cache' section there are almost for all tables the same errors. (part of the dump attached)

I had this problem before and back then (couple months ago) I think I copied almost every table individually. I thought it was specific to that DB. But I can't do a dump/import of any of my PW installations.

MySQL: 5.6.27
PHP version: 7.0.11
phpMyAdmin: 4.5.5.1

Anybody knows that problem? Or what to do?

phpMyAdmin SQL Dump.sql

Share this post


Link to post
Share on other sites
11 minutes ago, suntrop said:

Anybody knows that problem? Or what to do?

Just for informations - on my test installation, your dump is imported successfully.

  • Apache/2.4.23 (Win64) PHP/5.6.25
  • libmysql - mysqlnd 5.0.11-dev - 20120503
  • Extension PHP : mysqliDocumentation curlDocumentation mbstringDocumentation
  • Version PHP : 5.6.25
  • Version MySQL : 5.7.14
  • Version PHPMyAdmin :  4.6.4
  • Like 1

Share this post


Link to post
Share on other sites

:-) That's a quick reply and help. Many thanks!

When I import the complete dump it stops at the first error. It seems the problem is caused by the import, not export. I'll ask my provider, perhaps they must install an update.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By jds43
      Hello,
      Does anyone have experience with migrating content from Django to Processwire? Or are there any suggestions for achieving this?
    • By flydev
      There you can download the module : https://modules.processwire.com/modules/duplicator/
       
       
      ---
      Introduction
      I was not aware of this module/topic and spend some time developing a module to backup, clone and move sites to a local folder or even GoogleDrive and Dropbox.
      The idea begun when I read about this Wordpress's plugin. I was planning to add features like s/FTP, Amazon Cloud, deployment installer and others great features from Wordpress Duplicator and release it for free to the community.
      Now that I see this @rot's module , I am wondering if it would be benefit to the community to have a second solution and so, if I should finish it.. ?
      ---
      Features / Wishlist :
      Save package to local folder :  implemented Save package to Amazon AWS : implemented Save package to Dropbox :  implemented Save package to GoogleDrive :  implemented Save package to FTP/FTPS :  implemented Manual backup with a standalone button :  implemented Backup from scheduled cron job :  implemented Exclude by file extension / filename / directory :  implemented File naming convention (Y-m-d_H-i-s-description.ext)   implemented Protect access to the module screen by role/user   implemented Installer / deployment functionality   implemented ---
      2017-02-07: Starting the CLOSED BETA TESTING.
      2017-11-28: Module release - version 0.0.44 at https://github.com/flydev-fr/Duplicator
       
       
      screenshots:


       
    • By jaro
      This module (github) does with site/assets/files what Ryan's DatabaseBackups module does with the database:
      Backup site/assets Download ZIP archive Upload ZIP archive Restore site/assets Motivation: This module can be the missing part for projects with content backup responsibility on the client's side: The client will be able to download DB and assets/files snapshots through the backend without filesystem access, thus backing up all content themselves.
      Release state alpha – do not use in production environments.
      Credits for the nice UI go to @ryan – I reused most of it and some other code from the DatabaseBackups module.
    • By Brawlz
      Hi,
      I hope this is the correct section for my problem.
      All I need is a connection to an external Database and a query gettings some data. I do this in a processwire Page-Template. I am honestly not sure if it is a problem with processwire or my code:
      $host = ‚XXXXX’; $user = ‚XXXXX‘; $pass = ‚XXXXX‘; $db = ‚XXXXX‘; $port = ‚3306‘; $mydb = new Database($host, $user, $pass, $db , $port);  $result = $mydb->query("SELECT * FROM char“);  while($row = $result->fetch_assoc()) {  print_r($row);  }  
      Produces the following error:
      Error: Exception: DB connect error 2002 - Connection timed out (in /customers/9/4/e/XXXX.de/httpd.www/wire/core/Database.php line 79)
       
      I also tried connecting without the $port variable but got the same error.
    • By Mats
      Hi!
      On a clients multilanguage site, upgrading to latest PW version, started to generate the following exceptions:
      SQLSTATE[42S22]: Column not found: 1054 Unknown column 'pages.has_parent' in 'where clause' (in /wire/core/WireDatabasePDO.php line 480) SQLSTATE[42S22]: Column not found: 1054 Unknown column 'pages.has_parent' in 'where clause' (in /wire/core/WireDatabasePDO.php line 480) And this message by the newly created page:
      Name already in use! A sibling page (id=15877) is already using name "my-page-name" for language: English
      Searching the forums the only thing i've found seems related to multi language: 
       
       
×
×
  • Create New...