Jump to content

Search the Community

Showing results for tags 'loginregister'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to ProcessWire
    • News & Announcements
    • Showcase
    • Wishlist & Roadmap
  • Community Support
    • Getting Started
    • Tutorials
    • FAQs
    • General Support
    • API & Templates
    • Modules/Plugins
    • Themes and Profiles
    • Multi-Language Support
    • Security
    • Jobs
  • Off Topic
    • Pub
    • Dev Talk

Product Groups

  • Form Builder
  • ProFields
  • ProCache
  • ProMailer
  • Login Register Pro
  • ProDrafts
  • ListerPro
  • ProDevTools
  • Likes
  • Custom Development

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 10 results

  1. Hello, I'm new here, but I've been using PW for some time now, so far so good, but I have a problem with LoginRegister module. Some context : I have a website currently on Mamp's localhost : http://localhost:8888/sans-soleil/ I have a profile.php page and a connection.php page. When user is not logged in, he is redirected from profile.php to connection.php where Login/Register is used. The aimed setup : Not logged user are redirected to connection.php, after connection, they are redirected to profile.php The profile page contains everything to manage account The connection page is only there for registration and connection, not for account managing The Problem : The forms for login and the links to reset password & register are outputed, but when I try to login with a test user and click on the login btn or the register link I'm redirected to http://localhost:8888/sans-soleil/site/templates/?register=1, wich give me a 403, where I suppose I should have something like http://localhost:8888/sans-soleil/connection/?register=1. For the forgot password, the first link works, but after, when I submit the mail, I also get the 403. I tried the basic code provided in the documentation of the module, the more advanced version where you can give your own redirection target, and tried an other module (FrontEndUser). With everything I get the same 403 with the same url each time. I've bying searching the forum for some infos but gave me nothing that worked for me so far. I guess it as something to do with my install and not the module itself as two module have the same error, but I can't figure out what causes my problem. PS : The pro version of Login register will be better for my needs in the future, but I want to try out the regular, and make it work, obviously, before upgrading.
  2. Hi, I installed LoginRegister module. This is the instructions: But in Setup > Templates there isn't any templates > user. I don't know how to configure this module... Has anyone already tried it?
  3. Dear processwire community, i have a problem in loginRegister module, i could not add custom field in login and register page. i read from plugin documentation. they are saying. " By default, the email and password fields are required for both forms. You may want to add more fields. To do this, you’ll need to add fields to your “user” template. You can add fields to your user template in the admin by going to “Setup > Templates > Show system templates > user”. but i could not find similar scenario like “Setup > Templates > Show system templates > user” i can see just "Setup > Templates" not seeing "Show system templates > user" in my admin panel. Please help me in this case that how i can add custom field in these two page. Regards AbdulQayyum
  4. I don't seem to be able to add a role to a user when they register. I have a function to return the role as text based on the option that was chosen on the register form. I have checked that this function is returning the correct value by echoing it to the page. If I pass that text into the addRole function (as $myRole) it doesn't work. If I hard code the exact same text into addRole it does work. Do I need to change my getRole function to return the text in a different format? function getRole($role) { // return name of role based on id from register_member_role switch ($role) { case 1: return "type1"; break; case 2: return "type2"; break; case 3: return "type3"; break; default: return "type1"; } } $loginRegister = $modules->get('LoginRegister'); $myRole = getRole($input->post('register_member_role')); wire()->addHookBefore('LoginRegister::createdUser', function($event) { $u = $event->arguments[0]; $u->addRole($myRole); $u->save(); }); echo $loginRegister->execute();
  5. Hy everyone, i am using loginRegister module for front-end user login. In this module user can login with Email/username, i am showing with Email. done but not showing Email in Forgotton Password section. there still showing with username. i want to show Forgotton Password with Email instead username. and should reset with email. please help me in this section, how i can set it with Email. Thanks AbdulQayyum.
  6. Markup-Google-Recaptcha is not working with LoginRegister module in Forgotton Password Form. Here is my code wire-> modules -> process -> ProcessForgotPassword.php protected function step1_renderForm() { $form = $this->modules->get("InputfieldForm"); $form->attr('action', './?forgot=1'); $form->attr('method', 'post'); $field = $this->modules->get("InputfieldText"); $field->attr('id+name', 'username'); $field->attr('class', 'redesign-field forgotPassFeild'); $field->setAttribute('placeholder', 'Username'); $field->required = true; $field->label = $this->_("Forgotton Password"); $field->description = $this->_("If you cannot remember your password to access the affiliates portal. simply provide your username in the box below and we'll send you a reset link via email."); $form->add($field); // Calling MarkupGoogleRecaptcha Module. $captcha = $modules->get("MarkupGoogleRecaptcha"); // rendering form with recaptcha $captcha->render($form); $submit = $this->modules->get("InputfieldSubmit"); $submit->attr('id+name', 'submit_forgot'); $form->add($submit); $this->session->userResetStep = 1; // rendering form $out .= $form->render(); // getting captcha script $out .= $captcha->getScript(); return $out; } I am following this one example. please suggest me how i can show MarkupGoogleRecaptcha in forgotton password. Getting log error Thanks, Abdul Qayyum
  7. hello processwire community, i am using LoginRegister module for front-end user registration. i am facing an issue verification email not receiving while WireMailSmtp is working perfectly and user receives message "Thank you, a confirmation code has been emailed to you. When you receive the email, click the link it contains, or paste the confirmation code below." received this message in front-end but does not receive any email relevant it. please help me in this case how i can solve it. Please check screen shots for SMTP test and message which receives user. Thanks AbdulQayyum, First screenshot SMTP test message, second when user receives message after clicking register button.
  8. Hi all... after looking into the I've recognized some errors caused by this module. Error: Exception: Login not attempted due to overflow. Please wait at least 5 seconds before attempting another login. (in /***/public_html/wire/modules/Session/SessionLoginThrottle/SessionLoginThrottle.module line 150) Error: Exception: Login not attempted due to overflow. Please wait at least 20 seconds before attempting another login. (in /***/public_html/wire/modules/Session/SessionLoginThrottle/SessionLoginThrottle.module line 150) Error: Exception: This request was aborted because it appears to be forged. (in /***/public_html/wire/core/SessionCSRF.php line 191) Is there a way to output these errors in a user friendly way, without throwing an "Internal Server Error" on the Frontpage (see attached video)? Many greets! IMG_3955.MOV
  9. Update: The render behavior of the profile is correct. My mistake was to use TextLanguage in the fields when i just need the user to see labels according of his language (that can be achieved with the text field type). Hi, I'm using LoginRegister to allow users to edit their users profiles in the front-end, and some of the user fields are type TextLanguage (to allow multiple languages). The problem is that when I render the Profile Edit, the inputfields shows in all the installed languages. That doesn't happen when I render the login or register forms. How can i prevent that the TextLanguage inputfields render in both languages? My code <?php $user->language = $languages->get("default"); $input->get->profile = 1; $profileForm = $modules->get('LoginRegister')->set('renderStyles', false)->execute(); ?> and later... <?= $profileForm ?> The output for an multilanguage inputfield: <div class="InputfieldContent "> <div class="LanguageSupport" id="langTab_Inputfield_profile_firstname" data-language="1029"> <label for="Inputfield_profile_firstname" class="LanguageSupportLabel detail">English</label> <input id="Inputfield_profile_firstname" class="InputfieldMaxWidth" name="profile_firstname" type="text" maxlength="2048"> </div> <div class="LanguageSupport" id="langTab_Inputfield_profile_firstname__1031" data-language="1031"> <label for="Inputfield_profile_firstname__1031" class="LanguageSupportLabel detail">Spanish</label> <input id="Inputfield_profile_firstname__1031" class="InputfieldMaxWidth" name="profile_firstname__1031" type="text" maxlength="2048"> </div> </div>
  10. Hello everyone, I'm rather new in developing with ProcessWire and loving it every day more. I found that new module "LoginRegister", which is amazing. However, I would be happy about one feature. I wasn't able to solve this myself. Is there a possibility to achieve, that a user is redirected to a site (which is denied for guest users) he actually wants to view? Let's say I have a restricted sub-page called "test", which redirects to LoginRegister login form if a user is not logged-in. Right now, the redirection after successful log in is static and points to a pre defined site (let's say: "welcome"). So when a user tries to call mypage.com/test and logs in successful he gets to mypage.com/welcome instead of mypage.com/test.. Hope you have some hints for me on how to achieve this.
×
×
  • Create New...