Jump to content

caffeineben

Members
  • Posts

    10
  • Joined

  • Last visited

Recent Profile Visitors

449 profile views

caffeineben's Achievements

Jr. Member

Jr. Member (3/6)

4

Reputation

  1. I just answered my own question on the above. I am sure there are better ways to do things but all I had to do is add a Z-index number to the CSS that moved the buttons above the footer. Also could have adjusted the positioning of the buttons here (which I did not do), changing the bottom to say 80px for example. Nice and easy. .pw-edit-buttons.pw-edit-buttons-location-auto { bottom: 0; left: 0; z-index: 1100; }
  2. Hello! I am playing with an idea and want to be able to utilize the FrontPageEdit module so I can make quick content edits. Everything is working fine. I am just using the A method. It is working. The correct fields are editable. The problem I am having is that I have a fixed navbar and a fixed footer because this is meant to look like an app. The Save and Cancel button appears but it appears behind the footer. Is there a simple way to call the Save/Cancel buttons so that I can control where they appear? Maybe even have control over the Z-index so at least the buttons come in front of the footer? Thank you to anyone that can help. This is not urgent. Just a personal project and figure there must be a simple way to do this.
  3. My hosting company (Dreamhost) upgraded their VPS accounts from Ubuntu 14 (also known as Trusty) to Debian 10 (aka Buster). Since they have done that, I can no longer upload photos through the PW admin. Most of my templates use the Images field and when I go to upload an image - no matter the size, I just see spinning over the image icon. I checked my console and get the following errors: [Error] Failed to load resource: the server responded with a status of 418 () (edit, line 0) [Error] SyntaxError: JSON Parse error: Unrecognized token '<' parse (JqueryCore.js:2:13595) parseJSON (JqueryCore.js:2:13595) (anonymous function) (InputfieldImage.min.js:1:35271) I have multiple sites hosted by Dreamhost and this is now happening on all sites. I am using Processwire 3.0.165. PHP 7.4. I don't know what other info is helpful so please let me know if you have any ideas. I have filed a ticket and suspect this is a result of the upgrade as all these sites worked previously. And the sites still work - just can't upload and save to the images field.
  4. Had the same error when moving the site from one server to a new one. Checked and for some reason the ProcessPageView.module was skipped in the upload so solved by uploading that file. Glad this was here!!
  5. This issue was happening to me all of a sudden. Happened just after uploading a 3MB photo via the admin. Tried messing with permissions and no help. Tried deleting the photo via FTP and suddenly was able to login again. Uploaded another photo and got the "appears to be forged" warning. Then it occurred to me that possibly I had maxed out my allocated storage. This was the case. I increased my space on my hosting account and everything is good again.
×
×
  • Create New...