Jump to content

mauricius

Members
  • Posts

    23
  • Joined

  • Last visited

  • Days Won

    2

mauricius last won the day on September 8 2015

mauricius had the most liked content!

About mauricius

  • Birthday 05/09/1986

Contact Methods

  • Website URL
    mauricius.dev

Profile Information

  • Gender
    Male
  • Location
    Italy

Recent Profile Visitors

1,709 profile views

mauricius's Achievements

Jr. Member

Jr. Member (3/6)

56

Reputation

  1. Ehy @teppo I'm really digging Wireframe and I really think that it's a brilliant work. Thank you also for mentioning my old TemplateEngineBlade module in the list of alternatives. I'm currently restyling one of my websites and I decided to use Wireframe for the purpose. Everything is going great so far! I also decided to create a renderer module that uses the Blade template engine, because I don't like Twig that much. Check it out https://github.com/mauricius/WireframeRendererBlade
  2. Nope, I got the same error. I'm trying to debug it right now. EDIT: I was able to figure it out. Apparently the saveConfig function is called from the following line in _sanitize_data, but the module is not present in the moduleIDs array inside Modules.php. if(json_encode($data) != json_encode($_data)) wire('modules')->saveConfig(self::clsname, $data); I temporarily removed this line from the module, then I installed it before putting it back. Now everything works correctly 👍
  3. Ehy @matjazp, I tried to install version 4.0.1 on a PW 3.0.148 and I got this error "Unable to find ID for module \AllInOneMinify". Do you have any idea what that means? Version 3.2.9 however works great! Thanks
  4. Unfortunately, as I said before, Jssor developers heavily changed the way to define animations in the markup, making the module almost useless. You can try with a previous version of the Jssor plugin. Sadly I don't have much time to work on a new version of the module and probably I would need to change the underlying plugin to something else.
  5. Thanks for your response. However the request gets redirected before even touching PW functions. Writing a die() instruction at the top of the ___processInput() function in InputfieldFile.module doesn't change a bit. I'm thinking that this problem is related somehow to the hosting provider and some obscure Apache directive. Non-ajax uploads work correctly.
  6. I have probably the same issue with an old PW 2.6 install on a shared hosting with PHP 5.5.32. The ajax upload completes with 100%, but I get Uncaught SyntaxError: Unexpected token < in the console. The problem is that the ajax request to admin/page/edit/?id=1067 ends with a 302 response code, therefore jQuery tries to parse the response of the root page, which obviously starts with <html>. I have the directive always_populate_raw_post_data set to Off, so I think that the problem is not related to https://github.com/ryancramerdesign/ProcessWire/issues/1174 and The directive upload_tmp_dir is set to /tmp/ with 755 permissions. No sign of errors in PW logs and messages. Anyone has clues?
  7. I think that 19 is the latest working version. Yesterday evening I tried with the new 20 version, but I noticed immediately that it was not working. In fact they removed the possibility to define caption animations directly in the markup (http://www.jssor.com/development/slider-with-caption-jquery.html) in favor of the new Jssor Slider Maker available on the website. At this point, with this new version, the module it's nearly useless. I could try to change how the module internally works, to reflect the new Jssor features, but I'm doubting that it will turn out as complete as the new Jssor Slider Maker.
  8. Yeah something might have changed in the last few months. As soon as I have a little bit of time I'm going to look into these recent issues with a new fresh PW 3 installation.
  9. You need to check if the Javascript code kicks in. Make sure to follow the instructions of the MarkupSlider module or make sure that you have all the JSSOR dependencies on your page.
  10. Unfortunately I haven't had the opportunity to play with PW 3 yet, so I don't know what's wrong here. Probably something is different in the way that PW fetches images. I'm quite busy by now, but I'll look into it as soon as possible, hopefully next week.
  11. Just check the Responsive/Full Width checkbox! However you still have to define the size of the slider in pixels. Ideally you should set the values based on the largest uploaded image.
  12. You have to make sure that the Jssor library is available in the folder /site/modules/ProcessSlider/jssor. Otherwise you can download it from the official website at http://jssor.com/download.html. The module uses only the files in the "js" and "img" folders, specifically the files "jssor.slider.debug.js" in development mode and "jssor.slider.min.js" in production.
  13. Thank you! Unfortunately this module doesn't use any ProcessWire fields (except for the images). It works only with HTML, therefore at this point building multilanguage sliders is nearly impossible. The only way you could build multilanguage sliders would be creating each time a new slider. However if you have access to your database you can easily use a little trick to speed up the process: add a new row in the slider table for each one of your languages. For example if you have German and English you can add two new rows (let's call them slider_de and slider_en) and you can copy and paste the code column to have the same settings as the original slider. Now you can translate your text in the administration section. As the last step you have to change the type of the Slider field from Slider to TextLanguage. In this way you can reference a different slider for each language, but remember that you have to type in the ID of the slider and not the name.
  14. I really don't know how to help you. Just make sure that $page->get('slider') returns a valid slider ID otherwise it will throw that error because you're trying to render NULL.
×
×
  • Create New...