Jump to content
benbyf

files get added with 600 permissions and dont know why

Recommended Posts

not sure why but PW adds any uploads as permissions 600 (e.g. images wont load after upload unless i go in with the same server user and change permissions to 755 or similar). This ever happened to any one else?

Share this post


Link to post
Share on other sites

Strange, it look like a sftp/ftp issue, how do you upload your files ? via FTP ? If yes yes, which server type ?

Forgive, I misread the post..

What's the server type ? Dedicated ? shared host ? ProcessWire and PHP version ?

Share this post


Link to post
Share on other sites

ubuntu 14, digital ocean droplet, serverpilot.com runs the sysadmin setup with nginx, PW 3.0.98. PHP 7.2

Share this post


Link to post
Share on other sites

Ok, to give you the idea, I suspect that you have an issue with suPHP in your setup overriding permission or with FastCGI (through the use of suEXEC).

You should take a brief look at this direction and report things here. For example, if you confirm that suPHP is present, them check the value of umask in /etc/suphp.conf

 

ps: check your PM

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for your help @flydev. The solution that worked you suggested was as follows:

  1. cd /srv/users/serverpilot/apps/chinaandco/public/
  2. chmod 755 site/assets
  3. find site/assets -type d -exec chmod 755 {} \;
  4. find site/assets/ -type f -exec chmod 644 {} \;

This sorted it out. Though still not sure how i got into that permissions mess to start with 🙂

  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, benbyf said:

Though still not sure how i got into that permissions mess to start with

We will know that on your next upload. 

On the next upload, try to remember the mode (FTP or SFTP (over ssh) ?) and compare permissions on localhost and on the hosting server to see if they are the same, if not, then I put a bet on suPHP or SSHd umask configuration.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By snck
      Hello,
      for a project I have pages with different “content areas“ that can be edited only by specific user roles. In the past I setup a fieldset (tab) containing all the fields that should be available to only one specific group of users and set the fields' view and edit permissions (in the Access tab) accordingly. The result was as expected: Users assigned to the specific role could see the tab, click on it, edit content, users without the role could not see the tab. After updating this installation to 3.0.148 yesterday I wanted to setup another tab following the same principle, but I have no "Access" tab for the fieldset to limit access to the specific role. I even tried cloning an existing (and still working) fieldset. The existing fieldset has some template overrides (screenshot attached) that lead to the desired behaviour, but I am not able to reproduce these settings because there is not "Access" tab for my fieldset in template context either.
      Is this a bug in 3.0.148? Has the fieldset fieldtype changed? Am I missing anything here?
      I am glad to hear from you guys.
      Cheers,
      Flo

    • By fruid
      Hi,
      this is the first time I'm using ProcessWire.
      I thought I get how fields, template and pages work, but when I create a template in the CMS, it doesn't generate any file in site/templates/
      Then I thought I might need to create a blank file myself manually on the FTP (which already seems odd to me).
      Once I did that, I tried to add fields to the template but again, doesn't write to the php file.
      When I create a new page and apply said template to it, the page stay blank.
      AFAIK the mod_rewrite of the apache is on and I went for the worst case scenario described here https://processwire.com/docs/security/file-permissions/ and set all file-permissions for future files to 0666 and folders to 0777 in the config.php
      What am I not getting and what am I doing wrong?
      Help is appreciated, stay save everybody,
      Fred
    • By MarkE
      Having just wasted the best part of a day debugging an access issue because I hadn't realised that page-edit-created negated any related page-edit permissions, could I suggest that a note to this effect is included in the default title. I have amended the title on my system to read:
      Edit only pages user has created (IMPORTANT: This will negate any related page-edit permission - including permissions granted to a user by other roles) ..although it may be possible to make it briefer while not losing clarity and impact.
    • By lenoir
      Is it possible to let people edit a page without having to have a user-role?
      My case is the following:
      Visitors fill in a form (Formbuilder) which is saved to pages. They get a confirmation email which could contain a unique editing link. In case they need to update some information, they can click on this link, edit the fields and save. 
      Am I totally off? Is there a better practice? 
    • By DV-JF
      Hi, 
      I'm using this kind of setup (https://processwire.com/blog/posts/language-access-control-and-more-special-permissions/#language-page-edit-permissions) in order to control the page edit permissions. Now I'm wondering if it's possible to hide the "none-ediable" language-tabs instead of striking them through.

      Many greets...
       
×
×
  • Create New...