Jump to content

Moving site to another server


Recommended Posts

Hello all,

I seem to be having trouble moving a site to new hosting / domain.

Just getting a 500 internal error. I have tried the following.

1. Commenting out .he access lines.

2. Installed the site onto another domain and different hosting with worked fine.

3. Install a new copy of pw onto the domain and hosting in question which worked.

Iam not really getting any other error massages to just wondering if anyone has had something similar.

Iam using processwire3

Link to comment
Share on other sites

Sorry you are having problems.  

Please review and go through the informative Troubleshooting Guide tutorial.


Here is information for the ProcessWire 3.x Version


Hopefully these 2 links will provide some help to you.

  • Like 1
Link to comment
Share on other sites

Hi Jon,

Actually a 500 internal server error is a very classical one and in many cases related to the .htaccess

? uncomment # RewriteBase /

? Options -Indexes
? Options +FollowSymLinks

? a module that needs to be updated.

? bad database connection

Always do a new fresh install of processwire on the new host. This will tell you first hand if the .htaccess

and the settings on the new host match up. Second replace your site folder with the one on the new host,

but leave the config.php. Only replace the user salt in the config.php.

Normally everything works at this stage but sometimes you have to empty out cache and sessions

in /site/assets/cache/ and /site/assets/sessions/, or simply have to set the right php version on the host.

If things still don't work set $config->debug = true; check your site/assets/logs/errors.txt, apache error logs.

  • Like 2
Link to comment
Share on other sites

Hello guys thanks for the response, I did reply to this yesterday but must have forgot to post it doh!

I managed to get the site working after following pwired advice and replacing the site directory, debug worked. Which showed a problem with the AssistedURL field type module. So I updated that and seemed to work.

Which was a bit of odd one as the site worked when I tested it on another server and domain. Maybe something server related.

SteveB iam using php5.5

The site is http://redmooncruises.co.uk if anyone's interested. Still got a few things to tidy up.



  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...