gebeer

SOLVED - Hybrid App Developer wanted

2 posts in this topic

Hello everyone,

for a project that is utilizing ProcessWire as a web frontend and REST API backend, we are looking for a hybrid app developer.

ATM our client has native Android and iOS apps that exchange data trough a REST API with the ProcessWire web app and then display that data on the mobile clients. We are looking into possibilities of dropping the native apps and working with a hybrid app instead. 

The project is long term. The web frontend and REST API is already up and running, though at an early stage. 

I can't get further into details here. Please PM me if you are interested and I will share more details. Thank you.

Share this post


Link to post
Share on other sites

@Jim_Chapman Thanks for posting here. In the meantime my client has decided to go with native apps and we already have developers for the project.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kixe
      Today I have been running in mysql errors using @renobird s Module MarkupActivityLog which still uses mysqli Driver.
      @all developers
      Although mysqli is still supported PDO driver is the default database driver in PW since https://processwire.com/about/news/introducing-processwire-2.4/
      and its strongly recommend to all module authors to use/change-to PDO driver instead of mysqli.

      @renobird I have sent a pull request.
       
    • By danielsl
      latest development version tryed adding url_link field (URL) unfortunately experience this error
       
      Session: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'expo_ch.field_url_link' doesn't exist trued recover db and add field again, every time same result
      any ideas how to create url link and add it to a repeater
      ui Session: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'expo_ch.field_url_link' doesn't exist
      SQLSTATE[42S02]: Base table or view not found
      SQLSTATE[42S02]: Base table or view not found
    • By Cole
      Long time listener, first time caller...

      I have been working with ProcessWire for some time now and it has been amazing, my go to CMS. Previously my workflow had a local development setup through MAMP using an address like http://localhost:8888/websites/example.com.
      I have recently changed this in preference of  http://dev.example.com, that way I do not need to disable the .htaccess forward from non-www to www to develop locally. My .htaccess forward is setup like:

        RewriteCond %{HTTP_HOST} !^dev\. [NC]
        RewriteCond %{HTTP_HOST} !^www\. [NC]
        RewriteRule ^ http://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
      This works on all sites that are still using ProcessWire 2.5, however on sites using 2.8 and 3.0 I am getting a 403 Forbidden error. After reading through the forum posts related to 403 errors I have not been successful in finding a solution for my issue. Has anyone experienced this or can assist? Thank you very much in advance, the forum community has been so helpful I have never needed to post until now.
    • By thlinna
      I am running development server where I test and try the changes in fields and templates of ProcessWire. The php files are stored in git@bitbucket. 
      The part of managing changes and versions of php code itself via git is quite straightforward, as I presume we all know. However, I have not been able to come up with decent way of moving the changes in fields, templates, modules and settings from development to production other than repeating them, step-by-step, manually in production environment via the admin back-end.
      Perhaps there is more sophisticated way of transferring these changes?
    • By Harmen
      Hi there,
       
      I am writing a module for people who want to import their products from the prestashop database to a new PW website. But if the database of the customer has another prefix then my database, they can't run the code or their needs to be a possibillity to input their own prefix. So I've added a field where you can input the prefix for the database, but then that inputted prefix needs to be set in the query. I tried the following: 
      $categories = $prestashop->prepare(" SELECT .... ..... FROM :prefix_category c etc etc and then in the function to import the categories:
      $prefix = $this->session->dbPrefix; $categories = $this->get_category(); $categories->execute(array(':prefix'=>$prefix)); $categories->fetchAll(PDO::FETCH_ASSOC); But if I run the code, I get the following error:
      ImportPagesPrestashop: SQLSTATE[HY093]: Invalid parameter number: number of bound variables does not match number of tokens
      Does anyone have an idea how to solve this? Is it possible to make this changeable or should the customers change their prefix to the same prefix as mine?
      I hope someone has an idea....
       
      (Sorry if you don't understand it. English isn't my native language).