Jump to content

lecrackffm

Members
  • Content Count

    47
  • Joined

  • Last visited

Community Reputation

36 Excellent

About lecrackffm

  • Rank
    Jr. Member

Contact Methods

  • Website URL
    webgestaltung.net

Profile Information

  • Location
    Germany

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. yep, took me about three hours from tracing to solution.. i thought an IDE like phpstorm would be at least sophisticated enough to inform me about these little suckers.. 🙂 Lesson learned anyways. Nice weekend to everyone!
  2. @flydev thanks. i reopend all files with Sublimetext 3.. found nothing. Then i begun to open all files with VSC.. and there i finally found �������� behind the <html> tag. I have no clue how they ended up there nor what funky encoding they are, but deleting them finally solved my problem.
  3. Hey all, i do, most probably have a problem with file encoding and / or BOM. My <head> content is getting moved into <body> and i can inspect a couple of &#65279; ( ZERO WIDTH NO-BREAK SPACE) chars with dev tools. I checked all template files with phpstorm, they are all in utf-8 w/o BOM. The current installation is based on a profile i exported from another project where i had not such problems. However, in the new project i did change the default language to german and installed english as the second language. Might there be any conflicts with the language support modules? Hints, tips or solutions are highly appreciated 🙂
  4. Ah. Finally got it!! It was indeed a permission. Stupid me removed the permission to view the "gallery-ratio" field on the live system.. Damn, this took me hours to find out.. but anyways. Have an nice weekend 🙂
  5. @wbmnfktr sure, here is the code. <?php $items = page()->repeater_home_gallery; ?> <?php foreach ($items as $i): $ratio = $i->gallery_ratio->title; switch ($ratio) { case "portrait": $w_l = 494; $h_l = 618; break; case "quad": $w_l = 494; $h_l = 494; break; case "normal": $w_l = 494; $h_l = 330; break; } $image = $i->image_single->size($w_l, $h_l)->url; ?> <img class="uk-width" src="<?= $image ?>" > <?php endforeach; ?> What grinds my gears is that it works on localhost..
  6. Hi everyone, currently im developing a photographer portfolio-website. Since i deployed it to a live server the API creates a 0x0 version of the each image, which are then correctly downloaded by the browser. (Instead of the appropriate image, specified in the CSS) However, this only happens for guests and other Users (non-superusers). Oddly, this only happens on the homepage. On all other pages, the Images are loaded correctly. I already checked the permissions in processwire and on the server. Afaik they are all correct, allthough i am not the biggest expert in that regard. Any help / ideas are highly appreciated 🙂
  7. This looks very nice @Noel Boss, is there a way to support repeater fields? EDIT: Sorry for my silly question, found it in your docs. This works for me: $query = ['repeater' => function($page){ return array_column($page->get('repeater')->each(['key', 'body']), 'body', 'key');
  8. Happy to announce that i just gave birth to another Processwire Website. 🙂 This one has an event calendar, which was easy to build with Processwire. bridgesmusikverbindet.de
  9. I am happy to present you the first processwire powered page i made for a client. Some more in the pipeline, but on hold because of missing content on the client side Big thanks to this helpful and great community!! https://feuerwehr-gimbsheim.de/ my own site webgestaltung.net is online for a while already, but not holding much content yet.
  10. I switched to ampps and now its working. But im still interested why installation fails with MAMP Thanks
  11. Hello, since yesterday i am not able to make any new PW installs. The Installer stops where it should delete unused files etc.. MAMP with PHP 7.1.12 I switched on Test Mode: warning: Cannot modify header information - headers already sent by (output started at /Users/**/**/**/**/wire/modules/AdminTheme/AdminThemeUikit/install-head.inc:8) in /Users/**/**/**/**/index.php on line 41 Can anyone help? Thanks EDIT: using wireshell i am able to make fresh installs.
  12. Thank you. ill give your strategy explained above combined with asmSelect a shot
  13. Thanks for your Input. The duties are "free-form" i.E i have no idea what kind of Duties, and Ranks are going to be set later.
  14. Hello, after working with PW for a while, im still unsure sometimes, how to structure certain Data. In this case it is a List of Members. Each Member consists of his name and a list of his duties. In the template file i need separate access to the name and the duties I was thinking about a Repeater Matrix with one textfield for the Membername, and a textarea with newline to UL for the duties? What do you suggest how to structure the Data in the PW template ? Is there a better way? Tips and suggestions more then welcome. Thanks
×
×
  • Create New...