Jump to content

Erik

Members
  • Posts

    42
  • Joined

  • Last visited

Recent Profile Visitors

728 profile views

Erik's Achievements

Jr. Member

Jr. Member (3/6)

9

Reputation

  1. That was the solution. Thanks.
  2. When I try to install this module i get this error.
  3. @elabx I studied PHP this weekend. As a result, I am starting to understand more and more of your code. I'm not quite there yet.
  4. Thanks for this example @elabx. I made my own version with checkboxes (multiselect). Only then did I come across the following problem. When I check 2 checkboxes in the same group, For example: Color = Red and Color = Green then only the products with the field green are displayed. After submit this what my url looks like: domain.com/?color=red&color=green I think it's too hard for me on a Friday 😉
  5. Thanks @elabx, I've used your example and I'm starting to get it. But what does your code look like if there is a second choice next to "color" in the search form? For example: size
  6. I have already made many (simple) Processwire websites, but never with this functionality. I have studied this example for an hour, but I think my knowledge of PHP is now lacking.
  7. Okay, I understand. But how do you filter on the front-end? I installed the skyscraper demo (https://demo.processwire.com/) to see how it works but find it too complex for what I want. Are there any other examples?
  8. That's what I'm looking for. Can you roughly indicate how you have set up this website in Processwire?
  9. I want to build a product catalog where products can be filtered by 5 attributes. It must be possible to filter on multiple attributes. e.g. size, weight. Now I am looking for the simplest way to do this in Processwire. Who will help me on my way?
  10. When I install the module MaintenanceMode then I get this error message: Breaking news… Fatal Error: Uncaught Error: Access to undeclared static property: MaintenanceMode::$fM in site/modules/MaintenanceMode/MaintenanceMode.module:94 #0 [internal function]: MaintenanceMode::getModuleConfigInputfields(Array) #1 wire/core/Modules.php (3903): call_user_func(Array, Array) #2 wire/core/Wire.php (400): Modules->___getModuleConfigInputfields('MaintenanceMode', Object(InputfieldForm)) #3 wire/core/WireHooks.php (823): Wire->_callMethod('___getModuleCon...', Array) #4 wire/core/Wire.php (465): WireHooks->runHooks(Object(Modules), 'getModuleConfig...', Array) #5 wire/modules/Process/ProcessModule/ProcessModule.module (1349): P (line 94 of site/modules/MaintenanceMode/MaintenanceMode.module) What can I do?
  11. When I want to make a link in a template to, for example, the contact form on a bilingual (Dutch and English) website. What does this link look like so that it goes to the currently active language contact form?
  12. I did try the "Profields Table" but there is no way to have a "File"column. In need it for the PDF file.
  13. I want to build a searchable database like this in Processwire. https://decon.se/en/adapters/ Now I'm looking for a way to structure this in the backend. I started to make a structure like this with pages: Adapters->E-drive->Alu Rhab->Netti I (but maybe it's to complex beacause of repeating brand names in the categories.) Is there a better way with help of tables or repeaters maybe.?
  14. I installed this module in version 3.0.123 but i gives me a error: Fatal Error: Uncaught Error: Access to undeclared static property: MaintenanceMode::$fM in /xxx/xxx/xxx/public_html/site/modules/MaintenanceMode/MaintenanceMode.module:94 Stack trace: #0 [internal function]: MaintenanceMode::getModuleConfigInputfields(Array) #1 /home/xxxxk/domains/xxxxx.nl/public_html/wire/core/Modules.php(3885): call_user_func(Array, Array) #2 /home/xxxxk/domains/xxxxx.nl/public_html/wire/core/Wire.php(386): ProcessWire\Modules->___getModuleConfigInputfields('MaintenanceMode', Object(ProcessWire\InputfieldForm)) #3 /home/xxxxk/domains/xxxxx.nl/public_html/wire/core/WireHooks.php(723): ProcessWire\Wire->_callMethod('___getModuleCon...', Array) #4 /home/xxxxk/domains/xxxxx.nl/public_html/wire/core/Wire.php(442): ProcessWire\WireHooks->runHooks(Object(ProcessWire\Modules), 'getModuleConfig...', Array) #5 /home/xxxxk/domains/xxxxx.nl/public_html/wire/modules/Process/ProcessModule/ProcessModule.module(1255): ProcessWire\Wire->__call('getMo (line 94 of /home/devhk/domains/hk2.witxl.nl/public_html/site/modules/MaintenanceMode/MaintenanceMode.module) What is wrong?
×
×
  • Create New...