Jump to content

[solved] iconv() in sanitizer.php error during module installation


Recommended Posts

Hey guys,

I realise this is related to a module so it should be in the other forum, however I did post it there as part of the "Module: Blog" thread but maybe it was hidden too deep so support is a little slow (waiting 3 days on last reply).

However I also see $sanitizer as part of the API, I'm not sure if that's related to sanitizer.php but in case this is a general issue I'm trying my luck here as well.

Anyone with good ProcessWire knowledge / PHP / sanitizer.php know what's going on here?

During installation of the Blog module, I'm also installing the preview blog so I imagine a bunch of posts, categories, content is being created. Part of that is where this error occurs. It seems to be related to creating a new post and some interaction with sanitizer.php

Any help would be soooo appreciated!

Screen Shot 2017-10-28 at 8.58.49 pm.png

Link to comment
Share on other sites

2 hours ago, bot19 said:

but maybe it was hidden too deep so support is a little slow (waiting 3 days on last reply).

Sorry, I've been a bit busy. It has nothing to do with hidden too deep. In fact, it is not hidden. I follow the topic and am also aware of unread posts :).

What @matjazp said. I don't know how I missed that error. Check if that resolves your error. This thread in an external forum suggests that AMPPS has iconv disabled by default. So, you'll need to enable it.

ProcessWire requires iconv support to work; did it not throw an error when you installed it?

Edited by kongondo
  • Thanks 1
Link to comment
Share on other sites

Hey guys,

I switched on iconv and it worked!!! (after using the blog cleaner to clean previous failed installation and then running install wizard again).

Actually, I've had a couple of errors like this on this website also and they were all related to turning on some PHP modules (including GD for image uploads).

Thanks so much @matjazp!! I've been stuck on this for days!

@kongondo PW installation didn't  throw any errors for this. What I meant about it being hidden too deep was that it was under the "Module: blog" thread so people not intending to interact with the module wouldn't see the issue as there's no indication of it unless you click into the thread. The issue seem kind of general so I thought other people could help :D thanks so much for your help as well!

I'll link this to the other thread as well for future reference.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...