Jump to content

Crssp

Members
  • Content Count

    70
  • Joined

  • Last visited

Community Reputation

11 Good

About Crssp

  • Rank
    Full Member

Profile Information

  • Gender
    Not Telling
  1. I started looking at other solutions as well, for creating custom packages, so far nothing solid. My angle on this would be a solution for me to run on my shared hosting, so I don't have access to server level scripts. For one click installers it sort of depends what your host offers. As far as finding your own custom installers for shared hosting especially, nothing to report. Learning your way around the Processwire Site Profile setups, is probably time well spent. Customizing a Softaculous installer looks to be very in-depth, read not so easy. http://www.softaculous.com/docs/Making_Custom_Package
  2. It looks like I've found an answer for switching 'Site Profiles', at least for the Foundation Site Profile: http://modules.processwire.com/modules/foundation-site-profile/ Part way down the page in the instructions where it has, starting with an already installed copy. Not sure the would the process be the same for most all of the site profiles, or different in each case? Thanks. -------------- If starting with an already-installed copy of ProcessWire Replace the /site/templates/ directory with the templates directory from this profile. Add the following two lines to your /site/config.php file: $config->prependTemplateFile = '_init.php'; $config->appendTemplateFile = '_main.php';
  3. Hi All, just noticed Softaculous now has a 1-click installer for Processwire: https://www.softaculous.com/apps/cms/ProcessWire Hoping to discuss a few points, maybe write up a tutorial, if I get something up and running as far as demo sites. Site Profiles: can I easily toss in a site profile after the softaculous installer installs whatever is the default site? Big thank you's to whoever got this over there to them, my web host is Asmallorange, so will let you know how the installer works there, once I've had a chance to run it.
  4. Sweet success... It loaded up, the install page at the localhost root. Now to try a few sub-folder installs Thanks soma! Quick question are time-outs ever a problem if on a slow connection? Looks like the default time out is maybe only 60 seconds for the download to happen? This could also necessitate changes to one's INI file, or checking with your host if it's a hosted server environment.? Oops looks like timeouts were covered earlier in the thread, and those involve several places that may need timeouts changed. Where Soma mentions the scripts is set to 120 sec. Thanks again.
  5. I think I got it, lin 1009 of the php.ini is commented out: ;extension=php_openssl.dll I'm assuming, that line beginning with the ; means it's commented out. Was unaware of that commenting method, so here's a link to the parsing the INI file for php: http://php.net/manual/en/function.parse-ini-file.php Attempting to rerun then here in a few. thanks, again. [Hint: Don't forget to restart your xampp server, after making the php,ini file change, found at xampp/php/php.ini]
  6. Does it sound like I need to make changes to my Xampp PHP directory 'php.ini'... If so I'm unsure of what changes would need to be made. thanks. Ooops sorry guys this one crossed the wires with the replies above... thanks for the help. I'll look at the suggested resources then, and get back.
  7. Tried running this install script on a local Xampp setup. I got this error message: Warning: file_get_contents(http://grab.pw): failed to open stream: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP? in C:\xampp\htdocs\grabpw.php on line 74 File could not be downloaded http://grab.pw I've not made any changes to the file, so far... I had another wordpress install script, and it was working, I grabbed a fresh copy of Xampp, and those were not running now either, maybe my Xampp setup is having issues. The wordpress installer sets up the db and everything, that is where it is now failing. nevermind about the wp stuff of course Going to line 74 now, any suggestions appreciated. [edit]: If I can get this running, how do I install to a sub-folder, does the script install right in the folder where it resides. so if it were in the HTdocs root folder, it would be a root install then? Plus just to double check, I'll need to manually create the db first, I'm thinking?
  8. Exactly my thoughts Ryan, it's sort of a comparison, MODX did it this way, and with PW we can do it that way. It's sort of a roadmap from Point A to Point B for both systems, just follow the learning curve.
  9. Are the mentioned Examples & Demo hosted live someplace? They don't seem to be linked to anything. Looks awesome!
  10. Yep, thought it was something like that. I frequent all the wrong places, and occasionally a right one. Even though it's a left turn on a red light usually, lol.
  11. @BillyKochMoved over from??? I'm sure I missed something in the translation? Maybe I need subtitles.
  12. I'm seeing some menu errors on inside pages on an iphone device at uodance. Anybody on board to report bugs for that one?
  13. @apeisa's pick of WINscp was spot on! Should work with Brackets or notepad++ specified as the editor, yet to try it though. Here's a help article on adding an editor: http://elementdesignllc.com/2009/09/notepad-ftp-winscp/ Cool•ness
  14. Thanks Teppo, was about to download the whopping 130 mb Aptana, I'm holding off and trying Brackets also. It's only 22mb, not saying Aptana would be worth it. Here's the latest Youtube preview. https://youtu.be/VKitqLpJtAY The inline live editing features look just 'too smooth' more later then. With me it's all about a learning curve, rocking some templates is the first thing. One big-ish caveat, no ftp, so needs an ftp syncing option, lol. oopsie.
  15. Anyone tried Brackets, Adobe open-source project editor? http://download.brackets.io/
×
×
  • Create New...