Jump to content

bee8bit

Members
  • Posts

    12
  • Joined

  • Last visited

Recent Profile Visitors

1,122 profile views

bee8bit's Achievements

Jr. Member

Jr. Member (3/6)

4

Reputation

  1. Oh, this looks good. I have to take some time to read this. Would be good if http://cheatsheet.processwire.com/ had a hint.
  2. Thank you, Adam! Right, nothing in the logs. ProcessWire is not seeing that TFA is enabled, because I'm not using ProcessWire's own login form but the API. We could ask Ryan if he just overlooked this or if there is reasoning for keeping $session->login() open without the second factor. Version is 3.0.123. Martin
  3. Ah, same problem with other 2FA modules. And probably the answer: I am using a custom login form and $session->login(). This seems to circumvent any second factor! Now i have to research if there is any way to trigger two-factor authentication from the api.
  4. Hmm, there's something odd here: I have installed this module, used the admin account to modify a less-privileged account (changed tfa_type, added a security key). Then I tried to log in as that user ... and was logged in without that second factor. No need to press my hardware button, even worked with the security key plugged out. Does this possibly depend on another module which enables 2FA before login is dispatched to your module? Thank you for you effort. I'm really looking forward to using my FIDO for ProcessWire.
  5. Hi tires, I think this may be related to a problem I had earlier: So, you might have to find a way (event, interval, ...) to trigger that init() when your maps becomes visible.
  6. Hi! I'm using MarkupRegions and it works great. But when I try to render a user page (as in /admin/access/users/my-user/) the template file user.php is rendered without MarkupRegions. PrependFiles and AppendFiles seem to be ignored, no matter if configured globally or on the template level. Is this because user is a system template? I couldn't find any special treatment in the sources yet. Or is it a bad idea™ to make these pages accessible?
  7. Hi, this module throws an error when I create a new page. Call to a member function getLanguageValue() on a non-object (Zeile 121 in /var/www/_html_default/processwire-playground/site/modules/ProcessSetupPageName/ProcessSetupPageName.module) My name format for children is "date(Y/m/d) title", LanguageSupport is installed but the title field has the type PageName, not PageNameLanguage. In this case, $page->title is a plain string, so this seems to work for me: // case 2: title default else if ($format == 'title') { if(is_object($page->title) && strlen($page->title->getLanguageValue($languageID))) { $pageName .= '-'.$page->title->getLanguageValue($languageID); } else { $pageName .= '-'.$page->title; } } Further investigation might be necessary: Can $page->title->getLanguageValue(...) be an empty string?
  8. @adrian Thank you, that was not the right solution. But it made me investigate in the right place: InputfieldMapMarker's init function is never called. At the bottom, InputfieldMapMarker.js says: $(document).ready(function() { $(".InputfieldMapMarkerMap").each(function() { var $t = $(this); InputfieldMapMarker.init($t.attr('id'), $t.attr('data-lat'), $t.attr('data-lng'), $t.attr('data-zoom'), $t.attr('data-type')); }); }); When the $(document) is ready() there are no $(".InputfieldMapMarkerMap")s yet, as they will be AJAX-loaded later. So I guess we need an event that is fired after each successful AJAX call, so we can InputfieldMapMarker.init() all those Maps which haven't been initialized before. Is there a way to register a listener for such events?
  9. Hmm, I'd like to use many of these in a repeater. Or actually, 2 levels deep: MapMarker in a repeater in a repeater. (Think a travel journal with 2 or 3 locations for 14 days) The MapMarker Map is only displayed in the editor when the inputs are expanded upon load. When I collapse one repeater or another (visibility or AJAX) then the map stays empty. This means my editor will be confusing, very long and creating new entries will require saving. Is there an easy way to fix this? Thanks Martin
  10. Hi Davabo, the problem seems to be your generated HTML code, not the PHP code. You need to create one single select with a dynamic list of options. Try this: <select id="colour"> <option value="-" selected="selected" disabled="disabled">Select Colour</option> <?php foreach($page->colour as $colour): ?> <option value="<?= $colour->colourtext ?>"><?= $colour->colourtext ?></option> <?php endforeach; ?> </select>
  11. Thank you for your great CMS! I have a litte issue that is related to the FileCompiler (in version 3.0.17, actually): One of my templates contains the line <?php include('asides/_comments.php') ?> This is compiled to <?php include(\ProcessWire\wire('files')->compile('asides/_comments.php') ,array('includes'=>true,'namespace'=>true,'modules'=>true,'skipIfNamespace'=>true))?> which gives me a Parse Error: syntax error, unexpected ',' (line 71 of [...]/site/assets/cache/FileCompiler/site/templates/post.php) Setting $config->templateCompile = false; helps - but I suppose this is not the way you meant it to be. I have seen https://processwire.com/api/ref/wirefiletools/compile-include/ Are you trying to compile include() in my templates to $wireFileTools->compileInclude() or do you expect me to use compileInclude() myself?
  12. Hi! I have a PageTable which may contain pages with different templates that have different fields. The only common field is 'title' but I'd like to show some more useful information. Template A { (PageTitle) title, (Integer) number_one, (Integer) number_two } Template B { (PageTitle) title, (Textarea) body } I found the Cache fieldtype which can combine multiple fields. So I created a cache field named 'summary' and combined number_one, number_two and body. I configured my PageTable to show the columns 'title' and 'summary' and was expecting something similar to this: | title | summary | +------------+-------------------------------------------+ | page_a | number_one: 11, number_two: 22 | | page_b | body: (text goes here ...) | +------------+-------------------------------------------+ It seems to me that PageTable does not like Cache columns. When I try to edit a page with that PageTable, it crashes: Error: Call to a member function attr() on a non-object (line 345 of /var/www/(...)/wire/modules/Inputfield/InputfieldPageTable/InputfieldPageTable.module) Is there a different approach for heterogeneous PageTables? A different syntax to define the columns for PageTable? Thanks for pointers - or a patch ;-) Martin
×
×
  • Create New...