Jump to content

Jennifer Stock

Members
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Jennifer Stock

  • Rank
    Jr. Member

Recent Profile Visitors

878 profile views
  1. Hi. Sometimes when I select text in a textarea field outfitted with CK Editor, it fails to register as a "Block Style" and therefore the custom styles I have specified for block-level elements are not displayed in the Styles drop-down menu. If I open the page in an incognito window and select the same elements, the Block Style styles appear as expected in the Styles menu. Is this a caching issue of some kind? I've played with turning on and off the HTML "quality assurance" options as well as putting my custom styles directly within the CKEditor folder in the /wire directory. Once the field stops registering the selection of block-level elements, it also seems to have simultaneously stripped the custom styles that had been successfully applied to these block-level elements previously. Not sure what to do next.
  2. Hi. I have a template which allows users to specify a redirect. It contains two fields: one is a URL field for off-site redirects, and the other is a Page Reference field that points to the top of the site tree for selecting internal pages. What I'm wondering is: once I have selected an internal page via the Page Reference field, how can I get it to go back to its initial "Choose..." state? I'm using the "Page List Select" input field type.
  3. Hi. I'm wondering if there is a way to add code to the module to strip the "?fbclid=" parameter from incoming links. My users have noticed that the redirect links they have established via the module are failing when used from Facebook, due to the new FB click tracking code.
  4. Hi. I'm wondering if there is a way to add code to the Redirects module to strip the "?fbclid=" parameter from incoming links. My users have noticed that the redirect links they have established via the module are failing when used from Facebook, due to the new FB click tracking code.
  5. Greetings. I would like to restrict access to certain sections of my organization's ProcessWire site using pubcookie. We are rolling out Shibboleth authentication later this year but for now, it seems I can only make use of our institution's single sign-on routine by utilizing rules in an .htaccess file. I am wondering if there is a way to ask PW to apply these rules to certain pages in the site, whether via template type or location in the page tree: AuthType UWNetID PubcookieAppID "MyApplication" require type staff faculty
  6. Looks like I'm talking about something like this.
  7. I'm building a site where I have "topics" and "programs" as sibling parent elements in the page tree. Each contains about sixty sub-pages. I want the user to associate them with each other from both the topic template or the program template. I can give the template for each type of content a field that selects from its opposing collection of sibling elements; what I'm wondering if there is a way to make them match up, so that selecting from one "direction" will make the association "show up" from the other "direction." Happy to explain again if that doesn't make sense.
  8. Hi. I just tried to add the style set to another input field that has the CKEditor enabled and it is successfully reading my custom styles. Is there something special about the "body" field vis-a-vis custom styles + CKEditor? J It's working now for the body field too. I guess I was experiencing a caching effect.
  9. I am having trouble getting the CKEditor to include a custom style set. I put this in the Custom EditorJS Styles Set input box for the body field (Context: None(default)): mystyles:/site/templates/styles/mystyles.js That file reads like this: CKEDITOR.stylesSet.add( 'mystyles', [ { name: 'Inline Codex', element: 'code' }, { name: 'Inline Quotation', element: 'q' }, { name: 'Button', element: 'a', attributes: { 'class': 'uw-btn' } }, { name: 'Left Aligned Photo', element: 'img', attributes: { 'class': 'align_left' } }, { name: 'Right Aligned Photo', element: 'img', attributes: { 'class': 'align_right' } }, { name: 'Centered Photo', element: 'img', attributes: { 'class': 'align_center' } }, { name: 'Small', element: 'small' }, { name: 'Deleted Text', element: 'del' }, { name: 'Inserted Text', element: 'ins' }, { name: 'Cited Noodle Work', element: 'cite' } ] ); I've checked everything multiple times and I can't figure out what I'm doing wrong. Thanks, Jenn
×
×
  • Create New...