hheyne

Database connect 1und1 dbxxx.db.1and1.com failed

Recommended Posts

Hello, I want to install pw 2.5.29dev on a 1and1 server. The installations goes into 

Database connection information did not work.

and also 

SQLSTATE[HY000] [1045] Access denied for user 'dboxxxx'@'xxx.xxx.xxx.xxx' (using password: YES)

I tried the parameters with adminer.php and everything works fine. Is there something to tweak in the install.php?

Thanks

Henning

P.S. I have databasename, username, password and servername. No unix-socket-connection.

Share this post


Link to post
Share on other sites

Try "dboxxxx'@'xxx.xxx.xxx.xxx:3306" or use the hostname of the MySql server instead of the IP address.

Share this post


Link to post
Share on other sites

Hi cstevensjr, I used the hostname. In the error message the hostname is translated to the IP. I tried it with the port behind the IP and also with the port behind the hostname. Both fails. If I try it with the IP it goes into „connection refused”.

Share this post


Link to post
Share on other sites

Please check with the hosting provider to ensure the user has all permissions/privelages in MySQL.

Share this post


Link to post
Share on other sites

It's a mass hoster. There are no specific rights for databases :-( I solved it now temporary with a database connection via Hetzner. So the site is now online and I have time to solve the problem.

Share this post


Link to post
Share on other sites

Hi Henning,

I had similar problems with 1&1 and fixed them by installing PW locally, then moving everything to the server (db via phpmyadmin), changing the config.php with the 1&1 db-credentials and finally adding the following line in the config:

$config->dbSocket = '/tmp/mysql5.sock';

Not sure where I found it, but worked for me :-)

  • Like 6

Share this post


Link to post
Share on other sites

Hi Robert,

thank you for your post. This is/was my plan b :-) I'll try it and wether if it works or not I will report the result so that others won't have such trouble.

Share this post


Link to post
Share on other sites

I had the same problem with iPage.

"Database connection information did not work."

and also 

"SQLSTATE[HY000] ..."

The fix was getting the correct hostname. What seems to work for iPage is this host (replace username with your iPage username):

username.ipagemysql.com

The port is 3306.

I asked my hosting service and they gave it to me right away.

Share this post


Link to post
Share on other sites

Today I found the time to move the database to 1und1. I found that the given password has two interesting characters: " and '

This was the problem. I simply escaped one of them in the config file. Never use passwords with " or '.

Now I have another problem. I will post it in a seperate thread.

Share this post


Link to post
Share on other sites

Please open a ticket with the hosting provider to resolve this configuration issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.